7 Replies Latest reply: Jan 8, 2013 9:58 AM by lrdooper
Kathy Bourassa Level 1 Level 1 (25 points)

I'm back.  Still no luck getting spell check to work.  With all the things I've tried, I'm sure it is now isolated to a operating system based problem.  The spell check on InDesign works, but mac mail, text edit, and Open Office.org which all access the OS based spelling function don't work.  Not only will they not do dynamic spelling, you can't highlight and tell any of these programs to check the spelling.  That doesn't work either. 

 

I am running 10.6.8 on an iMAC 27" that is three years old.  I have kept up with my updates as they have come available, and my 3 year warranty just ran out in Nov. this year.  I would like to figure out how to fix this without having to wipe the hard drive or anything else that is so radical it might take me days to restore all my functionality.

 

Any suggestions?  Run the utilities and repaired permissions, restarted holding down the shift, etc. and nothing has helped.

 

thanks,

Kathy


iMac, Mac OS X (10.6.8)
  • 1. Re: Spell Check in Mail not working
    lrdooper Level 1 Level 1 (0 points)

    Kathy, had same problem -- here is what I found just now by running tests:

     

    Ok, what is going on is that the preferences for spelling and grammar in word and mail seem not to be working…..

     

    in mail preferences there is no oportunity to set preference re spelling and grammar.  I can't find it in apple preferences either

     

    You have to do it manually --- so if mispelled words in EMAIL YOU GO TO EDIT, SPELLING AND GRAMMAR:

     

    if you check grammar with spelling -- all you get is red underline.

    if you CHECK  check before sending nothing happens

    If you check  ----check spelling and grammar (which seems to be the default)  nothing happens

    BUT IF YOU CHECK   show spelling and grammar, you get the red underline and correction box

     

     

     

     

    IN WORD, there is spelling preferences --- i chose : check spelling as type, suggest corrections, check grammar with spelling.

     

    IF I go back to check preferences, they are changed for example if i had chosen check spelling while typing, when i go back it is unchosen

     

    So with a document----- (before going back to preferences) ,only mispelled words are underlined red. BUT  if then you go to tools, spelling and grammar --- you get the box right away

     

     

    i did this research before checking directions on web  see    http://support.apple.com/kb/PH6911

    Which for me would take copying the article, double space, under key words  AND THEN MAYBE i could understand it --

    i have no idea if it correlates to actual testing above.

  • 2. Re: Spell Check in Mail not working
    Kathy Bourassa Level 1 Level 1 (25 points)

    Thanks for your suggestions, but none of this works for me. I have done all these tests, quit and restarted mail and the computer and everything.  Nothing works.  There is no spelling function at all.  No underlines under any command under spelling and grammar.  It always underlined in red, and now it never does that, and if I tell it to check, it doesn't show any of the misspelled words.  It's like it has just disconnected the OS spelling from the system.  It is also not there on the text edit program.

     

    Anyway, I have found my original system disks, so if anyone knows if you can just reinstall the system without having to erase the whole disk, please let me know.  I'm thnking that if I re-install the OS system 10.6.8 from the original disks, and then update, perhaps the spelling will be fixed.

  • 3. Re: Spell Check in Mail not working
    Klaus1 Level 8 Level 8 (44,505 points)

    Mail Preferences/Composing: what have you selected under Check Spelling?

  • 4. Re: Spell Check in Mail not working
    lrdooper Level 1 Level 1 (0 points)

    If you have CHECK SPELLING IN composing, all it does is underline mispelled words.   And you have to figure the right spelling.

     

    BUT, here is the exciting part... if you chose check spelling when i send, it offers you the box to change to their corrections and when you have gone through the message content -------,it sends it right then

     

    so you have no opportunity to doublecheck your message for content, spelling or to add new content

  • 5. Re: Spell Check in Mail not working
    Kathy Bourassa Level 1 Level 1 (25 points)

    It doesn't matter what I check or uncheck, no spelling or grammer is available.  Even whe I try choosing the Check spelling now, the box pops up and does not show any of the misspelled words.  No underlining in red, no nothing.  It also doesn't work in Text Edit program.  But Adobe InDesign which has it's own spelling function works fine.  When I open Openoffice.org and go to preferences it has a box for activating the OS spelling and when I do that, it too doesn't work, all of which is how I know it's the spelling function in the system software. 

  • 6. Re: Spell Check in Mail not working
    PaulWhite Level 1 Level 1 (20 points)

    I think I fixed it.

     

    I need spelling checking both in English and in German. It used to swap automatically depending on how a sentence began. Recently it stopped working.

     

    I can't remember where, but somewhere I think I switched on check grammar for British English. After that it didn't check either English or German or whatever correctly. Everything showed as wrong and was red underlined..

     

    To fix:

    Open a new mail

    Typed in some German ( but I am sure it works with any language).

    From the Mail Menu: edit / spelling and grammar / show spelling and grammer

     

    This opens a little window. At the bottom there is a drop-down where you can select the language, or as I did select automatic by Language.

     

    Voila it now checks both English and German the way it used to.

     

    -Paul-

    Hope this helps

  • 7. Re: Spell Check in Mail not working
    lrdooper Level 1 Level 1 (0 points)

    I just spoke to apple support

     

    in case you haven't gotten this

     

    MAIL - on an red underlined word click control and then click - the correction box comes up

     

    in word, select misspelled word, go to tools, select spelling and box comes up