2 Replies Latest reply: Jan 3, 2013 5:06 PM by cdocc11
cdocc11 Level 1 Level 1 (0 points)

i downloaded the newest version of itunes (itunes 11.0.) and when i plug in my ipod touch (just got for christmas) to my computer (computer doesnt recognize it either) a message pops up saying "itunes requires a newer version of Apple Mobile Device Support. Please Uninstall both itunes and apple mobile device support." Now i've done that...then it took me forever to reinstall itunes, and when it finally worked the message still pops up...so i tried uninstallaing/reinstalling just the AMDS and that didnt work....i even tried just updating the AMDS and it said the newest version is already installed on my computer (clearly its not)...any ideass??!?! i need helpp!!


iPod touch