Skip navigation

Printing to AppleTalk printer via Ethernet

8616 Views 32 Replies Latest reply: Jan 4, 2013 12:44 PM by Bob Weaver RSS
  • BADD Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 9, 2012 6:03 PM (in response to Bob Weaver)



    Are you suggesting IP addresses for the Macbook because everything else is working fine. I did however try the IP address rout eearlier in my quest with no luck.

  • BADD Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 9, 2012 6:18 PM (in response to Bob Weaver)

    Right. I have the JetDirect installed on the LaserJet 5m using the ethernet port.

  • BADD Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 9, 2012 6:27 PM (in response to Bob Weaver)

    Now when I try to print  I'm getting "On Hold" (Authentication required) with respect to the HP laserJet 5M

  • Harley Davidson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 2, 2012 8:59 PM (in response to Bob Weaver)

    Hey guys.  I've had problems with all kinds of print servers and printers.  Best bet:  Get a long cable and connect the printer to a desktop, even an extremely cheap one with a minimal OS and share it.


    This is an old trick, but works in case the ip-adresses change with any print server\computer setup:

    Get the host name of the Print Server (the network name; NetBios name; NetBOUI, etc).  When installing the printer, use the host name, then try setting up a CUPS compatible driver for the printer.  CUPS is a network compatible version of drivers.  If you can't find it, try using the native (the manufacturer's) driver, but there are no guarantees.  If this doesn't work, use generic postscript printer.  This usually works, and allows you to print.


    Using the Host Name (Network name etc) points your computer at the printer's name rather than an IP.  The next thing you should do is put in a DNS search domain that matches your primary router (the one that is your internet gateway); do this in network prefs, select advanced, and then click DNS and you can add an address on the right side.  Then put in a WINS server address by selecting that tab, using the same address you put in DNS.  THis will perform the check for internet and local domain services against those two locations (note: your primary router gateway's address doesn't change so using this ip is perfectly alright, and since it has to give out addresses or at least track them back in order to forward requests from the internet, using it as a dns even if it doesn't have a full DNS server, it'll still support a name lookup).  Now open the queue, and run a test print to the printer.  You should get a CUPS page, even using the native driver (most drivers use a native cups backend anyway, but build their own interface on top, so they access the stored test page image in the CUPS system).  IF you see the page clearly, your printer's installed, and you can shut down the whole kit and kaboodle (network, printer, computer) and it'll never lose the connection to the printer.  Why?  Because it asks your router where the printer is every time it links.


    If you still have trouble or the host-name is rejected, you may have to set up an internal domain name on your router, then use that domain name with the printer's host name.  EG 

    Make sure you check for this in your router.  Once finished, you can include the domain name in your DNS for your network.  All this allows you to utilize the routing tables and basic host-name functions to make sure your printer is always connected.


    Option 2 is to set the print server's ip to a static address inside your network.  It should say static instead of DHCP in the network options for BOOT method or "DHCP:" and it'll never change.  IF your driver doesn't come with a utility, and your print-server doesn't come with a link, you'll want to open it's web-page with that ip address and make sure to place a shortcut to it on your desktop.  If this page doesn't respond there's a problem.


    Hope this helps.

  • Harley Davidson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 2, 2012 9:03 PM (in response to Bob Weaver)

    by the way, if you can print the status page or setup page from the printer, it'll have the host-name to use when using jetdirect, and you can select that in the printer setup, use the hostname with default options for queue and then choose the CUPS print driver.  Make sure the top says hpJetdirect.  This will allow it to find the printer and print to it with native software options, it might even detect the proper driver for you.

  • Harley Davidson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2012 10:44 AM (in response to Bob Weaver)

    Glad to help.


    Many protocols have been outdated and dropped from newer OSes, so if you have trouble, I'm not sure but I think my email address is linked here somewhere.


    I've worked with old HP workhorse laser printers and macs for upwards of 10 years, and I've studied how they communicate.  Jetdirect should still be current.  IP printing can work over VPN quite easily, and LPR can work over ethernet using the hostname, but typically uses only a one way communcation with the old HP COM architecture (basically COM over ethernet;  much the same as serial to usb adapter does COM over usb).


    I may be a little disappointed with the latest apple blunders in their OS, but I'm also thrilled at the idea of troubleshooting it and finding a way to make it go.  Scanning over SANE might be useful if you could get it working, but printing will always be a standard funtion with multiple fallback methods.

  • Ocean 17 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jan 3, 2013 4:46 PM (in response to Bob Weaver)

    I had my Hewlett Packard 6MP running without problemt through the ethernet port of my old iMac.


    ethernet cable from ethernet port on iMac to Hewlett Packard JetDirect 300x.


    Parallel cable from JetDirect to 6MP.


    In the OS menu:


    click add printer.


    Click IP among the four selections of this window.


    enter the IP of your JetDirect (print a test page to see, but usually it's


    Enter Jet-Direct socket in the box below.


    Choose 6 MP printer driver.


    That worked.


    Now I'm on a retina MacBook Pro and still want to keep my 6 MP as its print quality is better than even a $ 1000 laser printer,and it has a lower per page cost, cartridges being at $ 25. And the low cost laser printer below $ 200 are junk (so I heard), breaking down all the time and have a high page cost.


    So I'd love to keep mine.


    The retina MacBook Pro has no ethernet port, so I got an ethernet/usb adapter from Plugable.


    That's where the problem starts. I think that adapter has a driver that's not working in OS X Mountain Lion.


    I'm going to return it and get the Apple Ethernet adapter.


    Let me know if you could connect your printer. The 6 MP is still a stellar printer . The fact that it has no market value doesn't mean to throw it out. Mine has a low 9000 page count....

  • Harley Davidson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 11:09 PM (in response to Ocean 17)

    I aplaud your ingenuity with that one, but remember, this question didn't pertain to standard ethernet capable devices.  The 6mp has a standard ethernet packet size and conforms to the standard.  Some needed a specific packet size, pre-amble signal, and byte-order.


    Once you get one connected, you might be able to update the firmware to make it compatible, if you can find somebody who rewrote the firmware.  Otherwise, older printers are usb only.


    You might have to use an old mac to connect them, then share the queue, and point your other computers at the computer that's sharing the printer using it's host-name to make sure you don't lose access to the printer if the ip address changes.

  • Ocean 17 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jan 3, 2013 11:48 PM (in response to Harley Davidson)

    Actually, the 6 MP does not have an usb port. Only an Apple talk port and a serial port.


    A true museums piece.


    But it once was a high end printer, very expensive, and is pretty much indestructible.


    My last chance is to get the Apple ethernet-usb adapter working. I guess I'll stand a higher chance as the Apple Ethernet adapter will have a proper driver in OS X. I don't care it's only 10/100 - don't need a high speed for the small file sizes the 6 MP is getting.

  • Ocean 17 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jan 4, 2013 12:28 AM (in response to Ocean 17)

    I just got my Hewlett-Packard 6MP to print under Mountain Lion.


    It's an excellent printer with top of the line print quality and I'm glad I can keep using it.


    Here it is how it works:


    You need a USB to ethernet adapter and a print server (like the Hewlett-Packard JetDirect 300x)


    The usb adapter is about $ 26.00, the print server should even be cheaper on ebay used.


    Connect the parallel cable from the printer to the print server.


    Connect the print server per ethernet cable to the computer's usb port using the usb adapter.


    Be sure to install the driver for the ethernet adapter should you not use the Apple version.


    Print a test page by pressing the test button on the print server. It will tell you the IP adress of the print server.


    Then go to the OS X system preferences - printing/scanning.


    Click add printer. There are four menu items on top. Click IP.


    Then enter the IP address of the server


    choose jet direct socket


    choose printer driver



    If it works, fine.


    In my case it didn't work.


    I went to the networking section of system preferences.


    There was the ethernet adapter listed as a device.


    For some reason it started to work when I changed the IP address of the ethernet adapter.


    Configure IPv4: switch it to "using DHCP with manual address."



    I chose an address that was the same in its first three numbers, and only made the fourth different. Maybe it worked because the ethernet adapter got an IP address so similar to the print server it was connecting to.


    and then the printer/print server chose its own subnet mask.



    Router, DNS Server, Search Domains fields remain empty.



    This worked in my case.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.