4 Replies Latest reply: Jan 4, 2013 5:31 AM by timmsky1
timmsky1 Level 1 Level 1 (0 points)

Trying to restore an ipod touch Gen4, tried everything, the usual checks have been carried out, latest version of iOS on my Mac, latest iTunes version, no USB conflicts, plugged directly into the Mac and yet every time I get the same message while trying to install the latest iOS for the iPod (currently running 4.3.1) - "The iPod "iPod Touch" could not be restored. This device isn't eligible for the requested build."

 

i checked online and the 4th Gen touch is eligible for iOS 6, but even if i could get it to 5 that would be fine.  I know it works as we have other 4th gen iPods running iOS 6.

 

Help, please!!


iPod touch, iOS 4.3.1
  • 1. Re: Not eligible for the requested build
    lllaass Level 10 Level 10 (142,190 points)

    This device is not eligible for the requested build (Also sometimes displayed as an "error 3194")

    1. Update to the latest version of iTunes. Mac OS X 10.5.8 (Leopard) users may need to download iTunes 10.6.3.
    2. Third-party security software or router security settings can also cause this issue. To resolve this, followTroubleshooting security software issues.
    3. Downgrading to a previous version of iOS is not supported. If you have installed software to performunauthorized modifications to your iOS device, that software may have redirected connections to the update server (gs.apple.com) within the Hosts file. Uninstall the unauthorized modification software from the computer.
    4. Edit out the "gs.apple.com" redirect from your hosts file, and then restart the computer for the host file changes to take affect. For steps to edit the Hosts file and allow iTunes to communicate with the update server, see iTunes: Troubleshooting iTunes Store on your computer, iPhone, iPad, or iPod—follow steps under the heading Blocked by configuration (Mac OS X / Windows) > Rebuild network information > The hosts file may also be blocking the iTunes Store. If you do not uninstall the unauthorized modification software prior to editing the hosts file, that software may automatically modify the hosts file again on restart.
    5. Avoid using an older or modified .ipsw file. Try moving the current .ipsw file (see Advanced Steps > Rename, move, or delete the iOS software file (.ipsw) below for file locations), or try restoring in a new user to ensure that iTunes downloads a new .ipsw.

    Note yo can only update or restore an iPod to the current iOS. For the 4G you can only go to 6.0.1

  • 2. Re: Not eligible for the requested build
    timmsky1 Level 1 Level 1 (0 points)

    Thanks lllaass, however this does not help with my issue - I am running an Intel Core i5 Mac 2.8GHz, therefore no anti-virus software, I already run the latest iTunes and iOS, and the iPod is a 4th Gen running 4.3.1 iOS.  Any other ideas please? Thanks!

  • 3. Re: Not eligible for the requested build
    lllaass Level 10 Level 10 (142,190 points)

    Are you trying to update to iOS 6.0.1?

    Are you using the Update/restore buttons in iTunes?

    Try deleting update file and try again downloading a new copy.

  • 4. Re: Not eligible for the requested build
    timmsky1 Level 1 Level 1 (0 points)

    Thanks again - I tried step 4 above and it worked.  I have 5 or 6 iPhones and iPods synced to my Mac and all were working apart from this one.  Adding the hash & space in front of the gs.apple.com scripts seemed to allow it to update to 6.0.1.

    I had another completely locked up 4th gen Ipod touch which hadn't worked for about a year but I got that one working by syncing it to another Mac and now that's all updated and running fine.

     

    Thanks again