Skip navigation

iphone 5 won't send mms

122054 Views 55 Replies Latest reply: Feb 14, 2014 9:51 AM by Quziesue RSS
  • Demonhunter315 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 10, 2012 5:04 PM (in response to Jablonski283)

    So the Onavo information started leading me down the right path. I had Onavo at one point, but deleted it. I had forgot that it installs a "profile" onto your phone. I found the only way to completly delete onavo was to follow these steps and delete the profile they installed.

    • Goto your iPhone's Settings -> General -> Profiles
    • Locate the Onavo profile
    • Tap 'Remove'

    If you EVER had Onavo installed you need to follow these steps!! Fixed it for me!! Hope it helps!!

  • Demonhunter315 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 10, 2012 5:06 PM (in response to geneeius)

    If you EVER had Onavo installed you need to follow these steps!! Fixed it for me!! Hope it helps!!

    • Goto your iPhone's Settings -> General -> Profiles
    • Locate the Onavo profile
    • Tap 'Remove'
  • Thurm33 Calculating status...
    Currently Being Moderated
    Dec 11, 2012 11:40 AM (in response to Demonhunter315)

    I have the same problem re: group MMS to anyone or pic messages to non-iPhone people.  None of these options on this thread worked for me. I have never had Onavo and don't even have a Profiles section in my Settings menu.  I went into Verizon and the guy reset my network settings and it didn't help either. He looked online (probably at some of these threads) and simply said that it must be an Apple issue that they'll need to work on.  The worst part is that I know I'll walk into the Apple store on my appointment time and they'll say that it is a carrier issue.  Although people say it's a carrier issue, I see these threads posted for Sprint, Verizon and AT&T. 


    There is a thread out there that says, for Verizon, to go to Settings>General>Reset and then click Erase All Content and Settings.  I'm hesitant to do this right now but may later today, after I write down everything I've downloaded and send my pictures somewhere else to retrieve them later. Someone else said they had success with just using Reset All Settings in the same menu, but I tried this and it did not work. 


    Hopefully it works because this is ridiculous.  First time iPhone buyer and I'm upset about this, even if it's not Apple's fault.

  • diesel vdub Level 7 Level 7 (20,675 points)
    Currently Being Moderated
    Dec 11, 2012 12:15 PM (in response to Thurm33)

    MMS and SMS are a carrier feature.

    It is a carrier issue.

     

    It may be a simple has having them reprovision the account for the correct features.  Try calling Verizon customer support and asking them to reprovision the account first.

  • AKcrab70 Calculating status...
    Currently Being Moderated
    Dec 17, 2012 6:31 PM (in response to geneeius)

    Disabling Onavo fixed the issue for me.

  • Thurm33 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 18, 2012 7:25 AM (in response to diesel vdub)

    diesel vdub is right, is a carrier issue.  Have yet to call Verizon but I do know now that I can send group messages as long as everyone is an iPhone user.  I will call Verizon and hopefully they can fix it without much trouble.  Thanks

  • DaleAtl Calculating status...
    Currently Being Moderated
    Jan 4, 2013 6:45 AM (in response to Jablonski283)

    I've read all the messages here...the problem is with the carrier, not Apple. If you have tried all the troubleshooting steps found in this forum and other places online with no success, you should now call your carrier. I called my carrier and picture messaging was blocked on my account. My account was recently turned over to a business account and I guess that’s where the change came. Have your carrier check to see if its block, and if its block you can have them enable it. BTW..my carrier is Verizon.

  • Edward_277 Calculating status...
    Currently Being Moderated
    Jan 10, 2013 11:41 PM (in response to Thurm33)

    Dude I have the same exact problem, I've spent several hours trying to find a solution but nothing. Yeah I tried that reset all setting but nope didn't work. I don't wanna erase all content though, if you do can you let me know if it works or not? Thanks :)

  • Thurm33 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 11, 2013 7:25 AM (in response to Edward_277)

    DaleAtl is right. It's definintely a carrier issue and not even the carrier's fault. I called Verizon and straightened everything out.


    Turns out, like DaleAtl, when my work took over my account they blocked MMS. Since I had MMS turned on in my settings, whenever I sent group messages (with 1+ non-iPhone user) it would try to send it as an MMS and therefore would have a deliver failure (because my account's MMS is deactivated).  If you don't have MMS activated on your account, then go into your settings and turn off MMS messages. That's what I did and now I can send group messages no matter what phone the message recepients have.  I still can't send or receive pic/video messages (i.e., MMS messages) from non-iPhone users but now I understand that it is because my account isn't set up with MMS activated. I'm going to try to convince my company to turn it on, it looks like it's an additional monthly charge (even though I have a data and text package).

     

    Simply user misunderstanding. Hopefully this clears it up for most of you. Calling Verizon and talking to their tech support team is how I realized that MMS was blocked, so I would check your account as well.

  • Icleaves Calculating status...
    Currently Being Moderated
    Jan 14, 2013 6:54 PM (in response to Jablonski283)

    Hello to all I have the same problem about a month ago my issue was that I can't send or receive picture messagin mms or send/receive group messaging.  I change my nano sim card in att about 3 times and the problems still won't solve.  But fortunately I found the root of the problem that is the backups from itunes I factory reset my iphone 5 and then starte as a new iphone in itunes and the problems was solved.  I know this because I realized a couple of test factory erasing the phone and then backing up with previous data and the problem again appeared.  So apparently the only solution is to factory erased your iphone and then stard like its a new dont back up with old data.  You wont lose any information as long as you save your contacts on Icloud.  Remember all of your apps are in the appstore.  I hope this works for all.

     

    I got on my settings mms messaging on and group messaging on to

     

    Message was edited by: Icleaves

  • Icleaves Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 14, 2013 6:58 PM (in response to diesel vdub)

    I don't think its a carrier issue I believe its a itunes bug

  • Kaka Dongguan Level 3 Level 3 (720 points)
    Currently Being Moderated
    Jan 14, 2013 9:18 PM (in response to Jablonski283)

    Hi Friend,

     

    You must set the Cellular Data according (Settings>>General>>Cellular>>Cellular Data). Contact your carrier for further information.

     

    Turn on Cellular Data, Roaming and 3G as well, even your carrier doesn't have 3G available.

     

    Hope it will be helpful

  • TylerMultiSax Calculating status...
    Currently Being Moderated
    Jan 15, 2013 1:07 PM (in response to Jablonski283)

    This thread saved me after a GREAT deal of frustration...the Onavo tip is what fixed mine. And yes, I had to go remove the Onavo Profile in Settings after deleting the App.

     

    I do not remember who offered it up...but many Big Thanks to you.

     

    I can now send/receive group MMS messages (not Imessage) and I can now send pictures to NON-Iphone users.   Yes I'm happy!

  • Rheindie Calculating status...
    Currently Being Moderated
    Jan 28, 2013 10:11 AM (in response to Jablonski283)
  • dougapple Calculating status...
    Currently Being Moderated
    Feb 12, 2013 1:41 PM (in response to Jablonski283)

    If you have LTE turned on, turn it off. That worked for me, partially, at least for group messaging. Went from "Group MMS" to "Group Message". I have Verizon.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.