Skip navigation

Screen flickering issue on the iMac Mid 2011

16545 Views 24 Replies Latest reply: Feb 4, 2014 12:03 PM by Cthulhu RSS
  • baltwo Level 9 Level 9 (59,160 points)
    Currently Being Moderated
    Dec 14, 2012 2:05 PM (in response to 3gs LS)

    Thanks for the elaboration. Good luck when returning to the store.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2
  • Cthulhu Level 1 Level 1 (60 points)
    Currently Being Moderated
    Jan 4, 2013 7:11 PM (in response to 3gs LS)

    It seems to me to be an electrical design flaw where some grounds are not isolated or something. Here is what I tried, and I would love to see if someone else can repeat my experience. To be clear:

     

    1. Plugged the display into a surge protector and used the display to power the MBP. Flickering was intolerable.
    2. Plugged the MBP into the wall, and plugged the display into the surge protector which was plugged into the wall. Some minor flicker.
    3. Plugged the MBP into a surge protector using its power adapter with the surge protector plugged into the wall, and plugged the display into a the wall. No flicker.

     

    I tried multiple types and brands of surge protectors with identical results. Basically, if the display is plugged into a line conditioner or surge protector, then it flickers. If I power the MBP with the display's connector, the flicker is even worse no matter how the display is powered. If I plug them both into the wall (and do not use the display to power the MBP), the flicker is gone.

     

    Isolate the power supplies, and let us know if that helps. I really hope it does, I really feel your pain 3gs LS.

  • killhippie Level 3 Level 3 (580 points)
    Currently Being Moderated
    Jan 5, 2013 12:16 AM (in response to 3gs LS)

    Contact Apple directly and explain whats happened, I would not put up with that. It helps to have before and after pics though but you may get lucky and get some help.

  • Slapera Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 5, 2013 2:34 AM (in response to 3gs LS)

    Fixed repairing permissions

  • teigur_1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 15, 2013 6:51 AM (in response to 3gs LS)

    Had the same problem on my 27" iMac but if you turn up the brightness a bit and take auto adjust off then it will stop. Or did for me.

  • mike sanders3 Level 1 Level 1 (25 points)
    Currently Being Moderated
    Feb 25, 2013 1:50 AM (in response to 3gs LS)

    My imac is 4 years old and the screen doesn't just flicker it goes completely dark with a flickering brightness in the top left corner, this continues for a maybe 20 seconds or so and then the screen settles down, it only occurs on waking up or booting up.

    Any ideas welcome.

  • jeaneen Level 1 Level 1 (5 points)
    Currently Being Moderated
    May 3, 2013 3:57 PM (in response to 3gs LS)

    Ok... just spoke with Apple.... I'm running a MacBook Pro (mid 2009) w/ an Acer (p221w) Monitor. Everything worked fine in Leapord and it was the main reason why I NEVER upgraded to Snow Leopard cause I had this problem then....

     

    Try changing the resolution...

     

    1. Apple Menu > System Preferences
    2. Gather windows if you must and choose your external monitor
    3. For Resolution select "Scaled" and choose a different resolution size. 1680 x 1050 flickers on my monitor but 1600 x 1000 w/ a refresh rate of 60 Hertz worked fine.

     

    Play around until you find the combo that works for you!

    Hope this helps!

     

    Message was edited by: jeaneen because typos suck ((shrugs))

  • Old Toad Level 10 Level 10 (113,235 points)
    Currently Being Moderated
    May 3, 2013 4:42 PM (in response to 3gs LS)

    Have you tried applying the latest Mt. Lion Update,  OS X Mountain Lion Update v10.8.3 (Combo)?

     

    OT

  • Cthulhu Level 1 Level 1 (60 points)
    Currently Being Moderated
    Feb 4, 2014 12:03 PM (in response to 3gs LS)

    Well, I know this is an older thread, but it still drives me crazy. For a few days I'll be fine, then it will flicker. Turning the brightness up basically burns my retinas even with glasses on, soooo....I thought I would post a rather odd workaround that is helping me.

     

    1. Make a big, completely black image about the size of your screen (or do a web search for "solid black" and download one). It does not need to be exact.
    2. Install Geektool from http://projects.tynsoe.org/en/geektool/
    3. Launch Geektool, and drag the image geeklet to your desktop
    4. Set the path of the image to be the background you made
    5. Set the opacity to about 33%
    6. Choose the "Stay on top" option
    7. Adjust the size and position as needed

     

    So all that basically leaves a semi-transparent image as an overlay to your screen, effectively dimming it. Now you can turn your brightness up and not fry your eyes with the brilliance of your 8 million lumens cinema display.

     

    It's obviously not ideal, but it seems to be working, and it's easy to disable as needed.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.