Skip navigation

MacBook Pro Retina Sound Issues

28298 Views 124 Replies Latest reply: Apr 2, 2014 11:26 PM by kfraser23 RSS
  • Mr.Techno Calculating status...
    Currently Being Moderated
    Dec 14, 2012 4:48 PM (in response to nordlund.e)

    I got mine with mountain lion already installed as well. The computer has been working like a charm ever since two days ago. I still have the problem with the sound. The issue occured after I updated OS X 10.8.1 to 10.8.2! What system does your computer run? Could it be a software issue with the 10.8.2 update maybe?

  • calabek Calculating status...
    Currently Being Moderated
    Dec 15, 2012 6:55 AM (in response to pyemcg)

    You are right. This situation - as would Apple said occurs only on the integrated graphics.

     

    Hope that they are already working on a fix...

  • Mr.Techno Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 15, 2012 7:47 AM (in response to Daxter137)

    I went to an apple store yesterday and they said they couldnt tell if it was a hardware or software problem. They adviced me to either reinstall the system or leave the computer to them. A repair can take up to two weeks

     

    Do you guys have a problem with the sound playing through the internal speakers as well or is it just through the audio jack? My right stereo chanel is distorted and noisy. Am I the only one with that kind of issue?

     

    Thanks!

  • nordlund.e Calculating status...
    Currently Being Moderated
    Dec 15, 2012 2:15 PM (in response to Mr.Techno)

    I'm running 10.8.2 as well, but I'm pretty sure I remember it being a problem for previous editions of Mountain Lion, too.

  • sarahwoodgreen Calculating status...
    Currently Being Moderated
    Dec 18, 2012 12:46 PM (in response to Daxter137)

    I have this problem too.

     

    I just bought the same model as you (15inch Retina MacBook Pro 2.6 Ghz, 16GB Ram, 512GB SSD)

     

    Whatever program I listen to sound on (Logic Pro, Safari, iTunes, Skype) I get a poping/static sounds randomly.

     

    Its really annoying I use it for music and need to hear sound perfectly. Turning off Automatic Graphics Switching does stop the problem but makes the fan go crazy and dramatically reduces the battery life. We just spent over $3200 and should not have to make do with work arounds!

     

    Do you think this is a Hardware or Software issue? There is a lot of talk about this problem online but when you call Apple they say they've never heard about this problem.

  • Caderind Calculating status...
    Currently Being Moderated
    Dec 18, 2012 3:46 PM (in response to sarahwoodgreen)

    Having the same issue. As mentioned turning off 'Automatic Graphics Switching' solves it but its not a very good work around.

     

    This is a pricey laptop and anything less than perfect for the premium you pay is quite unacceptable. I must admit I have been really sadned by my rMBP purchase. I am finding it really difficult to justify the cost to me when even such basic tasks (e.g. youtube videos/itunes etc) are marred by performance issues and sound stuttering.

     

    I hope that Apple get out a fix ASAP. Between this and the IR problems I cannot see myself picking up a new macbook in future.

  • Christofer Karlsson Calculating status...
    Currently Being Moderated
    Dec 19, 2012 3:02 PM (in response to Daxter137)

    Having the same sound problem as the original poster. Can also confirm that the problem only exist for me when the integrated graphics card is in use.

  • Snail3 Calculating status...
    Currently Being Moderated
    Dec 19, 2012 5:10 PM (in response to Daxter137)

    I have a similar issue too. Got it in August and has been fine so far. But the other day when I was watching the new Batman movie, the bass was horrible. First I thought it could be the source of the movie then I tested with a PC with the same movie, it sounded amazing. So, it must be the computer then. Is it the EQ in the setting or hardware? I'm concerned...

  • fluxmc302 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 23, 2012 5:14 AM (in response to Daxter137)

    Yep I have the same issue... very annoying. it doesn't happen when I am producing music (using cpu intensive DAW and plugs.) only when watching youtube or les cpu intensive tasks.

  • lanceenjoyscereal Calculating status...
    Currently Being Moderated
    Dec 23, 2012 7:20 AM (in response to Daxter137)

    Same issue here. Definitely an integrated graphics issue as using discrete graphics fixes the problem. Please fix apple!

  • Arrun Calculating status...
    Currently Being Moderated
    Dec 24, 2012 4:06 PM (in response to Daxter137)

    This happens randomly for me, and it's definitely software related because it doesn't happen on a fresh user account. It also makes no difference if I enable or disable onboard vs geforce.

     

    This is utterly pathetic and unacceptable, Apple. How dare you charge the steep premium you do for what is supposed to be a better OS and you give us THIS. Macs are primarily the go to device for musicians, and you provide a laptop that has insane distortion.

  • calabek Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 30, 2012 2:51 AM (in response to lanceenjoyscereal)

    I just figure out, that the issue when music is "cracking" in iTunes for example, is solved when you re-launch the iTunes while you running on the integrated graphics. In this case, cracking disappears.

  • defn86 Calculating status...
    Currently Being Moderated
    Jan 2, 2013 6:29 AM (in response to Daxter137)

    I have the exact same problem. A restart usually fixes it for a few hours until it comes back again. Fix this, Apple.

  • grocklin Calculating status...
    Currently Being Moderated
    Jan 5, 2013 10:38 AM (in response to Daxter137)

    Same problem and I'm also surprised that it goes away when using discrete graphics, which is obviously worse for the battery.  Does anyone know if apple is following this?

  • DevManJr. Calculating status...
    Currently Being Moderated
    Jan 6, 2013 12:10 PM (in response to Daxter137)

    I have the same issue.  It is a problem with the software that switches between integrated and discreet gpus to save power.

     

    It only happens on the intel 4000hd GPU. I sure hope the code monkeys at apple get their **** together soon.  This issue seems to have remained pretty much unaddressed as far as a few google searches have led me to believe.

     

    Some say using the gfxCardStatus.app to stick to the discreet gpu fixes things.  As most of you have said, it's unacceptable for something so expensive to malfunction out of the box.

1 2 3 4 ... 9 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.