8 Replies Latest reply: Jan 19, 2013 10:02 AM by anticafase
anticafase Level 1 Level 1 (0 points)

hello, on my imac after upgrading to mountain lion my computer password and/or username seems not to work anymore: when i want to install an update or search for updates on the app store the combination i used so far, does not work anymore. i tried to find out how to reset the computer password but without too much success, and i'm a bit confused, what can i do? thanks a lot


iMac, OS X Mountain Lion (10.8.2)
  • 1. Re: username/password not working after upgrade to mountain lion
    anticafase Level 1 Level 1 (0 points)

    ps. i tried to log out and in again with the password and it works, but still when i try to insert in the authentycation it doesn't work!

  • 2. Re: username/password not working after upgrade to mountain lion
    Linc Davis Level 10 Level 10 (118,145 points)

    In the Users & Groups preference pane, there's a checkbox marked Allow user to administer this computer. Is it checked? If not, do you have any other user accounts?

  • 3. Re: username/password not working after upgrade to mountain lion
    anticafase Level 1 Level 1 (0 points)

    it's not checked, but in order to check it i have to unlock the changes by inserting the username and password and guess what? the one i used to log in and out doesn't work

     

    here's the whole story: 3 years ago i bought this 24" imac from another person, who bought it refurbished and kept it for a very short time; i changed the name of the user by a complex procedure i can't recall anymore, in order to have my name on the disk and so on. i remember i entered into some sort of "root" mode, and from then on, despite the name and password i had set while installing the OSX, i had "System Administrator" as username and a different password i had to set up. since then that worked fine, until yesterday, when i installed the new OSX. i had my original account, this new System Administrator account and a guest account. now the SA account is gone, i am using the old account (but nothing's changed, and i've been able to log in and out fine), but this user name and password doesn't allow me to install any new software or system update, nor the old SA account and password.

     

    i'm afraid it's a bit of a mess, but there must be some way to overcome it, right?

    thanx for your support!

  • 4. Re: username/password not working after upgrade to mountain lion
    Linc Davis Level 10 Level 10 (118,145 points)

    You went wrong at the very beginning by not erasing the hard drive of a used computer before starting to use it yourself. I suggest you do that now.

     

    Back up all data to at least two different storage devices.

     

    Boot into Recovery (command-R at startup), launch Disk Utility, and erase the startup volume. This operation will destroy all data on the volume, so you had be better be sure of your backups. Install OS X. If your Mac was upgraded from an older version of OS X, you’ll need the Apple ID and password you used to upgrade, so make a note of those before you begin.

     

    When you reboot, you'll be prompted to go through the initial setup process. That’s when you transfer the data from one of your backups. For a walkthrough, see here:

     

    Using Setup Assistant

     

    Don't transfer the Guest account, if it was enabled on the old system.

     

    Note: You need an always-on Ethernet or Wi-Fi connection to the Internet to use Recovery. It won’t work with USB or PPPoE modems, or with proxy servers, or with networks that require a certificate for authentication.

  • 5. Re: username/password not working after upgrade to mountain lion
    anticafase Level 1 Level 1 (0 points)

    wow, that sounds scary. luckily i just bought a new hard disk so i can have 2 total backups. i'll finish sorting out a few things and the i'll try this way, i'll let you know how it goes.

     

    thank you a lot!

  • 6. Re: username/password not working after upgrade to mountain lion
    anticafase Level 1 Level 1 (0 points)

    hello, i still didn't try erase the startup volume because, for some reasons that i can't solve now, i'm not able use the assisted backup function of my hard disks. i managed to manually copy the folders with my files and archive on one of the hard disks, not the system files and applications, but those i can get back most of them.

    my question is: can i try to erase the startup disk, re install osx, and then place back my files without problems?

  • 7. Re: username/password not working after upgrade to mountain lion
    Linc Davis Level 10 Level 10 (118,145 points)

    can i try to erase the startup disk, re install osx, and then place back my files without problems?

     

    I have no way of knowing that. You obviously have a damaged system and I don't know why you're unable to back up in the usual way. If you didn't back up when your system was working normally, there may be no easy way out now.

  • 8. Re: username/password not working after upgrade to mountain lion
    anticafase Level 1 Level 1 (0 points)

    i managed to do everything, it took me a while since i don't have a good internet connection, but in the end it's all solved! thank you very much!!