1 2 Previous Next 18 Replies Latest reply: May 21, 2013 9:05 AM by VoilaMagic Go to original post
  • 15. Re: Stop asking to use my keychain... OS X.
    Sakahara Level 1 Level 1 (0 points)

    Wait, there is an issue (it's asking for login keychain pasword after sleep or screen... when it's unchecked). But I thought you meant if it caused the other issues I mentioned above (unable to type in password and freezing).

     

    Anyways, here's part of the log right before and after waking from sleep at 4:22:17;

     

     

    1/4/13 4:15:21.396 PM sandboxd[11073]: ([11072]) mdworker(11072) deny mach-lookup com.apple.ls.boxd

    1/4/13 4:15:21.401 PM sandboxd[11073]: ([11071]) mdworker(11071) deny mach-lookup com.apple.ls.boxd

    1/4/13 4:15:21.000 PM kernel[0]: Sandbox: sandboxd(11073) deny mach-lookup com.apple.coresymbolicationd

    1/4/13 4:17:09.000 PM kernel[0]: PM mode before entering WoW is 1 and PM allowed state is 1

    1/4/13 4:17:09.000 PM kernel[0]: Wake reason: EHC1

    1/4/13 4:22:17.000 PM kernel[0]: Previous Sleep Cause: 5

    1/4/13 4:22:17.000 PM kernel[0]: The USB device Keyboard Hub (Port 1 of Hub at 0xfd000000) may have caused a wake by issuing a remote wakeup (2)

    1/4/13 4:22:17.000 PM kernel[0]: AirPort: Link Down on en1. Reason 4 (Disassociated due to inactivity).

    1/4/13 4:22:17.000 PM kernel[0]: en1::IO80211Interface::postMessage bssid changed

    1/4/13 4:22:17.000 PM kernel[0]: en1: 802.11d country code set to 'X0'.

    1/4/13 4:22:17.000 PM kernel[0]: en1: Supported channels 1 2 3 4 5 6 7 8 9 10 11 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140 149 153 157 161 165

    1/4/13 4:22:17.000 PM kernel[0]: The USB device Apple Keyboard (Port 2 of Hub at 0xfd100000) may have caused a wake by issuing a remote wakeup (3)

    1/4/13 4:22:17.000 PM kernel[0]: HID tickle 138 ms

    1/4/13 4:22:18.448 PM WindowServer[8829]: handle_will_sleep_auth_and_shield_windows: no action for lock state 1

    1/4/13 4:22:24.558 PM configd[17]: network changed: v4(en1-:192.168.1.1) DNS- Proxy- SMB

    1/4/13 4:22:28.000 PM kernel[0]: en1: 802.11d country code set to 'US'.

    1/4/13 4:22:28.000 PM kernel[0]: en1: Supported channels 1 2 3 4 5 6 7 8 9 10 11 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140 149 153 157 161 165

    1/4/13 4:22:28.000 PM kernel[0]: Auth result for: d8:30:62:31:48:93 MAC AUTH succeeded

    1/4/13 4:22:28.000 PM kernel[0]: AirPort: Link Up on en1

    1/4/13 4:22:28.000 PM kernel[0]: en1: BSSID changed to d8:30:62:31:48:93

    1/4/13 4:22:28.000 PM kernel[0]: en1::IO80211Interface::postMessage bssid changed

    1/4/13 4:22:28.000 PM kernel[0]: AirPort: RSN handshake complete on en1

    1/4/13 4:22:28.752 PM configd[17]: network changed: v4(en1+:192.168.1.1) DNS+ Proxy+ SMB

    1/4/13 4:22:28.767 PM UserEventAgent[11]: Captive: en1: Not probing 'CGA' (protected network)

    1/4/13 4:22:28.772 PM configd[17]: network changed: v4(en1!:192.168.1.1) DNS Proxy SMB

  • 16. Re: Stop asking to use my keychain... OS X.
    Linc Davis Level 10 Level 10 (118,030 points)

    Back up all data.

     

    Launch the Keychain Access application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Keychain Access in the icon grid.

     

    Select the login keychain from the list on the left side of the Keychain Access window. If your default keychain has a different name, select that.

     

    If the lock icon in the top left corner of the window shows that the keychain is locked, click to unlock it. You'll be prompted for the keychain password, which is the same as your login password, unless you've changed it.

     

    Right-click or control-click the login entry in the list. From the menu that pops up, select Change Settings for Keychain "login". In the sheet that opens, uncheck both boxes, if not already unchecked.

     

    From the menu bar, select

       

    Keychain Access Preferences First Aid

      

    If the box marked Keep login keychain unlocked is not checked, check it.

     

    Select

      

    Keychain Access Keychain First Aid

       

    from the menu bar and repair the keychain. Quit Keychain Access.

  • 17. Re: Stop asking to use my keychain... OS X.
    MarkDouma® Level 6 Level 6 (9,845 points)

    Launch the Keychain Access application (in the /Applications/Utilities/ folder). In the window that appears, make sure the keychains list is showing like in the image below (if it isn't, choose View > Show Keychains):

     

    Screen Shot 2013-01-05 at 8.22.18 PM.png

    Make sure the login keychain is selected in the list like shown above, then choose Edit > Change Settings for Keychain "login"…. It should bring down a sheet like that shown below:

     

    Screen Shot 2013-01-05 at 8.23.16 PM.png

     

    Make sure both options are unchecked and click Save.

     

    Each application that need access to keychain items will block (in other words be completely unresponsive) until the security dialog that's requesting acess to your keychain items is dismissed.

  • 18. Re: Stop asking to use my keychain... OS X.
    VoilaMagic Level 1 Level 1 (0 points)

    This works.

     

    I solved this issue by

     

    Opening Keychain Access,

    Selecting the "Lock after x minutes of idle"

    Select File > Preferences

    Select "FIRST AID"

    Deselecting "Keep Login Keychain Unlocked",

    You Can Also deselct "Synchronize Login Keychain Password with Account" (I did not deselect this.)

     

    This stops the "Mac OS X requests your "Login" password" pop-up boxes that were constantly popping up.

     

    Now, all of my keys are locked, unless I want to use a particular key.

1 2 Previous Next