5 Replies Latest reply: Jan 6, 2013 5:31 AM by stedman1
Rafy_B Level 1 Level 1 (0 points)

i d like download the os x mountain lion and i got the msg it is not compatible with my mac (just bought the newest one) what do i need to do??


iMac