0 Replies Latest reply: Jan 6, 2013 8:29 AM by KaraMac1950
KaraMac1950 Level 1 Level 1 (0 points)

I have MacBook 10.5.8.  Firefox says it is no longer supporting this and I am liable to 'attack'.  What should I do?


MacBook, Mac OS X (10.5.8)