Skip navigation

links open in wrong browser

14451 Views 20 Replies Latest reply: Jan 31, 2014 10:01 AM by mmmond RSS
  • BCPfan Calculating status...
    Currently Being Moderated
    Jul 15, 2012 10:04 AM (in response to bozo_z_clown)

    Bozo-

    I know this issue and thread are a few months old, but I too was sick of the "search google" function/short cut searching with Safari instead of Chrome.  I searched google for a fix and this thread came up.  Bozo's solution worked perfectly.  I thought the fix seemed too easy, but it worked great.  Thx!

  • CodyHoll Calculating status...
    Currently Being Moderated
    Jan 6, 2013 11:46 PM (in response to jaileer)

    I know this is old but I think I may have just solved it under the Safari>preferences>RSS tab and change default to Chrome.

  • WyoLarsens Calculating status...
    Currently Being Moderated
    Mar 29, 2013 4:12 PM (in response to jaileer)

    Not a solution but (for me) an answer: I was having the same issue of right-clicking some text *in Chrome* and doing a Google search but it would launch Safari to do the search. It seems there's a contextual menu item that Chrome includes, "Search Google for 'whatever'" and there's also a contextual menu item that's included by the OS, "Search with Google." I never noticed the second one and have always just used the first, but the second one launches Safari... I must've hit it without looking. 3 times. Today. And wasted an hour trying to figure out why Safari's launching.

     

    I guess I still don't know why Safari's launching when it knows Chrome is the browser I want to use, but oh, well.

  • BerndNW Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 9, 2013 9:12 AM (in response to silby102)

    Great, it worked! Thanks silby102

  • CREAMASTER Level 1 Level 1 (75 points)
    Currently Being Moderated
    Nov 26, 2013 11:14 AM (in response to andyBall_uk)

    This is amazing. It's 2013, almost 2014 as I write this and I see here it's been a bug since 2011… I thought - but no! This has been an issue since 2002! So I guess this is a feature not a bug?

     

    Search with Google still opens the wrong browser - even after 10 years of being a bug.

  • mmmond Calculating status...
    Currently Being Moderated
    Jan 31, 2014 10:01 AM (in response to bozo_z_clown)

    fail

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.