3 Replies Latest reply: Jan 8, 2013 2:30 AM by pterobyte
flipbosch Level 1 Level 1 (0 points)

I am Using Mountain lion server with the server app installed.

 

Not the strange thing is that a lot email is not delevered to my email clients, but some are.

The email that is having problems is test@mydomain.nl

 

Does anybody know how to debug where the email is, that is not deliverd?

 

Let me explain a strange situation.

 

When I sent a mail true wetransfer.com from info@mydomain.nl to test@mydomain.nl.

I recieve the message on info@, that is is successfull delevered at test@..  but never recieve the mail at test@mydomain.nl

 

Here a part of the logs:

 

2E673904CBB: message-id=<29389ec26ebec278cf2f78448c204405@mail02.wetransfer.com>

Jan  5 15:27:52 server.mydomain.nl postfix/qmgr[4178]: 2E673904CBB: from=<bounces+info=mydomain.nl@dynect-mailer.net>, size=18104, nrcpt=1 (queue active)

Jan  5 15:27:52 server.mydomain.nl postfix/smtpd[4224]: connect from localhost[127.0.0.1]

Jan  5 15:27:52 server.mydomain.nl postfix/smtpd[4224]: AB6E8904CD0: client=localhost[127.0.0.1]

Jan  5 15:27:52 server.mydomain.nl postfix/cleanup[4221]: sacl_check: mbr_user_name_to_uuid(info@mydomain.nl) failed: No such file or directory

Jan  5 15:27:52 server.mydomain.nl postfix/cleanup[4221]: AB6E8904CD0: message-id=<29389ec26ebec278cf2f78448c204405@mail02.wetransfer.com>

Jan  5 15:27:52 server.mydomain.nl postfix/qmgr[4178]: AB6E8904CD0: from=<bounces+info=mydomain.nl@dynect-mailer.net>, size=18770, nrcpt=1 (queue active)

Jan  5 15:27:52 server.mydomain.nl postfix/smtp[4222]: 2E673904CBB: to=<info@mydomain.nl>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.64, delays=0.43/0.01/0.01/0.19, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as AB6E8904CD0)

Jan  5 15:27:52 server.mydomain.nl postfix/qmgr[4178]: 2E673904CBB: removed

Jan  5 15:27:52 server.mydomain.nl postfix/pipe[4227]: AB6E8904CD0: to=<flipcrypton@server.mydomain.nl>, orig_to=<info@mydomain.nl>, relay=dovecot, delay=0.16, delays=0.04/0.01/0/0.11, dsn=2.0.0, status=sent (delivered via dovecot service)

 

 

Also some other people are trying to mail me on test@. But I dont see the any message recieving in the logs, and also no bounce message is there.

 

Hope somebody can help me with this, since I have lost a lot email from now.


OS X Server
  • 1. Re: Some emails are not delivered, also not in LOG, no Bounce message
    pterobyte Level 6 Level 6 (10,910 points)

    Not sure why you are testing this through a file sending service? You should try and send from an external, normal mail account to test@yourdomain.nl and then check your logs. If you see no log entry, then the message doesn't even reach your mail server which most likely indicates a DNS issue.

     

    If you care to post your domain, me or somebody else can easily check if your DNS is OK.

  • 2. Re: Some emails are not delivered, also not in LOG, no Bounce message
    flipbosch Level 1 Level 1 (0 points)

    Dear pterobyte,

     

    Thank you very much for you help.
    I indeed use a filesending service for testing, and agree that thats not the best way to test, but it was a way.

    Since most email are delivered it is hard to test when it is going wrong.

     

    Its a good change that it has to do with the DNS.

    Does anybody know how to test if DNS is installed proper? I did install a default MLS installation.

     

    What I see is that there is one issue with my reversed DNS.

     

    When I type in terminal:

     

    Host server.crypton.nl,

     

    I get my IP, but when I type:

     

    Host 83.2.97.95

     

    I don't see my server host but the one from my ISP.

     

    83.2.97.95.in-addr.arpa domain name pointer 095-097-002-083.static.chello.nl.

    Not

    83.2.97.95.in-addr.arpa domain name pointer 095-097-002-083.server.crypton.nl


    Might that be the problem?

    Since you mention it can it has to do with the DNS.

     

    Since it is all default, i dont know what is wrong with it.

     

    Kind regards,

     

    Flip

  • 3. Re: Some emails are not delivered, also not in LOG, no Bounce message
    pterobyte Level 6 Level 6 (10,910 points)

    Indeed your reverse PTR record for your IP 95.97.2.83 is not correct and you should ask your ISP to change it. This, however, is not the cause of your problems.

     

    You seem to have 2 MX records for your domain. One pointing to relay.transip.nl. Does relay.transip.nl accept mail for your domain and/or this specific user?

     

    HTH,

    Alex

     

    P.S. Testing through file sending service is meaningless. Any send receipts you get from them, merely mean they attempted to send the mail. They won't know what happened to the e-mail down the road.

    Use an external e-mail account like a Gmail account for example. Send to your address and check your logs.