Skip navigation

usb dac not working

481 Views 1 Reply Latest reply: Jan 8, 2013 5:23 AM by Roger Sinden RSS
Roger Sinden Calculating status...
Currently Being Moderated
Jan 5, 2013 5:14 AM

I have a USB DAC fed from my iMac via a powered Belkin hub. It used to work fine but after some system problems caused by an upgrade to Audio HiJack Pro, it now does not work with the iMac.  It works fine on an old PC laptop.  All symptoms are the same regardless as to whether the USB DAC is plugged directly into the iMac or the Belkin hub.


The iMac recognises when the USB-DAC is plugged in as it is then listed in Sound preferences.  It also makes iRecordMusic crash !  But no sound out from the DAC.


So what has happened leading up to this point?


I'd not run Audio Hijack Pro for many, many, many months.  I fired it up and it prompted me that there was an update available which I opted to download. The instal process prompts for a restart.  After the restart, my desktop locked with the small volume control pane permanently visible and taking the front window spot (if that is the right term). I could click on a pane from an another application that was lying behind the voulme control pane but as soon as I clickded off, the desktop went back to the volume control pane.  Thde volume control level was also at max.  You could click and drag the volume down but as soon as you released the mouse, back it went to max.


I tried to find a way to de-install this wonderful update but with little success.


So I then decided to restore the system from my Time Machine....which estimated it needed three days to complete (not so hot).  Not having three days available I next opted to do a complete restore from my SuperDuper backup.  This worked perfectly.  The volume control problem has gone away and as far as I could see, my system was back to normal.


But given my USB DAC problem, clearly there is something rotten somewhere.  I notice that SuperDuper does not backuop certain Apple system files (as recommended by Apple) and so maybe one of those files is still a corrupt version and explains the USB DAC problem.  I don't know enough.


Are there any USb sound related preference fiules that I can delete to try and force a rebuild of a clean version?


Any other suggestions, please, otherwise it looks like a complete rebuild from scratch. 


Many thanks in advance.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.