11 Replies Latest reply: Jan 16, 2013 3:03 PM by gimpi
gimpi Level 1 Level 1 (0 points)

I haven't used NetRestore/Install functionalities since 10.6, so my understanding of how things work may be dated.  Currently, I have a 10.8 server that I'm trying to get to serve 10.7 NetRestore images.  I understand that I need a 10.7 box to make 10.7 images, so I'm making the images in Lion and then uploading them to my ML server.  The creation process goes fine and, once uploaded and placed into the correct folder, NetInstall serves the image fine.  Client computers even see the NetRestore image as an option for startup disks but when I try to boot them into it, it gets as far as the Apple Logo and spinning gear - and it just keeps spinning.

 

Clients never show up on the ML NetInstall client list but logs show the computers accessing it - no errors, though - just nothing happens.

 

I've seen one old post from last year referencing Lion and the need to produce images from Reference releases but I don't remember SIU ever being that picky in 10.6... is there a way to produce a usable image without going through the arduous task of doing a complete reinstall from a reference release?  Is there a way to clean up a prospective computer that's been combo updated to where it will create a functional NetRestore image?

  • 1. Re: NetRestore & 10.7 images on 10.8 Server
    Richard Cartledge Level 2 Level 2 (435 points)

    Do you mean Apple Netinstall, or Bombich's Netrestore? If the latter, that is super obsolete.

    Try Deploystudio.

    http://www.deploystudio.com/Home.html

    A bit of an initial learning curve, but once you are used to it, it's great.

  • 2. Re: NetRestore & 10.7 images on 10.8 Server
    gimpi Level 1 Level 1 (0 points)

    I'm talking about Apple's System Image Utility and Apple's built-in Netinstall option in Server 10.8. I'm trying to avoid that learning curve of installing and figuring out DS, but does DS have any issues creating images from combo-updated computers? Does it, like Apple's products, require a reference release? This reference release is especially difficult for me to get my hands on, given that the university I work for doles out updates via Casper - so there's no going to the App Store and redownloading a copy..

  • 3. Re: NetRestore & 10.7 images on 10.8 Server
    Brian Nesse Level 4 Level 4 (2,780 points)

    You might check to make sure the both the NFS and HTTP (Web) services are configured and running properly. If I recall correctly, NFS is the default protocol for images created in 10.7, HTTP is the default protocol for images created in 10.8. It sounds like your NFS service is not configured correctly. Turning the NetInstall service off and back on *should* correct this.

  • 4. Re: NetRestore & 10.7 images on 10.8 Server
    gimpi Level 1 Level 1 (0 points)

    I've turned services on and off multiple times and have had no luck.  I've even restarted as well.  Given that there's no GUI tab to see if NFS is running anymore in Server, is there a way I can check via Terminal?

     

    Previously, under 10.6, I had to make a firewall exception for the clients, allowing access to ALL ports - but in 10.8 server, it seems the Firewall settings have moved out of Server and into System Prefs... but even with the firewall completely off, clients still aren't able to boot up into these images.

  • 5. Re: NetRestore & 10.7 images on 10.8 Server
    Brian Nesse Level 4 Level 4 (2,780 points)

    A couple of useful commands:

    $ nfsd status

    $ cat "/etc/exports"

    $ showmount -e

     

    status should be enabled AND running

    contents of exports should match the output from showmount

  • 6. Re: NetRestore & 10.7 images on 10.8 Server
    gimpi Level 1 Level 1 (0 points)

    nfsd is enabled and running.  both exports and showmount show the same volumes but there is a slight difference; I had changed the name of the volume the netinstalls were on because it had a space in the name initially (I read somewhere that may be an issue) - both exports and showmount show the new name and the old name but showmount states that the old name is offline.  Both, however, do reference the new name - so I think this is alright.

     

    I've tried network booting a client again and it, once again, sees the image but never gets further than the spinning gear and apple logo.

     

    Really wondering if this whole image-from-a-reference-build IS true.  Seems silly, though - from 10.3 to 10.6 I was always able to make images from combo-updated boxes - don't know why that'd change so dramatically now.

  • 7. Re: NetRestore & 10.7 images on 10.8 Server
    SBMTS Level 1 Level 1 (15 points)

    It's definitely true.  Ran into this with Lion Server serving a Lion NetRestore image a couple months ago, with the same symptoms as you described.  I "updated" the image with the installer from the app store and haven't had any issues since.

  • 8. Re: NetRestore & 10.7 images on 10.8 Server
    gimpi Level 1 Level 1 (0 points)

    Thanks for your post - I'm wondering if you could clairify "updated the image"; each site I've found that mentions this reference build issue says you have to start over fresh from the reference build - that there's no way to update an existing combo-updated image.  It'd be great to know that you could just update an existing image.

  • 9. Re: NetRestore & 10.7 images on 10.8 Server
    SBMTS Level 1 Level 1 (15 points)

    You can; however you'll need to use the full os x installer from the app store to update the image, sort of like the old archive and install option from 10.6.  Making a bootable USB of the installer makes it much, much easier. The install will leave things like home directories and the applications folder untouched, replacing just system files. It's annoying if you have a customized skeleton directory or something like that, but you can always back those up and copy them back after the installer is done. 

  • 10. Re: NetRestore & 10.7 images on 10.8 Server
    Brian Nesse Level 4 Level 4 (2,780 points)

    No. You most certainly can not make valid images from a combo updated source.

     

    Prior to Lion, combo updates used to contain scripts that modified the BaseSystem install receipt so that it "learned" about new drivers and libraries that were added to the OS during the update process. This was the process that allowed the combo updates to create a valid "new" OS install. This process is no longer supported, so the updated OS has no way of knowing what all of its required pieces are.

  • 11. Re: NetRestore & 10.7 images on 10.8 Server
    gimpi Level 1 Level 1 (0 points)

    Thanks for your help.  This clears up a lot.