Skip navigation

Spell Check in Mail not working

1978 Views 7 Replies Latest reply: Jan 8, 2013 9:58 AM by lrdooper RSS
Kathy Bourassa Calculating status...
Currently Being Moderated
Dec 26, 2012 4:09 PM

I'm back.  Still no luck getting spell check to work.  With all the things I've tried, I'm sure it is now isolated to a operating system based problem.  The spell check on InDesign works, but mac mail, text edit, and Open Office.org which all access the OS based spelling function don't work.  Not only will they not do dynamic spelling, you can't highlight and tell any of these programs to check the spelling.  That doesn't work either. 

 

I am running 10.6.8 on an iMAC 27" that is three years old.  I have kept up with my updates as they have come available, and my 3 year warranty just ran out in Nov. this year.  I would like to figure out how to fix this without having to wipe the hard drive or anything else that is so radical it might take me days to restore all my functionality.

 

Any suggestions?  Run the utilities and repaired permissions, restarted holding down the shift, etc. and nothing has helped.

 

thanks,

Kathy

iMac, Mac OS X (10.6.8)
  • lrdooper Calculating status...
    Currently Being Moderated
    Jan 3, 2013 10:13 AM (in response to Kathy Bourassa)

    Kathy, had same problem -- here is what I found just now by running tests:

     

    Ok, what is going on is that the preferences for spelling and grammar in word and mail seem not to be working…..

     

    in mail preferences there is no oportunity to set preference re spelling and grammar.  I can't find it in apple preferences either

     

    You have to do it manually --- so if mispelled words in EMAIL YOU GO TO EDIT, SPELLING AND GRAMMAR:

     

    if you check grammar with spelling -- all you get is red underline.

    if you CHECK  check before sending nothing happens

    If you check  ----check spelling and grammar (which seems to be the default)  nothing happens

    BUT IF YOU CHECK   show spelling and grammar, you get the red underline and correction box

     

     

     

     

    IN WORD, there is spelling preferences --- i chose : check spelling as type, suggest corrections, check grammar with spelling.

     

    IF I go back to check preferences, they are changed for example if i had chosen check spelling while typing, when i go back it is unchosen

     

    So with a document----- (before going back to preferences) ,only mispelled words are underlined red. BUT  if then you go to tools, spelling and grammar --- you get the box right away

     

     

    i did this research before checking directions on web  see    http://support.apple.com/kb/PH6911

    Which for me would take copying the article, double space, under key words  AND THEN MAYBE i could understand it --

    i have no idea if it correlates to actual testing above.

  • Klaus1 Level 8 Level 8 (43,375 points)
    Currently Being Moderated
    Jan 3, 2013 11:16 AM (in response to Kathy Bourassa)

    Mail Preferences/Composing: what have you selected under Check Spelling?

  • lrdooper Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 1:24 PM (in response to Klaus1)

    If you have CHECK SPELLING IN composing, all it does is underline mispelled words.   And you have to figure the right spelling.

     

    BUT, here is the exciting part... if you chose check spelling when i send, it offers you the box to change to their corrections and when you have gone through the message content -------,it sends it right then

     

    so you have no opportunity to doublecheck your message for content, spelling or to add new content

  • PaulWhite Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jan 5, 2013 11:12 AM (in response to Kathy Bourassa)

    I think I fixed it.

     

    I need spelling checking both in English and in German. It used to swap automatically depending on how a sentence began. Recently it stopped working.

     

    I can't remember where, but somewhere I think I switched on check grammar for British English. After that it didn't check either English or German or whatever correctly. Everything showed as wrong and was red underlined..

     

    To fix:

    Open a new mail

    Typed in some German ( but I am sure it works with any language).

    From the Mail Menu: edit / spelling and grammar / show spelling and grammer

     

    This opens a little window. At the bottom there is a drop-down where you can select the language, or as I did select automatic by Language.

     

    Voila it now checks both English and German the way it used to.

     

    -Paul-

    Hope this helps

  • lrdooper Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 8, 2013 9:58 AM (in response to Kathy Bourassa)

    I just spoke to apple support

     

    in case you haven't gotten this

     

    MAIL - on an red underlined word click control and then click - the correction box comes up

     

    in word, select misspelled word, go to tools, select spelling and box comes up

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.