Skip navigation

Garageband doesn't open in Mac Mini mid 2011

1370 Views 15 Replies Latest reply: Jan 9, 2013 12:48 PM by léonie RSS
1 2 Previous Next
hiemmsss Calculating status...
Currently Being Moderated
Nov 14, 2012 9:37 AM

I recently bought a Mac Mini and the first time I open Garageband it opens perfectly. Later I upgraded to 10.8.2, since then, when I open garageband I get this Error:


Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:

dyld: launch, loading dependent libraries

Dyld Error Message:

Library not loaded: /System/Library/PrivateFrameworks/IntlPreferences.framework/Versions/A/IntlPref erences

Referenced from: /Applications/

Reason: no suitable image found. Did find:

/System/Library/PrivateFrameworks/IntlPreferences.framework/Versions/A/IntlPrefe rences: open() failed with errno=-22

Binary Images:

0x1000 - 0x428fe3 (6.0.5 - 428.5) <32DC1BBC-5A9A-27F9-A337-38971C0253CF> /Applications/

0x4d0000 - 0x54fff7 (2.7.2 - 546) <824E7748-CA28-3105-B5C3-27E9D8C6D465> /System/Library/PrivateFrameworks/iLifeMediaBrowser.framework/Versions/A/iLifeM ediaBrowser

0x593000 - 0x5c4ff7 (9.1.0 - 233.34) <76BB88D6-6797-A2E1-8CF7-1F8030178935> /Applications/ ersions/A/MAAudioUnitSupport

0x5da000 - 0x5dcfff (1.5 - 10) <435C80BD-F463-360B-86CA-5E001CACD421> /System/Library/Frameworks/ExceptionHandling.framework/Versions/A/ExceptionHand ling

0x5e2000 - 0x640fff (9.1.0 - 219.62) <38D77B7D-C948-528E-2889-E60FE2CC7EF3> /Applications/ sions/A/MALoopManagement

0x65f000 - 0x6e2fe7 (9.1.0 - 477.43) <08166857-0F5C-0DB6-E64B-BD02A9F7BC77> /Applications/ Core

0x71e000 - 0x775fe3 (9.1.0 - 199.68) <23DD5203-CA5F-66A7-103D-296869983626> /Applications/ /MAHarmony

0x793000 - 0xa80fef (9.1.0 - 124.60) <6D29C3A5-2AD0-AD56-FE6F-E335276E8B59> /Applications/ MAChrome

0xa99000 - 0x1163fef (9.1.0 - 1699.74) <C6DB844E-949C-99F6-45E6-5C273C6EB17A> /Applications/ ic

0x135a000 - 0x1772fef (9.1.0 - 424.64) <88554B4B-2F4D-59BE-37BA-197D9B71402C> /Applications/ /A/MAPlugInGUI

0x1a8b000 - 0x1aacff7 (9.1.0 - 313.17) <4E81B1BB-F4C9-9F7E-E1E1-1A055E0B2323> /Applications/ ions/A/MAApogeeSupport

0x1ab7000 - 0x1ae4ff3 (1.6.4 - 1.6.4) <5F0E55AF-BDA6-36B3-86F2-8A84A8F5D089> /System/Library/Frameworks/CoreAudioKit.framework/Versions/A/CoreAudioKit

0x1af7000 - 0x1c15ff3 (8536 - 8536.26.14) <C98F734D-D579-3F89-9A58-9EE890B1748E> /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit

0x1cc6000 - 0x1d96feb (9.1.0 - 359.20) <B364DF7D-FD49-56C3-AE2B-D993025D39EF> /Applications/ ions/A/GarageBandUIKit

0x1e1b000 - 0x246fff3 (9.1.0 - 588.83) <A8F1574F-4D97-E742-A12F-64E2D90164E0> /Applications/ SP

0x8fea2000 - 0x8fed4e57 dyld (210.2.3) <23516BE4-29BE-350C-91C9-F36E7999F0F1> /usr/lib/dyld

0x901f3000 - 0x90250fff (4.1.0 - 4.1.0) <9549B81F-4425-34EE-802B-F462068DC0C5> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio

0x90383000 - 0x90383fff (154 - 155) <604ADD9D-5835-3294-842E-3A4AEBCCB548> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

0x907fa000 - 0x90972ff5 (1.8 - 304.0) <0B0EC55A-9084-3E28-9A84-1813CE3FAA9B> /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore

0x90f86000 - 0x90f86fff (6.7 - 19) <354094F0-F36B-36F9-BF5F-FD60590FBEB9> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

0x90faf000 - 0x91107ffb (1.8 - 1.8) <9205DFC2-8DAE-354E-AD87-46E229B5F2F1> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox

0x9114b000 - 0x9114bfff (1.8 - Accelerate 1.8) <4EC0548E-3A3F-310D-A366-47B51D5B6398> /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate

0x9130e000 - 0x9158aff7 (7.7.1 - 2599.13) <FE609160-E1EF-341D-9B6A-205D3E03A4D2> /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime

0x94c53000 - 0x94db0ffb (7.7.1 - 2599.13) <2DC9E2BB-9895-3D02-A318-88431052E70B> /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit

0x9629c000 - 0x96535ff3 (7.1 - 1167) <AF7B18F2-D0FF-33AA-9CE9-4106B1CDAE1D> /System/Library/Frameworks/AddressBook.framework/Versions/A/AddressBook

0x96940000 - 0x96940ffd (1.8 - 1.8) <4C13DEA2-1EB0-3D06-901A-DB93184C06F0> /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit

0x9696c000 - 0x9696cfff (57 - 57) <956C6C6D-A5DD-314F-9C57-4A61D41F30CE> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

0x973ce000 - 0x9741cff3 (1.12.2 - 1.12.2) <7BA6C58B-0357-356F-BB69-17ACB5E35988> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration

0x9742b000 - 0x97439fff libxar.1.dylib (105) <343E4A3B-1D04-34A3-94C2-8C7C9A8F736B> /usr/lib/libxar.1.dylib

0x98557000 - 0x98565fff (1.8.6 - 1.8.6) <1AD1AE7B-B57B-35B5-B571-32A34F0DA737> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL

0x98e1e000 - 0x990defff (7.0 - 55179.1) <CB470E48-621B-34D9-9E78-8B773358CB6B> /System/Library/Frameworks/Security.framework/Versions/A/Security

0x99338000 - 0x993a0ff7 (2.0 - 755.18.10) <9A80E97E-544F-3A45-916D-6DB7ED217E33> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

0x99d59000 - 0x99d61fff (2.5.1 - 2.5.1) <25A7232F-9B6A-3746-A3A8-12479D086B1E> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration

0x99e0a000 - 0x99ee0fff (7.0 - 7000.2.4) <C14E99B9-DEFA-3812-89E5-464653B729F4> /System/Library/Frameworks/DiscRecording.framework/Versions/A/DiscRecording

Model: Macmini5,1, BootROM MM51.0077.B10, 2 processors, Intel Core i5, 2.3 GHz, 8 GB, SMC 1.76f0

Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In, 512 MB

Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1333 MHz, 0x04CD, 0x46332D3130363636434C392D344742535100

Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1333 MHz, 0x04CD, 0x46332D3130363636434C392D344742535100

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xE4), Broadcom BCM43xx 1.0 (

Bluetooth: Version 4.0.9f33 10885, 2 service, 18 devices, 1 incoming serial ports

Network Service: Ethernet, Ethernet, en0

Serial ATA Device: APPLE HDD HTS547550A9E384, 500,11 GB

USB Device: hub_device, 0x0424 (SMSC), 0x2513, 0xfa100000 / 2

USB Device: Microsoft LifeCam VX-800, 0x045e (Microsoft Corporation), 0x0766, 0xfa120000 / 4

USB Device: BRCM20702 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0xfa110000 / 3

USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8281, 0xfa113000 / 5

USB Device: hub_device, 0x0424 (SMSC), 0x2513, 0xfd100000 / 2

USB Device: SONY Mouse, 0x054c (Sony Corporation), 0x0284, 0xfd120000 / 4

USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd110000 / 3

I have tried reinstalling it, but still no. Hope someone can help me. Thanks.

Mac mini (Mid 2011), OS X Mountain Lion (10.8.2)
  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Nov 15, 2012 2:58 AM (in response to hiemmsss)

    Dyld Error Message:

    Library not loaded: /System/Library/PrivateFrameworks/IntlPreferences.framework/Versions/A/IntlPref erences

    Referenced from: /Applications/


    The error message shows, that GarageBand tries to use a framework in your library, that is missing. There might be be two reasons for it:

    1. Either this framework has been corrupted by installing incompatible software (did you reinstall something else when upgrading to Mt. Lion? Then this older software may have corrupted your system library)
    2. Or you are using outdated device drivers and need to update your device drivers for your interfaces, now that you have switched to Mt. Lion.


    If the framework in your System library really got corrupted by another installation, reinstalling Mt. Lion should fix this. Try reinstalling using the combo updater at OS X Mountain Lion Update v10.8.2




  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jan 6, 2013 2:42 PM (in response to hiemmsss)

    What is your GarageBand version? From the CrashLog the first lines are missing, with the Program Version number, MacOS X,etc.

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jan 7, 2013 11:30 AM (in response to hiemmsss)

    What happened, when you reinstalled MacOS X with the Combo-updater? Did the reinstall succeed?


    If reinstalling MacOS X using the Combo-Updater did not work, I'd try to reinstall using the Internet Recovery, but you will have to make sure, your Internet connection is stable.

    OS X: About OS X Recovery


    Before making a second attempt at reinstalling the OS, I'd try to reinstall GarageBand. The link above says how.


    And about the second reason: what drivers should I update?


    I looked at your crashlog again, and I do not see any device drivers, that did not come preinstalled eiter in GarageBand or MacOS X. Did you install any software for Audio Interfaces?

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jan 8, 2013 7:59 AM (in response to hiemmsss)

    Sorry for the late response. I tried to find similar cases as your error message, and got help from a fellow poster.

    -22unitEmptyErrDriver ref num specifies NIL handle in unit table


    The error code in your crash log suggest to me, that your hard disk or file system may have a problem.


    Run DiskUtility (from the Applications > Utilities folder) to check the FileSystem of your system drive. Do you see any errors? If yes, boot into the Recovery Partion (you cannot repair your system drive while booting from it) and run Disk Utility from the First Aid to repair  the file system.

    OS X Lion: About Lion Recovery

  • Linc Davis Level 10 Level 10 (107,735 points)
    Currently Being Moderated
    Jan 8, 2013 12:36 PM (in response to hiemmsss)

    Back up all data.


    Boot into Recovery by holding down the key combination command-R at the startup chime. Release the keys when you see a gray screen with a spinning dial.


    Note: You need an always-on Ethernet or Wi-Fi connection to the Internet to use Recovery. It won’t work with USB or PPPoE modems, or with proxy servers, or with networks that require a certificate for authentication.


    When the OS X Utilities screen appears, follow the prompts to reinstall the OS. You don't need to erase the boot volume, and you won't need your backup unless something goes wrong. If your Mac was upgraded from an older version of OS X, you’ll need the Apple ID and password you used to upgrade, so make a note of those before you begin.

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jan 8, 2013 1:17 PM (in response to Linc Davis)

    Linc, thank you so much for coming to our rescue!


  • Linc Davis Level 10 Level 10 (107,735 points)
    Currently Being Moderated
    Jan 8, 2013 2:20 PM (in response to hiemmsss)

    There should be no data loss or other adverse effects, but that doesn't lessen the need for you to back up in case something goes wrong, which is always possible. Note that a Boot Camp installation is not backed up by Time Machine.

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Jan 9, 2013 7:28 AM (in response to hiemmsss)

    any progress, hlemmsss?

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.