Skip navigation

Numbers Will Not Sync With iCloud On Any Device

373 Views 11 Replies Latest reply: Mar 18, 2014 6:53 AM by SGIII RSS
TPSOxford Calculating status...
Currently Being Moderated
Jan 2, 2013 6:30 AM

Docs in Pages will sync just fine on any device I use (iMac, iPhone 4s, iPad3) as well as photos, music, etc. But I cannot get Numbers to sync and update on any of them regardless of what wifi or cellular connection I am using. I did have to do a hard restore on my iPad in the last week because the Mail app kept crashing. I did not restore from iCloud since doing so made the Mail app keep crashing. I deleted the Numbers docs on both of my IOS devices hoping that would help, but so far no luck. Anyone have a solution for this?

iMac (27-inch Mid 2011), iMac/Iphone4s/iPad3
  • tboett Calculating status...
    Currently Being Moderated
    Jan 8, 2013 2:27 PM (in response to TPSOxford)

    Had the same problem. The solution is to go to the settings on your iOS device and turn off iCloud syncing (Settings > iCloud > Documents & Data). As a result, all the docs living in the cloud will be removed from your device. Open Numbers and see them vanish.

    Return to settings and turn iCloud on again. Then back again to Numbers and everything in the cloud will come in.

    HTH

    Thomas

  • Lockjaw43 Calculating status...
    Currently Being Moderated
    Mar 17, 2014 2:35 PM (in response to tboett)

    I have the same issue- changes made in Calendar show up but I cannot get Numbers to sync to my iPad or my iPhone no matter what I do including the fix mentioned above. I've tried shutting and opening and closing each device to no avail.

  • Lockjaw43 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 17, 2014 2:36 PM (in response to Lockjaw43)

    And interestingly there's no 'Save As' in Numbers so I can't even create a new Numbers doc to try and re-sync! Grrrr

  • tboett Level 1 Level 1 (20 points)
    Currently Being Moderated
    Mar 17, 2014 3:00 PM (in response to Lockjaw43)

    For doing the "Save As", I suggest you go to your icloud account and send yourself a copy from the browser. Or download the file from iCloud. You can even duplicate the file in the browser (using the secondary click brings up the menu).

  • Lockjaw43 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 17, 2014 4:57 PM (in response to tboett)

    I'd prefer it to just work the way it's supposed to, and used to. And I'd prefer that there was a specified methodology to get iCloud apps to sync instead of fruitlessly searching for various home brew fixes that dont work. Hello Apple?

  • SGIII Level 4 Level 4 (3,290 points)
    Currently Being Moderated
    Mar 17, 2014 6:16 PM (in response to Lockjaw43)

    Hello Lockjaw43. No Apple here.  We're all fellow users. 

     

    Where did you get the idea Numbers has no Save As? In File menu just hold down the option key and you'll see it. 

     

    Calendar sync is different from Documents & Data.  You might want to doublecheck that this is checked:

     

    iCloud-system-pref-doc-data.png

     

    AND this is checked (after clicking options):

     

    iCloud-system-pref-Numbers.png

     

    And on your iOS devices you also need to turn on sync in two places:

     

    Settings > iCloud > Documents & Data > Numbers

     

    Settings > Numbers > Use iCloud

     

     

    SG

  • Lockjaw43 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 17, 2014 6:49 PM (in response to SGIII)

    I'm a relatively recent Excel migrant so forgive not knowing about Option-clicking, but all those are checked, and I did a 'save as' and the new doc still hasn't appeared. It was working flawlessly up til Mar 14 but nothing since and I have changed nothing in my setup or networks.

  • SGIII Level 4 Level 4 (3,290 points)
    Currently Being Moderated
    Mar 17, 2014 7:00 PM (in response to Lockjaw43)

    That's puzzling.  Have you checked the folder where Numbers keeps local copies of documents it syncs with iCloud?  To get there in Finder hold down the option key (yes, the option key can be pretty handy!)  and in the menu Go > Library > Mobile Documents > com~apple~Numbers. If there is nothing there, or everything is old, then your recent documents aren't in iCloud.  I assume for each document you want to sync that you've already checked to see that 'iCloud' is chosen in the dropdown to the right of 'Where:' in this spot:

     

    Screen Shot 2014-03-17 at 9.55.10 PM.png

     

    SG

  • Lockjaw43 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 17, 2014 7:57 PM (in response to SGIII)

    Thanks again for all your help. Yes -iCloud is where the doc lives- as I mentioned it was syncing fine until it wasnt. And thanks for the Mobile Docs tip- the correct updated versions are in the Mobile Docs folder in my MB Pro so what does that say as far as the source of the problem? If I didnt mention- the Calendar updates fine so it isnt a global iCloud issue as far as I can tell.

  • Lockjaw43 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 17, 2014 7:58 PM (in response to Lockjaw43)

    And all my devices are on the same network and I've restarted all of them to no avail.

  • SGIII Level 4 Level 4 (3,290 points)
    Currently Being Moderated
    Mar 18, 2014 6:53 AM (in response to Lockjaw43)

    If you do see the documents in the Mobile Documents folder then it seems Numbers is doing its part -- saving them where the iCloud daemons are supposed to come and whisk them off up into the cloud.

     

    You could try this. Drag the documents out of the Mobile Documents > com~apple~Numbers folder onto the Desktop and give iCloud some time to resync.  Then drag them back into the folder and let iCloud resync again.

     

    Documents & Data sync is, I understand, a different protocol from calendar sync. That probably explains why you can get calendar sync but not Numbers sync. The fact that you have calendar sync enables you to rule out other possibilities and focus in on the documents.  Dragging out of the folder and then back in may give iCloud the "kick in the pants" it sometimes needs to restart the sync.

     

    First be sure to download and back up any documents you see at icloud.com--just in case.

     

    SG

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.