1 2 Previous Next 18 Replies Latest reply: Jan 11, 2013 11:24 AM by Michael Heckner
Michael Heckner Level 1 Level 1 (5 points)

Hello

 

Since I upgraded to Mountain Lion (or 10.8), I see a lot of issues with Mail. It loses from time to time passwords, smtp settings and I need to reconfigure in order it works well.

 

Today I did it again, after I could not connect to any of the SMTP Server (4 of them). So I have redone everything, all settings, everything typed in new. At the end, it worked well, I received and could send mails. I closed Mail and before I shut down the Computer, I wanted to send another mail and opened Mail again.

 

What the heck happened? Despite my "iCloud" account, all other accounts (8 for different family members) disappeared. Not only I could not see any of the inboxes - no, in the settings "accounts" I only can find the iCloud account.

 

Oh Apple, I am really getting sick and tired about this. I had opened a call and got some support, but at the end of the day, it did not help at all. And now? This is a nightmare.

 

So, anyone else who has seen this and one of you who could fix the issue?

Are there any limitations with Mail? Eg in some past MS Outlook version there had been limitation on size of PST folders and numbers of offline folders. Anything known here?

 

 

 

Thanks

 

Cheers

 

Michael

 

PS:Using Mountain Lion with all the updates. The issue with the lost passwords and SMTP settings happened after I upgraded to Mountain Lion and I faced the issue several times before I contacted support. So, I have done several times the configuration already.


MacBook Pro (Retina, Mid 2012), OS X Mountain Lion (10.8.2)
  • 1. Re: Mail forgets, forgets, forgets...
    Linc Davis Level 10 Level 10 (118,030 points)

    Problems such as yours are sometimes caused by files that should belong to you but are locked or have wrong permissions. This procedure will check for such files. It makes no changes and therefore will not, in itself, solve your problem.

    First, empty the Trash.

    Triple-click the line below to select it, then copy the selected text to the Clipboard (command-C):

    find . $TMPDIR.. \( -flags +sappnd,schg,uappnd,uchg -o ! -user $UID -o ! -perm -600 -o -acl \) 2> /dev/null | wc -l

    Launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Paste (command-V) into the Terminal window. The command may take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear.

    The output of this command, on a line directly below what you entered, will be a number such as "75." Please post it in a reply.

  • 2. Re: Mail forgets, forgets, forgets...
    Michael Heckner Level 1 Level 1 (5 points)

    Hello Linc

     

    First, thanks for your reply. I got the number 324 as return.

    Secondly, I was shocked after I checked mail today. I didn't realize yesterday evening - everything is gone. Even the messages stored in the offline folders...

     

    I will try to restore from time machine

     

    Cheers

     

    Michael

  • 3. Re: Mail forgets, forgets, forgets...
    Linc Davis Level 10 Level 10 (118,030 points)

    Back up all data.

    This procedure will unlock all your user files (not system files) and reset their ownership and access-control lists to the default. If you've set special values for those attributes on any of your files, they will be reverted. In that case, either stop here, or be prepared to recreate the settings if necessary. Do so only after verifying that those settings didn't cause the problem. If none of this is meaningful to you, you don't need to worry about it.

     

    Step 1

    If you have more than one user account, and the one in question is not an administrator account, then temporarily promote it to administrator status in the Users & Groups preference pane. You can demote it back to standard status when this step has been completed.

    Triple-click the following line to select it. Copy the selected text to the Clipboard (command-C):

    sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -R $UID:20 ~ $_ ; chmod -R -N ~ $_ 2> /dev/null

    Launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Paste into the Terminal window (command-V). You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. If you don’t have a login password, you’ll need to set one before you can run the command.

    The command will take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear, then quit Terminal.

    Step 2

     

    Boot into Recovery by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.

    When the OS X Utilities screen appears, select

    Utilities Terminal

    from the menu bar. A Terminal window will open.

    In the Terminal window, type this:

    resetpassword

    That's one word, all lower case, with no spaces. Then press return. A Reset Password window will open. You’renot going to reset a password.

    Select your boot volume ("Macintosh HD," unless you gave it a different name) if not already selected.

    Select your username from the menu labeled Select the user account if not already selected.

    Under Reset Home Directory Permissions and ACLs, click the Reset button.

    Select

    Restart

    from the menu bar.

  • 4. Re: Mail forgets, forgets, forgets...
    Michael Heckner Level 1 Level 1 (5 points)

    Hi Linc

     

    I am currently in the mittle of the process. However, before I saw your mail, I'll tried to recover mail settings and mail folders from time machine. I got the error "aborted. You don't have sufficient access (free translation) for info.plist.

     

    Althoug I upgraded account now to admin

     

    Any hints on this as well?

     

    I searched data base here and try to recover V2 subfolder in Mail folder.

     

    Thanks

     

    Michael

  • 5. Re: Mail forgets, forgets, forgets...
    Michael Heckner Level 1 Level 1 (5 points)

    Hello Linc

     

    Gone through the process. Terminal now returns value 2735

     

    I couldn't manage so far to recover mail from TM...

     

    Cheers

     

    Michael

  • 6. Re: Mail forgets, forgets, forgets...
    Linc Davis Level 10 Level 10 (118,030 points)

    The following is an exception to the rule that you should never make any changes to backup data. I've tested this procedure in OS X 10.8 only. I don't know whether it works in earlier versions of OS X. Use this procedure only for files that were backed up from your home folder, or a folder on another volume created by you, and would normally be writable by you. Do not touch backups of system or application files.

    In the Finder (not in the time-travel view), navigate to the backup volume, then to the folder named "Backups.backupdb", and then to the snapshot you want to restore from. The snapshots are folders labeled with the date when they were created. Inside each of those folders is a file hierarchy like the one on the volume that was backed up. Descend through the hierarchy until you come to a folder named "Users," and inside that, a folder with your user name. The procedure will be different if you're trying to restore files on another volume.

    Select the folder and open the Info dialog (command-I). Click the padlock icon in the lower right corner of the window and authenticate. In the Sharing & Permissions section, give your account Read & Write access. You may have to close the window and repeat this step in order for the change to show up. Then click the gear icon and select Apply to Enclosed Items from the popup menu.

    Try the restore operation again, in the time-travel interface.

  • 7. Re: Mail forgets, forgets, forgets...
    Michael Heckner Level 1 Level 1 (5 points)

    Hello Linc

     

    Thanks for the help offered. As folder Library under user name was not shown (hidden), although I have switched it on, I did this for folder username. Now I get same error message, but with a different file name. Frustrating.

     

    I am now restoring from mail all the folders one by one. Takes a bit more time and I think I will lose mails from last 2 days, but that is fine. Despite I have to setup all acounts again manually.

     

    I hope I coudl solve the initial issue I was posting with your help.

     

    Again. thanks for the help you offered and for the quick turn around time.

     

    Cheers

     

    Michael

  • 8. Re: Mail forgets, forgets, forgets...
    Linc Davis Level 10 Level 10 (118,030 points)

    You will never get back to normal if you don't fix the permissions of your home folder. If you restore bad permissions from Time Machine after doing that, the permissions will be wrong again.

  • 9. Re: Mail forgets, forgets, forgets...
    Michael Heckner Level 1 Level 1 (5 points)

    So, you suggest to do same procedure after restoring the folders from within Mail, correct?

    Makes sense that way and I will do.

     

    I am just raising some question marks on TM. I do not feel save. Backup fine, restore a hassle. I am wondering there is no better solution, as it seems to be a access right issue.

     

    Cheers

     

    Michael

  • 10. Re: Mail forgets, forgets, forgets...
    Linc Davis Level 10 Level 10 (118,030 points)

    If I understand your report, you were unable to restore some files from backups. That's because Time Machine won't let you access files you don't have read permission for. I explained how to correct that. I suggest you take those steps, then restore. After that you may need to take the steps to fix your home folder again. When everything is back to normal, the number you get from the first shell command should be around 85, maybe less or a little more.

  • 11. Re: Mail forgets, forgets, forgets...
    Michael Heckner Level 1 Level 1 (5 points)

    After not being succesful yesterday with recovery of the mail/V2 folder (I followed your advice to change in the backup files the permission - but I just got another file named who is blocking; see my message from 23:22), I decided to recover the entire system, dated January 7th, today.

     

    Recovery is done, Mail issues are the same (sure).

    I copy/pasted the first terminal command from this thread. Return value now is 291350

    As a next step I copy/pasted the second terminal command in this thread and typed in the password. Now I get an error message

         username is not in the sudoers file. This incident will be reported.

     

    Anything else I can do?

     

    Cheers

     

    Michael

  • 12. Re: Mail forgets, forgets, forgets...
    Linc Davis Level 10 Level 10 (118,030 points)

    As I wrote above, you must be an administrator to carry out that procedure.

  • 13. Re: Mail forgets, forgets, forgets...
    Michael Heckner Level 1 Level 1 (5 points)

    Sure. Forgot that after recover I am back to user mode.

    Admin granted

    Rebooted

    Terminal started and copy/pasted first command - return value 0

    copy/pasted second command - done without error

     

    Shall I proceed further with rebooting and using OSX Utilities and resetting home permission?

     

    Michael

  • 14. Re: Mail forgets, forgets, forgets...
    Linc Davis Level 10 Level 10 (118,030 points)

    Yes.

1 2 Previous Next