3 Replies Latest reply: Jan 13, 2013 12:06 PM by blasure
blasure Level 1 Level 1 (0 points)

I've been having this issue for a while, and haven't found any solution as of yet.  I use iCloud to synch my calendars from my MacBook Pro with Mountain Lion to my iPhone 4S.  When events are synched to my phone, for some reason, they all automatically get an alert one day before the event, which I would really like to remove but I have a lot of events and it's a huge pain to manually go through and remove them all.  Is there any way to remove these alerts?  I've scoured all the settings (to my best knowledge) on both my phone and my computer and I have all default alerts turned off but I can't seem to find it.  I sent the calendars to the people in my classes and they have the same issue with alerts appearing on their iPhones and iPads.


iPhone 4S
  • 1. Re: iCal on iPhone creates alerts for synched events.
    mikebikemusic Level 1 Level 1 (0 points)

    I have the same problem with alerts coming up one day before even though every preference and every event has alerts turned off. This started within the last week. The two major things I did was: upgraded an iPhone to ios 6 and upgraded one of my macs to lion, which started merging calendar events and contacts (creating a rogue contact with hundreds of emails and phone numbers, but that's another story).

     

    I have seen it before that when you add a new OS feature, the default preferences sometimes don't act like the default. So I just went into the new lion's calendar preferences Alerts tab and deliberately changed the Events from None to 1 day before (the current bad behavior) Use these default alerts only on this computer is turned off. I then checked that the change propagated to another mac and then set Events back to None. I'm hoping this will force the change to go to the ios devices as well.

     

    If it doesn't, then what I will try is to go into each of my ios devices and do a similar thing: go into notification center for calendar and turn on alterts, then leave notifications, return to notifications and switch back to either banners or none.

     

    If that still doesn't work then I would delete each event that is alerting the day before and re-create them, to see if that helps.

  • 2. Re: iCal on iPhone creates alerts for synched events.
    mikebikemusic Level 1 Level 1 (0 points)

    I just found the smoking gun. I looked on icloud.com at the calendar events that were alerting and found that 1 day before was set there. So I am turning off each of them as I find them.  I don't know why, but the alert does not show up on the mac or ios devices with the 1 day before, just on icloud.com!

     

    MIke

  • 3. Re: iCal on iPhone creates alerts for synched events.
    blasure Level 1 Level 1 (0 points)

    I gave Apple a call; after talking to several people for about an hour (it seemed to stump about everyone) the only actual cure they could come up (rather than go and remove the alert for each event I make individually) with was to turn off the alerts in preferences>notifications on my phone.  It's a bit obnoxiuos and now I won't ever get notifications I DO want but I can set those ones to email me the notification instead.  Let's hope this is something that gets fixed in an update.  I'm a little disappointed in Apple for that one; they're usually pretty great about these kinds of things.