Skip navigation

Unable to download a podcast, only works under iOS iTunes store.

4245 Views 4 Replies Latest reply: Jan 9, 2013 7:50 AM by magomeara RSS
Sydtsai Calculating status...
Currently Being Moderated
Aug 11, 2012 10:14 AM

Dear all,

 

I has been trying to figure out why a certain podcast channel doesn't download under Podcast.app.

The episodes does download under iOS iTunes Store, but Podcast.app will prompt unable to download and ask to retry...

 

The podcast channel is called talkonly, a news channel can be searched in "talkonly",

 

Also, it's strange that streaming does work on both Podcast App and iTunes Store .

I have tried with same results on the new iPad too.

 

Thank you.

iPhone 4, iOS 5.1.1, the podcast "talkonly"
  • Londongeek Calculating status...

    I have something similar with the wizards of the coast dungeons and dragons podcast. The podcast app isn't even aware there have been two new episodes , but the iTunes app does and can be downloaded. However the iPod app can't find them even though the iTunes app states they are downloaded.

  • magomeara Calculating status...

    I have this problem for the Weather Eye Radio podcast also.  Downloads just fine through iTunes on my computer and through iTunes on my old iPod touch, but on my new gen 5 iPod with the podcast app, I can't get a single episode to download.  Other podcasts will download just fine.  I'm really hating the podcast app.

  • david267 Level 1 Level 1 (25 points)

    Look on your device and tap the right side of the podcast to see if you are subscribed. If you are, all the available episodes will be listed, but not yet downloaded. A little down arrow will indicate it still needs to be downloaded. In the settings you can set how many are downloaded and how many are kept.

     

    Apple needs a good manual or video to cover this. I think they are playing catchup.

  • magomeara Level 1 Level 1 (0 points)

    I am subscribed and it's set to download and keep all podcasts.  When I hit the down arrow to manually download the episode nothing happens.  It will not download any episode I try. 

     

    It has nothing to do with the instructions- some podcasts work as they are supposed to.  The app needs to be fixed or scrapped. iTunes worked and still works just fine for all podcasts I've tried.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.