Skip navigation

How do I update Aperture 2.1.4 to run on OS 10.8.2

918 Views 11 Replies Latest reply: Jan 14, 2013 10:39 AM by Ernie Stamper RSS
DocKin Calculating status...
Currently Being Moderated
Jan 8, 2013 8:34 PM

I was running an older Mac ,10.5.8, and transferred most of my apps to my new Mac 10.8.2.  I can't run Aperture 2.1.4 on the new Mac.  Any way to update Aperture 2.1.4 to be able to use it on the new Mac?

 

Thanks

  • léonie Level 8 Level 8 (46,580 points)
    Currently Being Moderated
    Jan 8, 2013 10:49 PM (in response to DocKin)

    From 2.1.4 to 3.4.3 is not an update but an upgrade.

    You will have to buy it from the App Store.

    See my answer in this thread on what precautions to take when upgrading:

     

    Upgrading from Aperture 2.1.4 to Aperture 3

     

    But Aperture 2.1.4 does run on Mt. Lion; there are some bugs, like brushes not working properly, but it does run. But there are no bug-fixes for Aperture available. How did you migrate, that Aperture does not launch? Or is your problem, that yo cannot run the installer on your new mac?

  • Ernie Stamper Level 8 Level 8 (37,455 points)
    Currently Being Moderated
    Jan 9, 2013 10:35 AM (in response to DocKin)

    It is best to not migrate apps, but rather to install them fresh from the discs you have.  If you have those for 2.1.4, try deleing it from the Applications folder, and reinstalling.  Your data is not contained in the application, so deleting it will not threaten your prior work.

     

    Ernie

  • léonie Level 8 Level 8 (46,580 points)
    Currently Being Moderated
    Jan 9, 2013 10:58 AM (in response to DocKin)

    You need an Aperture version, that is universal, not a Power PC version. What do you see, when you select Aperture in the Finder and use the command " File > Get Info" - does it say "Application (Power PC)" or "Application (universal)"?

     

    If you do not have a universal version, try to reinstall from the latest Aperture 2 update: http://support.apple.com/downloads/Aperture_2_1_4(or use it to upgrade your Aperture on on old mac to an universal version.

     

    If you can install it, use it to repair and rebuild your Aperture 2 library. And then I'd consider to upgrade to Aperture 3. As I said, Aperture 2 has some problems with Mt. Lion, and is no longer supported by Apple. You will get no bug-fixes.

     

    Regards

    Léonie

     

    For example:

    powerpc.png

  • léonie Level 8 Level 8 (46,580 points)
    Currently Being Moderated
    Jan 10, 2013 1:10 PM (in response to DocKin)

    but when I tried to open the new installed Aperture the message says my OS will not recognize 2.1.4 and you must upgrade to at least 3.0.

    I never heard that happen; there are quite a few Aperture 2 users posting here. Probably they migrated Aperture 2 from a Lion system.

    But it would be worth it to upgrade to Aperture 3; there are many improvements. And Aperture 3 from the App Store is no longer as expensive as the previous Aperture versions used to be.

  • William Lloyd Level 6 Level 6 (19,220 points)
    Currently Being Moderated
    Jan 10, 2013 2:09 PM (in response to DocKin)

    There is certainly a version of Aperture 2.1.4 that is a Universal binary and will run on Lion.  Others here have done so.

     

    That said, Aperture 2.1.4 is quite old and there is at least one issue that has been mentioned here (the loupe doesn't work, according to reports).

     

    Really, the best course of action on 10.8.2 is to buy Aperture 3.4.2 on the Mac App Store and go that route, if you're looking to continue using Aperture.  It's much enhanced over Aperture 2.x.

  • Ernie Stamper Level 8 Level 8 (37,455 points)
    Currently Being Moderated
    Jan 10, 2013 2:11 PM (in response to DocKin)

    Don't understand this behavior.  Where do you get to in attempting to install?  On my Mac Pro with Lion, I just mounted a boot disk, but did not boot into it, but instead accessed the applications on that disc which included Apertue 2.1.4.  It opened and allowed me to create a new library for 2.1.4 (whiich I did NOT import into).  In the Activity Monitor, it was running as Intel, and not PPC.  From its location, Get Info reported that it was an Universal app.

     

    When I tried to do the same on my rMBP with Mountain Lion, it opened as far as the registration, but I did not attempt to find that Serial # and activate.

     

    Ernie

  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Jan 14, 2013 10:08 AM (in response to DocKin)

    When you try to open Aperture are you opening on an existing library or are you opening on a new empty library?

     

    Don;t remember if the key sequence ins the same in 2 as in 3 but what happens if you hold down the option key while starting Aperture? Do you get a library choice window? If so try creating a new empty library and letting Aperture open.

  • Ernie Stamper Level 8 Level 8 (37,455 points)
    Currently Being Moderated
    Jan 14, 2013 10:39 AM (in response to DocKin)

    For definition of Boot Disk, see:

     

    http://en.wikipedia.org/wiki/Boot_disk

     

    The only thing important about my exercises is that I could take an Application available on another disk drive in my Mac Pro, and could successfully launch the prograrm to run in this Intel Mac Pro running in one case 10.7.5, and in another case 10.8.2..

     

    Once I did so, I looked in the Activity Monitore and found 2.1.4 was running as an Intel program, and and not Power PC.

     

    Ernie

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.