Skip navigation
This discussion is archived

Losing  Xsan volumes when internet link goes down

1325 Views 8 Replies Latest reply: May 17, 2006 5:05 AM by Michiel Nouwens RSS
rcsjt Calculating status...
Currently Being Moderated
Apr 7, 2006 12:54 AM
Please help!
While I know that Xsan isn't-- or at least shouldn't be-- dependent on an internet link, I have run into this problem where our Xsan volume becomes slow and unresponsive, and eventually stops mounting whenever our WAN link goes down (our ISP has been having some major problems recently so this has been occuring frequently). At first glance it looks like a DNS issue...whenever the WAN link goes down and Xsan starts acting up, Xsan admin starts showing weird stuff like displyaing machines by IP address rather than names.

We have 5 G5 edit bays, 2 Xserve G5's serving as nothing but mdc's, and they're all set to query ONLY the DNS servers in our internal LAN (and the DNS servers are on Xserves separate from the mdc's). The DNS servers are the only machines that have any reference of our ISP's public DNS servers at all.

We had our implementation set up by a consultant directly from Apple, so I'm pretty sure it was done right. It has been running very well in the meantime (whenever we DO have a solid internet connection), but it falls apart whenever the WAN link goes down (which should be completely unrelated to Xsan, right?) The minute our WAN link comes back online, Xsan turns rock solid again...

Anybody have any ideas? Any help would be much appreciated. We're already having enough problems losing our internet connection, but it really hurts when it takes Xsan along with it.

Thanks!
JT

   
  • sapridyne Level 1 Level 1 (130 points)
    Currently Being Moderated
    Apr 7, 2006 7:40 AM (in response to rcsjt)
    Is your metadata on a seperate LAN? If not, then it wasn't implemented correctly. Losing your Internet link -- or your main LAN (I'm assuming in this case) shouldn't affect Xsan one bit.

    Thanks,
    Sapridyne
  • IHateFriction Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 7, 2006 10:53 AM (in response to rcsjt)
    This may have nothing to do with your problem, but...
    In System Preferences, under Network, when you click on Show: Network Port Configurations, the port you use for the internet connection should be listed above the port for your metadata. Just a suggestion, keep in mind that it may be something simpler than DNS. Or not. Who knows?

    Many   Mac OS X (10.4.3)   Xserve, RAID, Xsan, you name it
  • James Knotts Level 1 Level 1 (55 points)
    Currently Being Moderated
    Apr 10, 2006 6:55 AM (in response to rcsjt)
    Is it possible that on your metadata controllers and possibly even your servers and RAIDs that your gateway is set to your EXTERNAL gateway as opposed to your internal DHCP machine? That would cause this kind of issue if it cannot reach the internet. Even if it doesn't use it, it still checks it and gets a litty "moody" if it's not there.

    Just a thought.
    PowerBook G4 1.67GHz, 2GB RAM, 160GB HD, Mac OS X (10.4.5), XServe G4 Dual 1.33GHz, 2GB RAM, 500GB
  • AppleUser2006 Calculating status...
    Currently Being Moderated
    Apr 19, 2006 9:56 PM (in response to rcsjt)
    Does anyone have any advice. I have the exact same setup and the exact same problem.

    My General Office LAN is 10.0.10.x with a Cisco PIX router at 10.0.1.1. Each machine has a fixed IP in the 10.0.10.xxx range. My XSAN metadata network does not have a router, and each machine has a fixed IP in the 10.0.50.xxx range. If I start up with the Cisco PIX router turned off, the nodes do not connect to the XSAN.
    G5, Mac OS X (10.4.6)
  • PaulRS Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 15, 2006 1:26 PM (in response to rcsjt)
    Try this: In Server Admin, DNS Settings turn off both Zone Transfers and Recursion. This will keep the DNS service from going outside for requests or forwarding your DNS info to outside servers. This means that your client computers must also list an outside DNS (in addition to your internal one) in order to get on the internet.

    -Hope this helps
    G5, Mac OS X (10.4.6)
  • Michiel Nouwens Level 2 Level 2 (290 points)
    Currently Being Moderated
    May 17, 2006 5:05 AM (in response to PaulRS)
    The lookup order for hostnames is default:
    LookupOrder: Cache FF DNS NI DS

    So by manualy editing the /etc/hosts file you do not depend 100% on your DNS which is good...

    Your DNS should always reflect the right IP addresses for hostnames and vice versa... You should check this I think...

    netstat -nr should provide you the default routing table...

    MacOs X doesn't function correctly without a gateway for your NIC's...

    Goodluck!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.