Skip navigation

Excel for Mac Running Very slow

42286 Views 52 Replies Latest reply: Apr 17, 2014 3:14 AM by kurbads RSS
  • stocky2605 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 24, 2012 4:44 AM (in response to Sameesunkaria)

    - whith this particular HUGE excel file, Numbers (iWork) is very slow, not as slow as Excel 2011, but still MUCH slower than OpenOffice and Office 2003 running in my virutal environment (it's Windows with Parallels and it is faster!)

    - there is no 100% compatibility

     

    I LOVE iWork - for personal use, not for business (compatibility issues)

  • stocky2605 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 24, 2012 4:57 AM (in response to stocky2605)

    one important hint: my huge Excel file here has a lot of filters, if I remove them scrolling is well. As I said before, OpenOffice and Win Office 2003 with active column filters don't have any issues regarding performance.

  • leo7777777 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2012 6:22 PM (in response to leon21)

    I have the same problem. Running 10.7.4 on a MacAir with Excel for Mac 2011. The only solution I found so far is to create a new (standard) user. Running the same spreadsheet is up to speed when logged in as the new user. But still haven't figured how to get Excel to run fast when logged in as administrator. Tried to delete duplicate fonts in Font Books App as suggested over web, but didn't see difference. Also suggested was to delete microsoft excel prefs in Library, but couldn't find them.

  • LAgnoletto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2012 5:32 AM (in response to leon21)

    I have the same problem... Upgrade from Notebook HP to Macbook air, i5 1,8GHz, 4gb 1600MHz DDR3, Excel 2011....

     

    It is IMPOSSIBLE to use Excel on Mac... Can't scroll.. Can't edit cells... Can't SELECT cells...

     

    I tryed every tip told above, but still doesn't work for me!

     

    Please, someone help us..

     

    Thanks,

    Lucas

    MacBook Air, Mac OS X (10.7.5), About Office 2011 ( Excel )
  • leo7777777 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2012 5:13 PM (in response to LAgnoletto)

    Lucas,

     

    Have you tried to creating and logging in as a new user? I can only run my large excel files when I login as user other than the main admistrator. So just create a new user with System Preferences under 'Users and Groups'. Log out of the main user, and log back in as the new user. Excel speed difference 100x in large files. No problems with small spreadsheets. Using Excel for Mac 2011 version 14.2.4 on Macbook Air running 10.7.5

     

    Hope this works. Good luck.

     

    Leo

  • LAgnoletto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 10, 2012 7:53 AM (in response to leo7777777)

    Leo,

    Thanks for reply. I made it, but no result.

     

    I have to create a Virtual Machine and use the Windows Excel instead the Mac Excel.

     

    That is no good, because im trying to homologate the Mac OSX to my company and i'm facing a lot of problems.

     

    Regards,

    Lucas

  • dwb Level 6 Level 6 (19,710 points)
    Currently Being Moderated
    Nov 10, 2012 8:01 AM (in response to LAgnoletto)

    The Mac version of Excel is slower than the Windows version, but not to the degree that you are experiencing. There must be something wrong. Have you attempted reinstalling office after doing a complete delete. Have you taken a look at the activity monitor while running Excel? I use the program daily and I'm not experiencing anything like what you are describing.

  • chris D\'Costa Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2012 3:51 AM (in response to leon21)

    Hello All

     

    I was pulling my hair out because of this problem, and was particularly annoyed because the older version of Excel runs fast, but of course it can't open the new .xlsx files. I wanted to upgrade because I also use Excel at work on a PC and I love the ribbon.

     

    I have found the answer and it's pretty obvious when you think about it...

     

    Turn off all the "Microsoft Knows Best" automatic checking that Excel (and Word and Powerpoint) do. Not just the font menu thing, but EVERYTHING in the preferences that does something "automatically".

     

    The only thing I left on automatic was the "autosave" feature.

     

    Now excel runs as fast as it's Windows counterpart.

     

    Chris

  • torasama Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 9, 2013 10:22 PM (in response to leon21)

    I never had any problems with Excel until I got a new Macbook Pro over the holidays (Jan 2013) with Mountain Lion pre-installed.  Then Excel just began running incredibly slow as everyone here has experienced.

     

    It definitely seems to be a Font related problem, and since I could create a new user on my machine and Excel ran fine from that login, I did some detective work with fonts and worked out a way to strip down fonts in my regular account log in.

     

    Keep in mind that I don't do any work with fonts really, so it didn't matter to me if I lost any special fonts because I never actively installed any...just accumulated alot of extra fonts over the years from various apps and rolling my data over through multiple Macbook incarnations.

     

    This is how I got everything running at normal speed again.

     

    1) Open Font Book Application

     

    2) Under EDIT, select LOOK FOR ENABLED DUPLICATES

     

    3) Automatically resolve any duplicates found

     

    4) Select all fonts, then under FILE select VALIDATE FONT

     

    5) Remove all fonts showing any type of error or warning.  Some will be system fonts and will require you to enter your password…go ahead and do it…get them all out of your system.

     

    6) Under FILE, select RESTORE STANDARD FONTS.  This will pull out everything except standard fonts.  You will probably get a message saying that some of the standard fonts are missing and asking you to restore them by reinstalling the operating system…don't bother doing it though.  The missing fonts are likely ones that got tossed out when you VALIDATED FONT and threw out the ones causing warnings/errors.

     

    7) Open your OS Library and look for the FONT folder.  You should also see FONTS (REMOVED) and FONTS DISABLED.  Open the FONTS (REMOVED) folder and find the MICROSOFT folder.  Drag this back into your FONTS folder…it will proceed to copy over. i.e. a copy will remain in FONTS (REMOVED) and a new copy will be formed in FONTS.

     

    8) Finally, for good measure use Disk Utility to repair disk permissions and then restart.

     

    This processed worked on my brand new Macbook Pro running Mountain Lion, as well as my wife's 2 year old Macbook Pro running Mountain Lion.

     

    I spent 3 hours searching forums and testing things yesterday and this finally worked...hopefully it can save others from wasting as much time as I was forced to.

  • leo7777777 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 10, 2013 12:26 PM (in response to torasama)

    Thank you. Deleting duplicate  and validating fonts worked great. Excel is working quickly now.

  • Matthew Gillard Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 3, 2013 4:10 AM (in response to leon21)

    I also experienced extreme slow down in Excel but not all the time. I cleaned up fonts and it happened less often. Today it did it again and I systematically closed down running programs then relaunched and tested typing speed in Excel each time. No change till I quit Dreamweaver 4 and then Excel was fine. This may or may not apply specifically to others but it shows that another program can affect Excel to the point that just typing in a cell takes approx a second per character to appear.

  • Rodrigo Baltuilhe Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 20, 2013 1:10 PM (in response to torasama)

    This really solved my problem!!! Thanks!!

  • Beth Ernst Level 1 Level 1 (45 points)
    Currently Being Moderated
    May 16, 2013 5:52 AM (in response to leon21)

    I don't know if this will be of any help to anyone but thought I'd offer up our experience. We were running Mac OS X Lion and the latest version of Office and had problems with Excel being horribly slow as well. I did some testing and noticed that when I turned off Suitcase Font Management that Excel ran fine. I assumed it was a confict with Suitcase so I contacted Extensis to see if they were aware of any issues with their product and Office. They did some testing on their end and could also reproduce the issue, but it turned out that it was not a conflict with Suitcase, but rather the fact that Office expects at least two of the Office fonts (Arial.ttf and Calibri.ttf) to be active. Since we use many fonts in our graphics businees we try to streamline our basic fonts and only have those active that we use on a regular basis so we had removed all Office fonts and did not have the expected fonts loaded. Once I added them back into our active fonts Office sped up quite nicely, No more slow copy, paste or print. So you may want to check out your fonts to make sure these two are active on your system. Since we use Suitcase for font management I simply loaded them in with our standard font set through Suitcase, but if you don't use Suitcase make sure they are in one of the appropirate Mac OS font folders so that they load at startup then reboot your computer and give Office another try. Hope this is helpful to someone.

  • DerWaschbar Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 20, 2013 9:30 AM (in response to torasama)

    Just a small precision about step 7) : the "MICROSOFT" folder is not located directly inside "FONTS (REMOVED)" but into another folder named with the time you emptied your font library.

  • CCHII Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 25, 2013 9:46 AM (in response to chris D\'Costa)

    Chris, how do you turn off Microsoft Knows Best is my first question.  2nd is how do you access your files if you sign in as a non administrator?  I have a new MacBookAir.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.