3 Replies Latest reply: Jan 28, 2013 1:37 PM by Christopher Murphy
bruban Level 1 Level 1 (0 points)

Mac OS X 10.8.2





I've recently upgraded to OS X 10.8.2 and am having great difficulty in mounting my NFS shares via the OSX GUI. This worked fine at OS X 10.6.


My aim is to provide an automount type of setup so that less experienced users don't have to worry about the command line.



Can someone please point me in the right direction here?



This is what I've tried to date.


My NFS service is hosted on my Debian server. It supports NFS v4. The service is working and stable and is used routinely with Ubuntu clients. It has also worked with OS X 10.6 clients in the past, but not with OS X 10.7 clients.


To date I have tried the following options:


  1. Mount via finder: Connect to server option using syntax: nfs://<user>@<server>/<share>
  2. setting up autofs using the instructions from pmbuko
  3. using the command line to mount the share.


The first option failed repeatedly.  I did find that it would eventually work, though only after I'd manually mounted the share at the command line.


I have not been able to get the second option to work.

  • I initiate autofs using the command 'automount -vc' and see that the connection is recognised
  • when I attempt to cd into a directory below the mount point, I eventually get the message 'Connection Refused'. 
  • when I check my Debian logs, I find that the NFS service had actually received an authenticated mount request from the Mac.
  • when I check my Mac Console logs, I see an error:
    • kernel: nfs_connect: socket error 61 for <server>/<share>


I was able to get the third option working, but only after using the '-o resvport' option.


'Something' does appear to be broken with OS X 10.8.2  as an NFS client.


Any thoughts?

MacBook Pro, OS X Mountain Lion (10.8.2)
  • 1. Re: can't mount NFS share via GUI
    bruban Level 1 Level 1 (0 points)

    I have found a work around that meets my imediate needs, though it doesn't allow me to use autofs functionality.


    The work around uses the traditional Unix/Linux approach of automatically mounting a file system or NFS share via fstab at boot time. OS X 10.8 still supports fstab, even though the file is not included in the default installation.


    Once mounted, the NFS share appears as if it is part of the normal file system.



    The following is only intended for people confident in Unix or Linux systems administration and in using a shell environment via the command line. Do not attempt this if you do not have these skills.


    To set up for fstab, do the following within a terminal session:


    • create an empty directory in your file system that you can use as your mount point for your NFS share:
      • sudo mkdir /data/share
      • sudo chown root:wheel /data/share
    • using your favourite editor, create the fstab file (in a terminal type 'man fstab' for details)
      • sudo vi /etc/fstab
      • add similar to the following to /etc/fstab and then save and exit, substituting your own values where appropriate



    # My NFS share


    <your-server>:/<your-share> /data/share nfs  resvport,rw,hard,intr 0 0



      • sudo chown root:wheel /etc/fstab
      • Please note: you may not need the resvport option in the fstab line above. It will depend on your NFS server's requirements.


    Once you have done this, reboot your Mac and your NFS share should be mounted at the mount point that you defined.


    If not, check your logs to see what went wrong.

  • 2. Re: can't mount NFS share via GUI
    RodneyW Level 4 Level 4 (3,030 points)

    I use NFS Manager by Marcel Bresink.  http://www.bresink.com/osx/NFSManager.html


    Works great!

  • 3. Re: can't mount NFS share via GUI
    Christopher Murphy Level 3 Level 3 (525 points)

    This isn't working for me either since upgrading to 10.8.2 from 10.7.5. I used to use:


    # sudo mount_nfs -o resvport,rsize=32768,wsize=32768 /Volumes/NFS

    mount_nfs: can't mount /export/back from onto /Volumes/NFS: Connection refused


    I've also tried:

    # sudo mount_nfs -o resvport,rw,hard,intr /Volumes/NFS


    But I get the same error message. On the linux side, there are no messages, nothing in dmesg, nothing in journalctl. In the OS X Console I have a message:


    Jan 28 14:30:09 ming kernel[0]: nfs_connect: socket error 61 for