Skip navigation

ML server - SMB mount from Linux impossible

1307 Views 9 Replies Latest reply: Jan 10, 2013 4:23 AM by tim_r_66 RSS
nick-without-a-name Calculating status...
Currently Being Moderated
Sep 26, 2012 8:57 AM

Hello all,

 

For a few year I ran my SL server without a hitch. Now the time has come to embrace ML server.

One thing though, is blocking my way.

Alongside my trusty Mac server I run a CentOS server. Using /etc/fstab this CentOS6 machine mounts a few folders over SMB which are located on the Mac server.

the /etc/fstab file is the automatic equvalent of manually mounting filesystems using mount command.

 

The lines in /etc/fstab are constructed as follows:

//<<ip of Mac server>>/<<sharepoint>> <<path to mountpoint on linux machine>> cifs user,uid=500,rw,suid,username=<<my_username@Mac server>>,password=<<my_password@Mac server>> 0 0

 

Bottomline: it's completely impossible to mount a SMB volume on my CentOS machine which is located on my ML server. Neither using fstab nor using the mount command.

Since I really need these mounts, I have returned to SL server. And, BINGO everything is fine again.

 

Can anyone shed some light on this matter?

Mac mini, OS X Server, CentOS Linux
  • JaimeMagiera Level 2 Level 2 (285 points)

    Any errors in the logs on eithe side? Apple switched to their on SMB in L and ML. There are some differences.

  • brycesteiner Level 1 Level 1 (0 points)

    There are plenty of SMB issues with Apple's file server. Try using SMBup and it should install Samba and get everything set up. It is frustrating because it should work perfectly. With SMBup I do have to turn it on each time I reboot.

     

    There may be another issue with yours specifically. I couldn't get it to work with the netbios name until I renamed the server (Apple SMB implementation, not Samba)

     

    I was able to get clients to connect but they would disconnect within minutes from Adobe Indesign within Windows. I switched the server to Samba and it's worked great since then.

  • haykong Level 1 Level 1 (115 points)

    I don't know if you are aware that SMBup 1.4.1 installs Samba 3.2.15 from Macports .. also If want to start automatically you need to download the launchctl files within the install of SMBup.

     

    The original author of SMBup.. worked with Samba 3.2.15 since that was the only samba version available at that time through Macports over a year ago.

     

    I haven't tried it yet, but I was considering installing Samba 3.6.7 through Macports on top of SMBUp... I don't know if anyone has tried that yet.

     

    I just not going to do it on my production machine.... might do it on a testbed machine soon.

  • brycesteiner Level 1 Level 1 (0 points)

    Hello Nick,

     

    I have had great luck with SMBup. I'm on 10.8.2. I had an issue for a while (after reboot Samba wouldn't be started), but Apple's SMB was messing with Samba even though SMBup said it was uninstalling or disabling Apple's SMB. I went into System preferences/sharing and turned off the SMB and that worked well even after restart. I haven't had any reliability problems with it for clients.

  • petroto Calculating status...
    Currently Being Moderated
    Jan 2, 2013 2:50 AM (in response to brycesteiner)

    thank you, finally it works

  • tim_r_66 Level 1 Level 1 (30 points)

    I just came across this post.  I've read that ML requires the nounix,sec=ntlmssp options to be used.  I've had some success with that but haven't fully tested.

     

    HTH, Tim

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.