Skip navigation

Air printing

1413 Views 7 Replies Latest reply: Jan 22, 2013 6:15 PM by bersfer RSS
Mcgrathtm Calculating status...
Currently Being Moderated
Jan 9, 2013 2:47 PM

I have just bought an epson wf 3520 air printer and can't print from my iPad. I have downloaded the iprint app and can print from there but not from emails or notes.

iPad 2 Wi-Fi
  • iLadyOK Level 2 Level 2 (155 points)
    Currently Being Moderated
    Jan 10, 2013 7:59 AM (in response to Mcgrathtm)

    hmmmn interesting, according to this list: http://support.apple.com/kb/ht4356

    you definitely have an airprint enabled printer, so therefore it should really work

    have you checked your settings on the ipad and printer etc?

    thats the first step, the second could be to try a free printing app and test it, such as printdirect on the app store

    see how you get on?

  • rccharles Level 5 Level 5 (5,155 points)
    Currently Being Moderated
    Jan 10, 2013 9:33 AM (in response to Mcgrathtm)

    Try powering everything off. ipad, printer, wifi router, modem.  wait 10 minutes power on devices.

     

    Robert

  • iToaster Level 3 Level 3 (585 points)
    Currently Being Moderated
    Jan 10, 2013 3:05 PM (in response to Mcgrathtm)

    if the printer is not configured to connect to your wireless network

    airprinting or the printer app will not work

    devices on your network will normally have a similar ip address

    eg 192.168.1.1, 192.168.1.2 etc

     

    since you posted this in ipad in the Enterprise, if your using a corporate wireless you may to speak to the network admin to get your printer connected correctly

  • kzimmerm Calculating status...
    Currently Being Moderated
    Jan 21, 2013 12:02 PM (in response to Mcgrathtm)

    I have this exact same printer and exact same problem.  I first opened a trouble call with EPSON and after about 4-5 emails they say it is an Apple problem not an Epson problem.

     

    WF-3520 - IP address assigned via DHCP.

     

    EPSON iPrint app finds printer.

     

    iPhone 4 & new iPad does not see the printer.

     

    2 Win7 computers prints to printer without issue. 

     

    If I power off the printer then power it back on I can sometimes find the printer on the IOS device. 

     

    Is it best to manually assign the IP address to the printer?

    Is it best to assign the IP address to the MAC address on the router?

     

    Thanks.

    Kurt

  • bersfer Calculating status...
    Currently Being Moderated
    Jan 22, 2013 6:15 PM (in response to Mcgrathtm)

    In my case, I bought Canon MX-517.

     

    I have 2 iPads [ iPad 1 and new iPad] and iPhone 4.

     

    With iPad 1 (IOS 5.3.3 - As you know IPad1 does not support IOS 6.0.1 ) it works well with airprint.

     

    My new iPad's software version is 6.0.1 and it doesn't work - It says "Printer is Offline"

     

    I tried airprint with my iPhone ( IOS 6.0.1) - Sometimes works well, and sometimes doesn't work. -"Printer is Offline"

     

    After tests , I think it on IOS 6.0.1. - 100% fail on new iPad (IOS 6.0.1)

                                                           50% fail on iPhone 4 (IOS 6.0.1)

                                                          100% success on iPad 1 ( IOS 5.3.3)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.