Skip navigation

10.8 Mail Server not sending Emails

2288 Views 33 Replies Latest reply: Jan 11, 2013 3:03 PM by lightspeedguru RSS
  • lightspeedguru Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 8, 2013 6:13 PM (in response to D0nEichi)

    Care to elaborate a little? I'm having the same problem but I have A and MX records on both my server and my domain registrar and as of upgrading to 10.8 Server my mail server won't send or receive email.

     

    The 'Forwarding Server' in my DNS panel is set to my router. I have one host name server.mydomain.com set to my server's IP and the create MX record checkbox is checked. When I show all, it expands the one entry into three lines that all say the same host name but with different words after them... 'machine', 'mail exchanger', and 'name server'.

     

    At my registrar, I created an A record for server.mydomain.com and pointed it to the static IP of my Mac mini... I created an MX record this name as well.

     

    What am I doing wrong?

  • UptimeJeff Level 4 Level 4 (3,390 points)
    Currently Being Moderated
    Jan 8, 2013 7:08 PM (in response to lightspeedguru)

    @lightspeedguru

     

    If you post your real domain, we can lookup your DNS.

    But yout post mentions that you upgraded to 10.8, so your problem is likely the server config and not DNS.

    (if your public DNS worked with an older server, it should work with the new).

     

    We need to see snippets from your mail logs.

     

    Post that info and we'll move forward.

  • lightspeedguru Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 11, 2013 3:03 PM (in response to UptimeJeff)

    I received this message from Apple...

     

    The problem you are encountering is a known issue and will be resolved in a future Server update. In the meantime you can resolve by going into Terminal and entering the following:

     

              sudo serveradmin settings mail:postfix:required_hits = 6

    Problem solved immediately!

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.