0 Replies Latest reply: Jan 11, 2013 5:12 PM by Ben222
Ben222 Level 1 Level 1 (0 points)

I have a brand new rMBP, which is, of course, running Mountain Lion, Safari 6.0.1.


When I am out, I try to connect to a hotspot wifi network that has a firewall login webpage. I cannot get the page to load, instead, Safari stalls out, saying that it "can't establish a secure connection to the server," with the little triangle with the exclamation point. It has worked fine for me for about a week (when I got the computer), but today the error has just randomly started, it seems.


I've researched this a bunch. I've tried:

- resetting Safari (multiple times)

- clearing the cache

- turning wifi on and off

- turning computer on and off

- fiddling with the DNS settings

- making sure the firewall has been turned off

- having no parental controls on

- clearing cookies

...and I cannot get the issue to go away.


It's strange, because it just started all of the sudden, it was working fine before. Before my new machine, my old MBP (also running Mtn Lion, Safari 6.0.1) had the same problem. It worked fine for a while, and then all of the sudden it could not establish a secure connection any more. My friend's MBP (2010 I think), running Snow Lepoard (unsure which version of Safari), has no problem connecting and never gets the error. Her's and mine can be right beside each other, and her's will work fine, but mine won't.


I'm beginning to think this is an error with Safari. Tonight I will download Chrome or Firefox and see if I get any different results the next time I'm out. Either way, I'm annoyed that my new $2500 machine is a glorified typewriter when I'm out and about. I thought I had this problem fixed.


Any suggestions from anyone? It's driving me nuts.



MacBook Pro with Retina display, OS X Mountain Lion (10.8.2)