Skip navigation

iPhoto on MBPr isn't showing thumbnails

369 Views 4 Replies Latest reply: Feb 17, 2013 3:36 PM by erikbiorn RSS
erikbiorn Calculating status...
Currently Being Moderated
Jan 12, 2013 10:06 PM

Issue: After migrating a 133 GB iPhoto library from my old MBP to my new MBPr I've been unable to see ~50% of the photo thumbnails.  The app has prompted me to go through a process of generating high resolution thumbnails, but in doing so (multiple 2-4 hour attempts) I've had to eventually force quit due to an endless process of trying to find "missing originals" (despite the transfer showing that all bits made the trip over).

 

Things I've tried: (1) Entered Photo Library First Aid to repair permissions, rebuild thumbnails, repair database, and rebuild database several times.  (2) Rebooted the computer.  (3)  Re-copied original iPhoto Library from the original computer and re-imported into the new.  (4) Scanned the Apple Support Communities looking for an answer.

 

I've seen quite a bit of discussion in the community forums about similar issues, but haven't found a solution that won't impact all the metadata.  I'm a long time Mac user - eager to start enjoying MBPr - but am exhausted from spending the entire day today trying to get this to work.  Is this a screwed up import, corrupt iPhoto library, or known iPhoto issue for users with retina display computers?  Any ideas out there?  Thank you! - Erik

 

Old System:  2009 MacBook Pro on Mac OS X 10.7.5 with iPhoto '11 (v.9.4.2)

New System:  2012 MacBook Pro Retina on Mac OS X 10.8.2 with iPhoto '11 (v.9.4.2)

MacBook Pro (Retina, Mid 2012), OS X Mountain Lion (10.8.2)
  • steve626 Level 4 Level 4 (1,395 points)
    Currently Being Moderated
    Jan 12, 2013 11:21 PM (in response to erikbiorn)

    Here's what I suggest, since you've used the Apple built in method to rebuild the Library but it didn't work.

     

    Download and purchase iPhoto Library Manager. It costs $20. If possible, start from the ORIGINAL iPhoto Library before you tried all the repair steps. I think this is better than starting with your rebuilt multiply iPhoto Library. but if you don't have that original iPhoto Library, then start from the one you have tried to rebuild.

     

    Have iPhoto Library Manager rebuild the iPhoto Library. As you no doubt already know, this can take ~ hours with a Library that size. One good thing about iphoto Library Manager is that it leaves the original Library untuched and creates an entirely new iPhoto Library based on all the photos it finds and info about them, contained in the previous Library.

     

    I don't know why you are experiencing this. I and many others have successfully migrated older iPhoto Libraries over to new Macbook Pro Retina computers. Every so often, someone does run into a problem. I would suspect some small corruption in the Library is preventing the updating of the thumbnails. IPhoto Library Manager is the best tool for repairing this.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.