Skip navigation

Aperture 3.4.3 not reading version 1.5.6 library

504 Views 3 Replies Latest reply: Jan 20, 2013 11:33 AM by léonie RSS
capn Earl Calculating status...
Currently Being Moderated
Jan 13, 2013 4:57 AM

I have had no success in version 3.4.3 accessing the 1.5.6 library.  It has attempted over 2 days to rebuild the old library and while it finishes the task, no pictures and associated data are available.  The size of the new library is twice that of the old one, but again, nothing is available.  Any ideas?

Aperture 3, OS X Mountain Lion (10.8.1)
  • léonie Level 8 Level 8 (46,525 points)
    Currently Being Moderated
    Jan 13, 2013 11:40 AM (in response to capn Earl)

    Do you still have your old system, Aperture 1.5.6, and the Aperture 1.5.6 version of your library?

    Then you might try to rebuild the Aperture library, before you try to upgrade it to Aperture 3. This is recommended in the Aperture 3.4.3 release notes http://support.apple.com/kb/TS2518, see the paragraph "Additional Information" at the end:

     

    If you are upgrading your Aperture library from an earlier version of Aperture, here are some guidelines to assist you in a successful move to Aperture 3:

     

     

    • Before upgrading, it is recommended (though not required) that you perform a rebuild of your Aperture library. To rebuild an Aperture library, hold down the Option and Command keys while opening your library in Aperture 1.5 or 2, then click the Rebuild Now button.
    • Aperture temporarily uses extra space on your hard drive during the upgrade process. This is for the purpose of backing up critical library info and insuring the integrity of your data during upgrade. If you don't have adequate space on your hard drive to accommodate the upgrade, Aperture will display a warning dialog. You may need to move your library to a different hard drive with more space in order to upgrade it, and then move it back to the original drive when the upgrade is complete. Any space used by Aperture during the upgrade is released and made available to you again once the upgrade has finished.

    Is Aperture still processing? If your library is large, this process may take a very long time.

    It has attempted over 2 days to rebuild the old library and while it finishes the task, no pictures and associated data are available.  The size of the new library is twice that of the old one, but again, nothing is available.  Any ideas?

    How large is your library? Also from the release notes:

     

     

    Keep in mind that fully upgrading a very large library is a one-time process that can take a long time; the process may take many hours or even overnight, depending on the size of the library. Once the initial database upgrade is complete, you can begin working with your Aperture library. However, post-upgrade processing will continue in the background for some time, as face detection and preview generation are performed. (A progress indicator and the word "Processing" will appear in the status line of the Viewer or Browser to indicate these operations are underway.) While you can work with Aperture while these operations are performed, you may experience temporary slow-downs. Optimal performance will return when all post-upgrade processing is complete.

     

     

    Regards

    Léonie

  • capn_earl Calculating status...
    Currently Being Moderated
    Jan 20, 2013 10:37 AM (in response to léonie)

    Well it took several trys but it finally worked - thanks Leonie!  I can't be sure what the finally issue was but your reference to rebuilding in 1.5.6 I think was key.  After that, version 3 still did not want to work using my NAS disk.  When I copied the library to my iMac it completed it's own rebuild.

     

    Thanks much!

     

    Capn_Earl

  • léonie Level 8 Level 8 (46,525 points)
    Currently Being Moderated
    Jan 20, 2013 11:33 AM (in response to capn_earl)

    You are welcome.

     

    After that, version 3 still did not want to work using my NAS disk. 

    Yes, Aperture needs a drive formatted MacOS X Extended. Thanks for letting us know that it is now working. 

     

    Léonie

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.