Previous 1 2 3 4 5 Next 161 Replies Latest reply: Dec 10, 2014 1:04 PM by gd0 Go to original post
  • IMRAN Level 2 (475 points)

    Count me on these increasingly dangerous mid-data-transfer ejects, even of things that do not have fancy drivers (e.g. camera memory cards) since Mountain Lion. The problems are NOT limited to USB. They happen on FireWire 800 on my MacBook Pro as well as on USB with or without a hub.



  • Blinksmom Level 1 (0 points)

    Count me in too!  I have Mountain Lion that came with a brand new Mac Mini. I am also running VMFusion to enable running a necessary windows program. ML keeps ejecting my FreeAgent Goflex drive. It can hold onto it for a while but randomly ejects it. sometimes after several days of running ok. I have disabled all the screen savers and sleep mode on both halves of the computer. (windows side and mac side). In order to leave everything on. (it seemed that when the screen saver ingaged the disk would eject when coming out of screen saver.)  We now have to turn off the monitor rather than putting the computer to sleep. While this works better the disk still ejects after several days of being on or the entire computer freezes.


    Sometimes the mac freezes and we don't know it because the windows side is still working but when we switch to mac mail for instance, we notice the computer mac side is frozen and then the windows side wont work and we have to do a hard shut down. Not a nice thing to do.


    Now we are having trouble with the printer ejecting from either the mac or the windows. (both the printer and external disk are plugged in using the usb ports)  For the life of us we cannot figure out what is causing all these problems.


    I have mountain lion on my macbook pro as well (as an upgrade) and I am haveing problems with it seeing my wireless printer that is in the same room. It was working with lion. Apple come on help us out here!

  • eosman Level 1 (0 points)

    My Macbook Pro 2012 still ejects my westen digital passport on the right port. I downloaded firmware that actually said it addressed some issues with Mountain Lion. Though I imagine Apple needs to put out a patch to fix this as its not just with Western Digital but a lot of USB devices.

  • hawkphotography Level 1 (0 points)

    Just got the new 27" iMac i7, 1TB Fusion, 680MX and am having THE EXACT SAME USB# PROBLEMS as all of you!  Glad I'm not alone, but the *** Apple?  $2800 machine and I can't WORK to pay for it???  I spent half my day today trouble shooting, reading forums, techtools, disk warrior, synchronize prox backups via ethernet to my MBP because I can't get my Burly Enclusures online eitther (another point of frustration).  I thought I could at least hook up ONE drive via USB3 to get work done while I figured out what was up with the burly's and the new USB3 port multiplier boards I bought and installed (drives all just eject and remount and eject again randonely)  This is messing up my ARCHIVES, I can't afford to corrupt discs, lose files, and waste a bunch of time trying to solve a problem that APPLE should handle QUICKLY.  Been a mac user since 2004 and I am ******.  Please, someone, help me. 


    <Edited By Host>

  • Frank Miller2 Level 2 (170 points)

    You should know that Apple does not respond to posts here.  This is a user-to-user forum.  To help solve your problem, you could take your machine to an Apple Store, contact Apple at (800-275-2273), or try to contact Apple Customer Service online.   might be a place to start.


    And, please don't post personal info like a phone number.  You never know who might read it.




    Message was edited by: Frank Miller2

  • Kyle Clausen Level 1 (5 points)

    I also have this issue.  Mac Pro, 2 1TB Buslink encrypted drives.  I can't operate these using firewire as they will unmount randomly throughout the day.  I have them hooked up now using USB and things seem to be more stable but I really need them via firewire 800.  I have tried most common solutions with no success.

  • sdb10024 Level 1 (0 points)

    This is happening to me as well with both my external drives attached through my Cavalry powered 2.0 USB dual bay. I'm on a new 2.6 GHz/8GB MBP. Have tried both this dual bay drive and a ThermalTak BlackX USB 3.0 dual bay. Its not even specifically a sleep/wake up issue. It happens as I'm working! Think I've now hosed one of the 2 drive and hoping I can repair the other. NOT pleased. ThermalTak says its not their fault but Apple's OS.

  • Hans_vA Level 1 (0 points)

    I have a new 27" iMac and a Lacie 4Big Quadra 16TB USB3 disk array.

    I have been trying different things for the past couple of weeks.

    The drives function fine fore a couple of hours and then spontaneously eject with the "... improperly ejected ..." message.  Pulling the USB3 cable out and plugging back in usually solves the issue, but not always.


    I received a replacement Lacie yesterday but it has the exact same issue.

    I have tried both units on my rMBP, also exact same issue.


    Both machines run ML 10.8.2 and show no software updates.

    The iMac is a full clean install, no data, apps or settings on it whatsoever.


    I have a support ticket with Lacie, but apart from the replacement unit, got no further info from that.

    I just spoke to Apple Support.  They say "it is a known issue and Apple is working on an update that should be there in a couple of weeks".  He did not know whether it would be part of 10.8.3 or whether the issue was fully root-caused and/or fixed.


    I am thinking whether to wait for the update or just exchange the unit for a Thunderbolt one now. Not sure yet.

  • eosman Level 1 (0 points)

    I thought I had fix my problem with my USB 3 hard drive Western Digital, however it still happens on the right port. So even with the firmware update from Western Digital I'm still having the issue. I think the issue is known by Apple and also from Western Digital because in the firmware release notes from Western Digital there was something that egg knowledge to the problem with the USB port.

  • mkiv18t Level 1 (0 points)

    I am experiencing the same problem with a new Seagate Slim for MAC.  It would randomly throw the "Disk was not ejected properly..." error message.


    At first I thought it was a drive issue so I tested the drive on a windows machine using the Seagate tools.  The drive itself is ok.


    Right now what I am testing out is formatting the drive to NTFS instead of using MAC partition.  This seems to behave properly for me.

  • rawrawraw Level 1 (10 points)

    Add me.


    I thought my one USB drive was going bad. Bought Disk Warrior to 'fix' it. Same problem. So I bought 2 firewire 800 4TB G-Drives to copy from my 3 2TB USB drives. One of those drives kept auto ejecting so I returned it. The replacement works better, but just ejected itself during a 1.2TB carbon copy clone backup.


    So summarize I spent $99 on Disk Warrior, $700 on the 2 new drives (they're also USB 3 for the new mac pro when that comes out) and it turns out the issue is with ML.


    Great.... just great.


    I swear, next time I get a rock solid sytem I'm done upgrading OS's.


    Hopefully apple will resolve this.

  • renatocoral Level 1 (5 points)

    Same issue here. I bought a new 2012 27" iMac with ML 10.8.2 and for the first 2 weeks I used my G-Drives via USB till I received the Thunderbolt-Firewire adapter. I had no issues via USB other than it being slow (2.0 drives) but since I started using the two drives daisy chained via Firewire 800 with the adapter, the drives unmount unexpectedly and my Aperture database gets corrupted.


    I've noticed that every time the machine goes to sleep both external drives won't mount anymore untill I reboot so I disabled the Sleep function. But it still happens in unexpected times.

    I've called Apple but they didn't seem to know how to solve it other than telling me to do a SMC reset and a NVRAM/PRAM reset none of which helped the case.


    Still hoping Apple gets this fixed soon so we can all get back to work.


    PS: both drives worked fine on my old 2008 iMac with Lion.

  • E Sheard Level 1 (0 points)

    Same issue here.  I bought a new 2012 27" iMac with ML 10.8.2I received the Thunderbolt-Firewire adapter and connected my  two OWC drives daisy chained via Firewire 800 with the adapter, the drives unmount unexpectedly.  This does not happen very offten and has not caused and loss of data, "YET".


    The one that disconnects is the 2 TB Time Machine back up drive which is the first one in the daisy chained.  This drive also worked with no problem on my MacBook Prorunning Snow Leopard.


    The 2nd one is a 3 TB OWC drive I use for TV recordings and is turned on only when I need to archive a TV program I want to save.  Both drives have their own power cord.  The dismount seems to happen after the iMac is awaken from sleep mode.

  • Dana Cameron Level 1 (15 points)

    I was experiencing the same thing the new late-2012 27" iMac. After a lot of wasted effort to fix the problem, AppleCare suggested I swap the adapter. I did, and now neither of my G-Drives will mount at all.


    The Thunderbolt ports correctly identify when the adapter is connected, but never show that a device is connected. Both G-Drives still work flawlessly via USB.


    One Apple senior rep gave me the runaround (maybe because he didn't have a solution) and another (suspecting the Thunderbolt ports on the new iMac are bad) has scheduled me for a Genius Bar appointment (tonight) to take my brand new 27" iMac in for diagnostics. Then this morning, iPhoto repeatedly crashed the computer while I was retouching a (large) photo. iPhoto has never been 100% stable in my usage, but I wonder if the crashing is related (maybe the motherboard, not just the Thunderbolt ports, is bad). What started out as seemingly a minor inconvenience seems to be ballooning quickly into a major problem.


    If this is a known issue for Apple, why have the senior advisors at AppleCare been so lost regarding my problems? And if this is truly a Mountain lion issue that's being addressed in a future update, should I even bother taking my computer in to my local Apple Store tonight? That's a major hassle I'd rather avoid if at all possible.

  • Dana Cameron Level 1 (15 points)

    The Apple Genius helped me sort out my problem: one bad FW800 cable!


    All my switiching things around, with phone support from multiple Apple Advisors, trying to figure it out and that one cable always managed to work its way into the mix! Only when the Genius and I had multiple Thunderbolt-enabled devices to experiment with were we able to isolate the bad cable.


    Odd how my problem seemed to mimick the random-unmounting issue others in this thread have been experiencing. Perhaps your cables may need another look? A trip to your local Apple Store may not hurt either; I didn't want to do it, but it turned out to be the right thing to do.


    My 2012 iMac itself is in perfect working order! As are the G-Drives. Best possible outcome for me!



Previous 1 2 3 4 5 Next