4 Replies Latest reply: Jan 14, 2013 4:54 AM by wackotecho
wackotecho Level 1 Level 1 (0 points)

My AppleTV (3rd Gen) suddenly dropped my ethernet connection and will not pick up wi-fi either.

 

I have tried restoreing, only worked for about an hourand back to square one.

 

I checked all networking to make sure nothing changed, all good there, checked my other Apple TV (2nd Gen) no issues.

 

Swapped cables, locations, still no change, rang support, got old sortware link to restore to as it may have been the lateset version issue.

 

Tried the restore to last version, sadly no change, checked other Apple TV no issue with latest version, I am really confused.

 

The unit is only a few months old and I think it may have hardware issue.

 

I disconnected ethernet cable and sadly no wi-fi available, it says it is connected to the internet via built-in ethernet, now that is definately not normal.


iPhone 5
  • 1. Re: Apple TV 3 not Wi-Fi or Ethernet Connectivity
    JonWolloff Level 1 Level 1 (0 points)

    exactly the same issue here, followed the same steps other than wasting time ringing Apple. My ATV2 is working fine even after update to the latest version. ATV3 was fine twelve hours ago, now failing as wackotecho described.

     

    guessing it's not a hardware issue if we have the same issues?

  • 2. Re: Apple TV 3 not Wi-Fi or Ethernet Connectivity
    rotorh60 Level 1 Level 1 (0 points)

    I'm in the same boat.  I performed the update without checking the boards first.  Anyway, after software update on my ATV3, I am not able to connect to my home network.  Everything was working as advertised before I performed the update an hour ago.  I was able to connect via Ethernet, and it works.  I am not going to have a Ethernet cable laying across the floor...

  • 3. Re: Apple TV 3 not Wi-Fi or Ethernet Connectivity
    OzziesMAC Level 2 Level 2 (150 points)

    Is this fixed yet?

  • 4. Re: Apple TV 3 not Wi-Fi or Ethernet Connectivity
    wackotecho Level 1 Level 1 (0 points)

    Well my issue is fixed, turns out the update with which cause my issue must have locked somthing up in the settings.

     

    I spent some time with one of the support people which is level two or higher and we found that the ATV3 had IP address etc setting for ethernet even with no ethernet/wifi available. We restored the ATV3 several times and even went to earlier versions of firmware to try to undo this, sadly this failed and my ATV had to be replaced, Apple sent out a new one now all is good again.

     

    I suggest you contact them and if you are able to get them to replace it for you.

     

    I did also notice that the iTunes update that came out at the same time had a problem which may have cause this to happen in the first place.

    Restore did not work unless you help option key while hitting the Restore.