1 Reply Latest reply: Jan 13, 2013 12:37 PM by AnaMusic
rsmith121782 Level 1 Level 1 (0 points)

I need to know what operating system I should upgrade to so I can run flash for games and such and the new itunes 11. I an curently running 10.5.8 so any help would be great!!


iMac, Mac OS X (10.5.8)