Skip navigation

HT5493: About Java for OS X 2012-006

Learn about About Java for OS X 2012-006

HT5493 Java update and reverting to 1.6 plug in.

3773 Views 9 Replies Latest reply: Mar 14, 2013 1:40 AM by Paul Fitz RSS
Sick_puppy Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 22, 2012 2:13 AM

Good afternoon.

After installing the java update this week I've realised it makes my Macbook useless for work. I regularly rely on a Corporate Information System at my University to access student records. This system is incompatible with Java 7, upon installing the update it directs me to install the plug in from Oracle (for which only java 7 is available) When trying to access the system it comes up with the following error, "requires jinitiator 1.1.8.2 or higher" Which I assume is a change between Java 6 and 7.

Spent a long time with the Universities tech support who couldn't help only to confirm that Java 7 is not supported (and even directed me to several .exe windows programs to update jinitiator, as well as to some malware). Apple Tech suport had no solution to the problem either other than to time machine back to before the update.

I have now used time machine to restore to prior to the update (which took 48 hours for 300GB!!!!!)

 

So ideally I would like to install the update (for various reasons, including security) but still have access to University system.

 

Can anyone provide any advice how I can do so?

 

Alternatively I suppose I will have to avoid this update, but I assume it is forever going to remind me. If that is the case then is there a way to permanently tell my macbook to ignore this update?

 

Any help greatfully received?

 

Kind regards

 

Josh

MacBook Pro (15-inch, Mid 2012), OS X Mountain Lion (10.8.2)
  • thomas_r. Level 7 Level 7 (26,920 points)
    Currently Being Moderated
    Oct 22, 2012 12:08 PM (in response to Sick_puppy)

    So ideally I would like to install the update (for various reasons, including security) but still have access to University system.

     

    It doesn't sound like you can. If this is a web-based Java applet, there is no Java 6 applet plug-in anymore. Apple has removed it in this update, so you have no choice but to use Java 7 for web applets. If it is not a web applet, rolling back should work fine, but the system may be incompatible with the changes in the latest version of Java 6 as well. If you can't use the latest versions of Java, you will be forced to use a version of Java that is not only vulnerable to attack, but that the hackers of the world have now gotten a road map to (in the form of the update). Just because a vulnerability is patched does not mean that it stops being exploited... many vulnerabilities continue to be exploited for years, due to people who are unable or unwilling to install security updates.

     

    Honestly, you shouldn't have to be forced to compromise the security of your system to use this software. You need to speak to people at your university at a higher level than just the techs, and explain to them how this system is compromising both university security and the individual security of every person who uses it. Scare them, and they'll light a fire under the techs to get this fixed.

  • William Lloyd Level 6 Level 6 (19,195 points)
    Currently Being Moderated
    Oct 22, 2012 2:49 PM (in response to Sick_puppy)

    Apple just published a Kbase article on how to revert, if you want to get down with your command-line bad self:

     

    http://support.apple.com/kb/HT5559

  • Paul Fitz Level 2 Level 2 (240 points)
    Currently Being Moderated
    Jan 10, 2013 5:46 AM (in response to Sick_puppy)

    Let me guess - the system you are having problems with is Oracle Forms based?

     

    This issue occurs because Java 1.6 has a vendor string of 'Sun Microsystems Inc.' and Java 7 has a vendor  of 'Oracle'.

     

    The Oracle Forms code looks at the vendor string, sees 'Oracle' and assumes you are running the Oracle JInitiator (Oracle didn't own Java when it was written).  It then looks up the version number, finds 1.7.x, then decides that this is not the right version of JInitiator (it will need JInitiator 1.8+).

     

    The good news is you should be able to work around it as Java supports a custom vendor string.  You will need to open the Java control panel, go into Java Runtime Environment Strings and enter a runtime parameter of:

     

    -Djava.vendor="Sun Microsystems Inc."

     

    After this, your system should work as it will decide you are using Java rather than a version of JInitiator.

     

    I realise this thread is old, but it will no doubt be useul for others.

  • arizwldcat Calculating status...
    Currently Being Moderated
    Jan 13, 2013 2:26 PM (in response to Paul Fitz)

    Thank you, Paul!  I had been trying to fix this issue on my Mac since last fall with no success.  Now I can work on report cards from home! Hooray!

  • ally2550 Calculating status...
    Currently Being Moderated
    Mar 13, 2013 1:26 PM (in response to Paul Fitz)

    Paul - Is this where I should enter the parameter you discribed? It didn't solve the problem so I must be doing something wrong. I still receive the "JInitiator version too low" error message.

     

    Thank you for any help as I've talked to no less than four Helpdesk employees at my company and none can figure this out. I can't be the only one with this problem. Thanks!!

     

    Screen Shot 2013-03-13 at 4.23.17 PM.png

  • ally2550 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 13, 2013 1:38 PM (in response to Paul Fitz)

    Paul - It worked!! No need to reply. I tried it in Safari and it is working perfectly. Thank you so much for this!

  • Paul Fitz Level 2 Level 2 (240 points)
    Currently Being Moderated
    Mar 14, 2013 1:40 AM (in response to ally2550)

    Apologies for not replying to your previous post but I did not receive any notification.

     

    It looks like you entered it correctly, however you might have had some java processes still in memory which you probably discovered was fixed by rebooting - for the benefit of people who might find this thread, after you make the change, if it doesn't work, first try restarting your browser, if that doesn't work, reboot.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.