1 2 Previous Next 17 Replies Latest reply: Jan 28, 2013 10:50 AM by JoexMoney
JoexMoney Level 1 Level 1 (0 points)

ever since i got this thing in summer of 2011 (27 inch iMac) my wifi has gone in and out, knowing my router was old i thought it was that. it went in and out but it would show no connection and of course internet wouldn't load. now it shows its still connected but it won't load. i know the router i had was problematic and would see my service go in and out on my iPad  and iPhone etc.

 

i got a new router and its mint, every other device works perfectly. my iMac is up to date with 10.8.2 if anyone has any advice they think that can help i would greatly appreciate it!

 

thanks,

-joe


iMac, Mac OS X (10.7.2)
  • 1. Re: anyone's wifi not working properly?
    a brody Level 9 Level 9 (63,250 points)

    Is it an Apple router?  If not, is the firmware the latest?

  • 2. Re: anyone's wifi not working properly?
    JoexMoney Level 1 Level 1 (0 points)

    no, brand new linksys n750 and yes i checked all of the updates to see if theres anything that needs to be updated but nothings come up

  • 3. Re: anyone's wifi not working properly?
    a brody Level 9 Level 9 (63,250 points)

    How far is your iMac from the router?  Do you have Media Access Control (MAC filtering) turned on?  Is WPA2 encryption enabled?

  • 4. Re: anyone's wifi not working properly?
    JoexMoney Level 1 Level 1 (0 points)

    maybe 20-25 feet but through walls. i dont have MAC filtering turned on that i know of. i never turned it on so it should be off. and as for the wpa all of the passcodes are correct

  • 5. Re: anyone's wifi not working properly?
    a brody Level 9 Level 9 (63,250 points)

    Other devices in the same vicinity work ok?

  • 6. Re: anyone's wifi not working properly?
    JoexMoney Level 1 Level 1 (0 points)

    my ipad is next to my imac and the ipad has been streaming hq videos from netflix all day without a hitch

  • 7. Re: anyone's wifi not working properly?
    a brody Level 9 Level 9 (63,250 points)

    Have you tried disabling all but the iMac's connection to the WiFi to see if it is a bandwidth sharing problem for the WiFi?

  • 8. Re: anyone's wifi not working properly?
    schink22 Level 1 Level 1 (0 points)

    I've been experiencing similar connectivity issues within the past week.  My PC and laptop are connected to the internet at normal speeds, and we are able to stream hi-def Netflix programs to my TV, but my Mac is unable to garner a download speed capable to stream 240p youtube videos.  Prior to this week (late last week) the Mac was fine, hitting speeds equivalent to that of the laptop on wireless.  I was reading Netgear support and they say that iOS6 has been having compatibility issues with their routers.  I would assume this is the cause, although my iPod can stream Netflix without issue and it is fully updated to iOS 6.0.1.  I ruled out wi-fi bandwith sharing issues as I am able to be online on xbox gaming while my better half watches Downton Abbey (Netflix) on the other TV.  At this point I'm trying to figure out a way to roll back the latest software updates on the Mac to see if that has any effect, but signs point to that not being an option.  Any additional suggestions would be welcome, although I'm unwilling to dig too deep into the router since all other connected devices are working fine.  I think a software update to my Mac is going to be the fix but the wait could be annoying... Ok that's all.

  • 9. Re: anyone's wifi not working properly?
    chuckgm1 Level 1 Level 1 (0 points)

    I am having the same exact problem. I have an intel iMac running 10.6.8. I'm writing this from a friend's laptop running 10.6.2 that's working just fine off of the same wifi connection. the iMac was working fine, but gradually started disconnecting more and more frequently over the course of the last week or so. This evening it finally won't stay connected for more than 45 seconds to a minute. It will barely load google. Tried this: https://discussions.apple.com/message/20917850#20917850 but it didn't work. Please help! Thanks!

  • 10. Re: anyone's wifi not working properly?
    JoexMoney Level 1 Level 1 (0 points)

    definitely not a bandwith problem, although there are multiple devices connected, they're not always on or in use. and i stream videos on my ps3 in hd and no lag, no problems. 

  • 11. Re: anyone's wifi not working properly?
    JoexMoney Level 1 Level 1 (0 points)

    found out if i go to the network prefferences > assist me > diagnostics and select my network it will work just fine for a few minutes (as opposed to turning wifi off and on)

     

    any one have anything that could fix this?!

  • 12. Re: anyone's wifi not working properly?
    a brody Level 9 Level 9 (63,250 points)

    The only way we might be able to fix this is if you try to isolate the iMac as the only device connected to the router and ensure it is connected via a WPA2 secure connection.  Otherwise the bandwidth on the router might be causing problems.   It may not be allocating all its bandwidth to the iMac and as a result drop its connection when it isn't certain which machine to allocate to.

  • 13. Re: anyone's wifi not working properly?
    JoexMoney Level 1 Level 1 (0 points)

    i am currently home alone, all of my devices are turned off except for the imac. no iphone, ipad, other computers are off as well as my gaming systems. this is the only device connected and it still keeps dropping the signal, and it did this with my old router as well and this one has better specs all around and it keeps dropping. i even hardwired it for a while and i had issues with that. i moved the computer closer to the router as well.

     

    i've tried everything i could think of and hasnt worked!

  • 14. Re: anyone's wifi not working properly?
    Paul_31 Level 6 Level 6 (12,750 points)

    There have been some users who have had troublesome wifi since LIon through to Mountain Lion. There doesn't seem to be a one fix solution.

    I've seen reports on here where people have changed the wifi channel and it's resolved their problem but hasn't helped others. Might be worth a try.

    There's also this oldish link that has helped some, although not everybody. It talks about Lion but still seems to be relevant to Mountain Lion. Also check out the links within the article:

     

    http://osxdaily.com/2011/11/06/lion-wi-fi-problems-solution-mac/?utm_source=feed burner&utm_medium=feed&utm_campaign=Feed%3A+osxdaily+%28OS+X+Daily%29&utm_conten t=FaceBook

1 2 Previous Next