Skip navigation

Spotlight indexing

6783 Views 13 Replies Latest reply: Nov 18, 2013 5:35 AM by TimPollard RSS
Swiggen Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 8, 2012 5:42 AM

After updating to Mountain Lion Spotlight is still indexing. This is easily over 24 hours and it is still saying 'estimating indexing time'


I also cannot use Time Machine as it has backed up under 200mb in 20 hours.


Any hints???

MacBook Air, OS X Mountain Lion, Just upgraded to Mountain Lion
  • Alfred DeRose Level 5 Level 5 (5,590 points)
    Currently Being Moderated
    Aug 8, 2012 5:46 AM (in response to Swiggen)

    Depending on the number of files you have, Spotlight can take a veeeeery long time. Give it a bit longer and see what happens.


    As to your Time machine issue, is it not backing up because of the load Spotlight is placing on your Mac? Connectivity issues?


    Try pluging in to Ethernet to see if it works better. Others have reported problems with WiFi connections so this might be the problem.

  • Alfred DeRose Level 5 Level 5 (5,590 points)
    Currently Being Moderated
    Aug 10, 2012 12:05 AM (in response to Swiggen)

    Yeah, that's too long. Try a restart. Seems like something got hung up. Do you see the mdworker process still running and consuming a lot of resources?

  • Yiota Siapera Calculating status...
    Currently Being Moderated
    Sep 21, 2012 12:34 AM (in response to Swiggen)

    I had the same issue. Restarting the computer didn't resolve anything. I had to reset the PRam to resolve the problem.


    Here’s how to reset your PRAM:


    Shut down your machine. Yes, all the way down, not sleep or logging out.

    Press the power button and then press command-option-p-r. You have to make sure you get those keys pressed before the gray screen comes up or it won’t work.

    Hold those keys down until your Mac reboots again and you here the startup chime.

    Let go of the keys and let your Mac reboot normally.

  • BigTunaAK Calculating status...
    Currently Being Moderated
    Oct 4, 2012 6:12 AM (in response to Yiota Siapera)

    I had the same issue and just rest the PRAM. All is good so far Thanks

  • dansandiego Calculating status...
    Currently Being Moderated
    Jan 13, 2013 1:27 PM (in response to Swiggen)

    Swiggen - have you found a solution since Aug? I'm having your exact issue for the past week. PRAM reset doesn't help, I've removed Spotlight library files in three locations. I have the weird TimeMachine freeze as well, that's what originally got me looking into spotlight but now that's not working. I keep this Mac clean and pristine so no malware or clutter.


    I also noticed before my spotlight issue that I have unusual hard drive activity. If I stop all processes down to only Activity Monitor and I still get between 400KB/sec and 2MB/sec write activity. It doesn't start for a couple minutes after login though. Makes no sense to me, especially when I've closed all running processes.


    I'm thinking of giving up and reinstalling the OS but hoping someone has figured this out by now. Thanks!!

  • Eric Root Level 6 Level 6 (13,850 points)
    Currently Being Moderated
    Jan 13, 2013 2:19 PM (in response to Swiggen)

    Here are some troubleshooting articles. Pondini is usually a recommended place to start:



  (note - older article)

  • dansandiego Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 14, 2013 5:56 PM (in response to Swiggen)

    Someone on another forum found my solution. This resovles the spotlight issue that was in turn preventing my TimeMachine from backing up more than a few MB then freezing, and also resolved the mysterious constant disk activity. It was all Spotlight's fault! But this fix worked 100% for all my issues. Thanks


    I posted this workaround in that topic. Here it is (it is not a solution, only a temporary workaround to let my backup and Spotlight work until a fix is released).

    Using Terminal:

    1. I disabled Spotlight indexing:
      sudo launchctl unload -w /System/Library/LaunchDaemons/
    2. I deleted Spotlight index in all my drives (including the backup drives):
      sudo rm -rf /.Spotlight-V100/Store-V1 /.Spotlight-V100/Store-V2  /.Spotlight-V100/VolumeConfiguration.plist
    3. sudo rm -rf /TimeMachineDrive/.Spotlight-V100/Store-V1 /TimeMachineDrive/.Spotlight-V100/Store-V2  /TimeMachineDrive/.Spotlight-V100/VolumeConfiguration.plist

    (rm -rf /.Spotlight-V100/* did not work for me.) (This can also be done by excluding the whole drive using privacy setting of Spotlight and then reincluding it.)


    1. I deleted /var/folders content (see this topic to know why): sudo rm -rf /var/folders/*
    2. I deleted the .inProgress files from my Backups.backupdb subfolders (put to trash then empty the trash is the only way to do this).
    3. I rebooted and then I restarted Spotlight:
      sudo launchctl load -w /System/Library/LaunchDaemons/
    4. sudo mdutil -i on -E /
    5. I waited until Spotlight finished indexing process
    6. I launched a new backup using TimeMachine
    7. I opened a bugreport to Apple with the title: "TimeMachine hangs when Spotlight is in use under Mac OS X 10.7" praying that many other people will do the same to make this bug a priority.

    Some steps may be useless, but I took all what I learn by reading different topic about slow TM and Spotlight.

  • djedi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 29, 2013 4:13 AM (in response to dansandiego)

    It seems like I have tried 10 other solutions. This was finally the answer! Thanks so much dansandiego! Spotlight is finally working.

  • nmorea Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2013 7:41 AM (in response to dansandiego)

    THANK YOU SO MUCH! This also fixed my issue!

  • TimPollard Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 18, 2013 5:35 AM (in response to nmorea)

    I had a similar problem after updating from ML to Mavericks. After trying everything suggested above without the problem being resolved, I was advised by a very helpful Apple 2nd line technician to re-index Spotlight WITH TM TURNED OFF AND THE TM DISK UNMOUNTED. I had previously exluded the disk, but turning it off and ejecting the disk before re-indexing fixed the problem. To be safe I also ejected all other drives as well.


    Spotlight then re-indexed happily, I re-enabled time machine and plugged in the disk and it was all good.


    Hope this helps someone.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.