Skip navigation

whatsapp not working on iphone 3G

168572 Views 482 Replies Latest reply: Feb 2, 2014 8:08 AM by Meg St._Clair RSS Branched to a new discussion.
  • DON KHAN Calculating status...
    Currently Being Moderated
    Jan 12, 2013 1:32 PM (in response to MartinH76)

    martin mate is it possible you could send me the whats app version 2.8.4 file??

  • KiltedTim Level 8 Level 8 (35,975 points)
    Currently Being Moderated
    Jan 12, 2013 1:35 PM (in response to DON KHAN)

    That would be illegal.

  • MartinH76 Calculating status...
    Currently Being Moderated
    Jan 14, 2013 3:33 AM (in response to DON KHAN)

    What KiltedTom said...  Sorry.

  • hila67055 Calculating status...
    Currently Being Moderated
    Jan 14, 2013 5:58 AM (in response to bbgt08)

    I dont understand the explanation

  • hila67055 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 14, 2013 6:06 AM (in response to rdzuan)

    how??????????

  • hila67055 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 14, 2013 6:25 AM (in response to dilip patwardhan)

    I DONT BUY APPLE ANY MORE

  • KiltedTim Level 8 Level 8 (35,975 points)
    Currently Being Moderated
    Jan 14, 2013 6:28 AM (in response to hila67055)

    Thanks. Don't let the door hit you on the way out.

  • Justvw Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 14, 2013 6:43 AM (in response to KiltedTim)

    Are all kilted people this annoying?

     

    I'm going to buy an android smartphone  this week

    Success Apple, and all of your customers.

  • Les@ Calculating status...
    Currently Being Moderated
    Jan 14, 2013 11:49 AM (in response to dilip patwardhan)

    Go Android!  Apple - you kan keep KiltedTim.

  • bbgt08 Calculating status...
    Currently Being Moderated
    Jan 14, 2013 2:10 PM (in response to dilip patwardhan)

    Here is the very disappointing reply I just got from WhatsApp:

     

    Ken V (WhatsApp Support)

     

    Jan 14 12:46 (PST)

     

    Hi,

     

    Thanks for your message.

     

    Apple no longer supports the iPhone 3G, nor does WhatsApp.

     

    In order for WhatsApp to provide a more secure and reliable service for all of our users, we simply cannot continue supporting older versions of the app. If you have WhatsApp Messenger version 2.8.4 for iPhone 3G on iOS 4.2.1, you should be able to continue using WhatsApp with the same phone number. Unfortunately, Apple does not provide any way for us to distribute previous versions of the app, so you will need to have had previously downloaded version 2.8.4.

     

    WhatsApp is an internet-driven service. It requires all of the devices that connect to it to be able to use the same protocol (similar to "speaking the same language"). As our protocol evolves to add new features and improve security and performance, it becomes imperative to enforce all of our devices to use the newer protocol. Otherwise, our system becomes vulnerable to attackers and spammers. If we allow old devices into the system, we allow the few users with old devices to jeopardize the experience for the rest of our users. Eventually, the protocol will evolve to a point where old devices will simply not understand the new protocol entirely.

     

    You can read our latest blog post to learn more about why WhatsApp Messenger now requires iOS 4.3 or later: http://blog.whatsapp.com/index.php/2012/12/iphone3g/

     

    It's not as simple as "Your device is too old", but the bottom line is: "Your device is too old."

     

    -ken

     

    ken@whatsapp.com

  • KiltedTim Level 8 Level 8 (35,975 points)
    Currently Being Moderated
    Jan 14, 2013 2:49 PM (in response to bbgt08)

    How many times are you people goig to repost the same tripe from Whatsapp?  If you want to complain about it, go complain to them.

  • Justvw Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 14, 2013 11:31 PM (in response to KiltedTim)

    I havn't seen this message from whatsapp before in this thread, so thank you bbgt08. But unfortunatelly it isn't true, it's still not working here. Maybe I'll send them a message about that.

  • Les@ Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 15, 2013 1:04 AM (in response to KiltedTim)

    Facebook app gives the same message from app store, so does my bank's app. 90% of apps does not support anything below 4.3.  Should I then go complain to all these companies?  The common thing here is iPhone 3G is no longer supported by Apple.

     

    My wife have a little Samsung Galaxy Pocket (about 10% the price of a iPhone) and it does everything (and more) that an iPhone can do.   

     

    KiltedTim, if you have such a problem with us complaining, why are you reading the complaints?  And about the door hitting me on the way out - if you knew anything about marketing you should know that every customer is important.  I bought the first iPod when it came out, but brand loyalty can only take you so far.  Be carefull that Apple won't have to sue more companies that look after their customers to keep their market share!!!

  • KiltedTim Level 8 Level 8 (35,975 points)
    Currently Being Moderated
    Jan 15, 2013 2:54 AM (in response to Les@)

    Why should I care about marketing? I don't work for Apple. No one here works for Apple

     

    As for that little Samsung Galaxy pocket, come back and let us know how it's doing when it is 4 1/2 years old... as the iPhone 3G is.

1 ... 25 26 27 28 29 ... 33 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.