14 Replies Latest reply: Jan 16, 2013 6:45 PM by Rageican
Rageican Level 1 Level 1 (0 points)

I've had my new MBP Retina for about 3 weeks now and was really looking forward to photo editing with Aperture 3.3 with the beautiful display but was shocked when the performance began lag pretty significantely. I've maxed out the memory,  and have the 500-something GB SSD. This computer is brand new so barely has anything on it, and I started fresh with a new Aperture Library as well. I am very concerned about this performance (or lack there of).

 

Any ideas?! Please help!


Aperture 3, OS X Mountain Lion (10.8.2)
  • 1. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    Kirby Krieger Level 6 Level 6 (11,945 points)

    Need more information  .  How are you determining that performance is lagging?  Does it ever not lag?  Have you tried on a new User Account?  Does anything show in Aperture's Activity window?  Does it happen on all Images?  Have you rebooted? Etc.

  • 2. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    Rageican Level 1 Level 1 (0 points)

    It varies, but moving adjustment sliders and lag to seeing results for around 2-3ish seconds. Where it really suffers is using brushes. At times clicking anywhere will simply freeze the program for around 3 seconds and then I've made an unwanted stroke across the the entire photo. I've tried rebooting, but haven't tried a differ user profile. There are times when doing simple adjustments seem to be working normally, but I havent been able to really see consistent performance for a solid time period. (ex. 1-2 hours, 20 photos) The lag is consistent across all images.

  • 3. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    Ernie Stamper Level 8 Level 8 (37,475 points)

    Some thoughts:  Aperture 3.4.3 should be the version to use on this laptop (I know, as I have one).  What is the camera or cameras with which the photos have been shot -- looking for size of original file?

     

    Ernie

  • 4. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    Rageican Level 1 Level 1 (0 points)

    3.3 in the description was a mistake. I am actaully running 3.4.3. Whoops...

     

    All the photos are shot with Canon 60D Raw. I don't have that computer in front of me so I don't know size off the top of my head.

  • 5. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    Ernie Stamper Level 8 Level 8 (37,475 points)

    As an 18 MP camera, the file size will not be as large as with some of the newer cameras produce.  But still you might check the size Previews you have selected.  A size consistent with your display size will be best.

     

    But other things may be in play.  Have you repaired the library, btw?

     

    Ernie

  • 6. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    Rageican Level 1 Level 1 (0 points)

    Repairing the library was my next step, though I can't believe I would need to do that since I just created it a week ago.

     

    Any ideas on what other things might be in play?

  • 7. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    William Lloyd Level 6 Level 6 (19,355 points)

    How many adjustments do you have on the photos?  In general, there are some adjustments that are computationally quite expensive.  Shadows/Highlights and Edge Sharpening are both pretty expensive.  Did you bulk apply that to a lot of the photos?

     

    I use Aperture on a similar machine to yours, and in general performance is fairly good with my 1Ds Mark III pictures which are about 21 MP.

     

    Does the lag get worse the longer Aperture is running?  If you go to Activity Monitor how much RAM is Aperture using, and in the System Memory tab what are the numbers beside "Page Outs"?

  • 8. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    Rageican Level 1 Level 1 (0 points)

    I usually do basic exposure, then a little retouching for skin if needed, maybe skin smoothing. I may sharpen the eyes at the end depending on the photo. I generally save a look as an effect and only apply it to like photos that I've chosen, if that makes sense. I don't ever mass stamp loads of adjustments on photos.

     

    Speed can get worse the longer its running and ill restart aperture and it doesn't seem to help for that long.

  • 9. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    Kirby Krieger Level 6 Level 6 (11,945 points)

    Skin smoothing is, just from observation, one of the most computationally expensive adjustments in Aperture.

     

    It seems odd to me that you save skin smoothing as an effect.  It is always applied via a Brush, and thus is applied to a specific area of the image.  It doesn't make sense to lift and stamp skin smoothing -- much less use it in a saved Effect -- unless one is working on nearly identical versions.

     

    You haven't answered two important and helpful questions:

    - Does anything show in Aperture's Activity window?

    - If you go to {the OS X utility} Activity Monitor how much RAM is Aperture using, and in the System Memory tab what are the numbers beside "Page Outs"?

     

    (Added:)

    I still think something is causing the problem.  I have the same machine (2012 15" rMBP with 16 GB RAM and 500 GB SSD), use Aperture every day, almost always on 24 MP RAW Originals, and rarely if ever see the kind of delays you have described.  Keep providing answers -- we'll figure out what is happening.  :-)


     

    Message was edited by: Kirby Krieger

  • 10. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    Rageican Level 1 Level 1 (0 points)

    Sorry I didn't specify. But yea, I don't save any brush work in the effects. That would be odd. Just the exposure/look work with certain bricks is saved in the preset.

     

    I will do some testing tonight to recreate the problem and watch the activity moniters and report back.

     

    I agree. Something is off. This machine should be breezing through. My bet is operator error. haha.

     

    Thanks for all the help!

  • 11. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    Rageican Level 1 Level 1 (0 points)

    Alrighty,

     

    so I recreated the problem and found the answers to your questions.

     

    Aperture, on average seems to be using around, 4GB mem when I'm doing my heaviest brush work.

     

    In the activity moniter in aperture, it seems to be hung up on generating the preview. As I type this it still has not finished and I don't know if thats normal. The app isn't frozen but I'm wondering if this process may contribute to the speed issues.

  • 12. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    Rageican Level 1 Level 1 (0 points)

    Aperture is now using upwards of 6GB of memory. Don't think thats a problem, but just thought I'd add that.

  • 13. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    Kirby Krieger Level 6 Level 6 (11,945 points)

    What size have you specified for your Previews?

     

    "Aperture➞Preferences➞Previews➞Photo Preview".

     

    Smaller is faster.  The entry (or entries) with asterisks are the size of your display(s).

  • 14. Re: Aperture 3.3 slow on brand new 15in MBP Retina
    Rageican Level 1 Level 1 (0 points)

    I'll try that! Thanks!