12 Replies Latest reply: Jan 15, 2013 4:51 PM by Tom Gewecke
jockefardig Level 1 Level 1 (0 points)

Hello, I need your help. I can't make the @-symbol no more with alt 2 + command. Why?

 

For this thread I had to copy-paste the @-symbol. It just stopped working.

 

* I also have to add that for a few weeks ago my keboard and trackpad was non-responsive for about 10 seconds from I touch it until I could use it. The support suggested that it was software-related rather than hardware-related. If that might have something to do with it? I re-installed my whole OS and everything was fine but I rather not have to re-install every second month because of bad software. There has to be a better solution?


MacBook Pro (13-inch Mid 2010), OS X Mountain Lion (10.8.2)
  • 1. Re: Can't make @-symbol
    dutch82 Level 1 Level 1 (10 points)

    whats wrong with shift 2

  • 2. Re: Can't make @-symbol
    jockefardig Level 1 Level 1 (0 points)

    shift 2 gives me a "

     

    I might need to add that I'm using Swedish keyboard layout.

  • 3. Re: Can't make @-symbol
    dutch82 Level 1 Level 1 (10 points)

    LOL- okay i will not know how to fix.

    maybe try system preference>Keyboard> and re-set all the options.

  • 4. Re: Can't make @-symbol
    OGELTHORPE Level 7 Level 7 (25,775 points)

    SYSTEM PREFERENCES> LANGUAGE & TEXT>INPUT SOURCES, select US and you should get the desired result.  Other languages will also work.  You must have it set to Swedish.  Explore.

     

    Screen Shot 2013-01-15 at 4.57.50 PM.png

    Ciao.

  • 5. Re: Can't make @-symbol
    jockefardig Level 1 Level 1 (0 points)

    Yes, if I choose input-language to US, I can make the @-symbol with shift 2. But I do not wan't to have my input language set to US because I have the Swedish keyboard.

     

    So, I obviously can make the @-symbol by changing the keyboard input to US. But for all time I have had the input set to Swedish and always made the @-symbol with alt 2 . It suddenly stopped working and now I am asking if someone have a solution for making alt 2 working again. Why did it stop working and how do I get it back?

  • 6. Re: Can't make @-symbol
    OGELTHORPE Level 7 Level 7 (25,775 points)

    I do not know why it stopped working, but you can set up languages in your menu bar that will allow you to conveniently switch if the need arises.

     

    Screen Shot 2013-01-15 at 5.18.48 PM.png

    Ciao.

  • 7. Re: Can't make @-symbol
    Tom Gewecke Level 9 Level 9 (71,730 points)

    jockefardig wrote:

     

    Why did it stop working and how do I get it back?

     

    You have set your keyboard to Swedish instead of Swedish Pro.  Fix that by unchecking the box for Swedish and checking the box for Swedish Pro in the Input Source preferences.

  • 8. Re: Can't make @-symbol
    jockefardig Level 1 Level 1 (0 points)

    I tried your suggestion Tom but that did not solve the problem.

     

    I tried to restart the computer though and it seems that I am able to make the @-symbol a few seconds right after I've logged in to my account but during processes starts, the @-symbol just stops appearing. So I am guessing there is some process that prevents the alt 2 to produce the @-symbol. I just have to figure out which process so I can uninstall or remove app or process.

     

    Does anyone know how I can find the process that causes this problem?

  • 9. Re: Can't make @-symbol
    Tom Gewecke Level 9 Level 9 (71,730 points)

    Do you have the Swedish Pro flag in the top right corner of your screen?  If not, go to the Input Sources preference pane and check the box for Show Input Menu in Menu Bar so you can at least see what keyboard layout is active.

     

    If one key does not work, then most often it is because this has been set as the trigger for something.  Double check your system preferences/speech to make sure this is not the case for speech recognition or text to speech, etc.

  • 10. Re: Can't make @-symbol
    jockefardig Level 1 Level 1 (0 points)

    So, problem solved!

     

    I found the process that made it impossible for me to make the @-symbol by pressing alt-2.

     

    About a week ago I installed FileXaminer which has the option in it's preferences to use alt-2 in finder to get batch-information of the selected items. I unchecked the box where it said "Batch FileXamine Finder selection when "alt-2" is pressed".

     

    Thank you for the replies.

  • 11. Re: Can't make @-symbol
    Keith Doherty3 Level 4 Level 4 (1,735 points)

    With a standard Mac keyboard set to Swedish this is the way to create the @ sign

     

    Press the option Key to modify keyboard the @ key is as per attached image

    Screen Shot 2013-01-16 at 00.09.jpg

  • 12. Re: Can't make @-symbol
    Tom Gewecke Level 9 Level 9 (71,730 points)

    jockefardig wrote:

     

    About a week ago I installed FileXaminer which has the option in it's preferences to use alt-2 in finder to get batch-information of the selected items.

     

    Thanks for that feedback, would never have guessed some app would do that!  It is really poor app design to have a setting  which takes over a keyboard character -- instead a combination with Control or Command should be used.