Previous 1 2 Next 20 Replies Latest reply: Jul 29, 2013 9:49 AM by PeterBreis0807
SuportID Level 1 (0 points)

I have 5 users.  2 Admin (Parents), 3 (Kids).


Pages has stopped working on my (Admin) login, but works fine on the other 4.


How can I fix this?  Thanks

iMac, OS X Mountain Lion (10.8.1)
  • VikingOSX Level 6 (15,818 points)

    When you say Pages won't open any documents, do you mean those with extensions .pages, .doc, .docx, .rtf, and .txt? Of these filetypes, can you single-click the document icon and tap the spacebar to display them? What application is offered at the top to open them?


    When Pages cannot open a file, does it offer any dialog or behavior worth noting here?


    Did you recently install Office for Mac on your machine?

  • SuportID Level 1 (0 points)

    Thanks.  The application will open, but it then fails to open a blank document, template or existing document.  It keeps running and Force Quit is the only way to terminate it.  I have not installed any Office Software on my machine.

  • kennymac Level 1 (25 points)

    I'm having the same problem. Pages opens fine, but then it won't open any existing .pages documents, not even a blank template.


    When I try to open a recent Pages document, I see the progress bar go all the way across, and then I get an error message that says, The document “xxxx” couldn’t be opened.


    When I try to open a blank template, I see the spinning gear, but nothing happens. I've let the spinning gear run for over an hour, with no progress.


    Mac Pro, runninng 10.8.2, Pages '09 version 4.3.


    I've tried deleting the preferences, looking in the ~/Library/Containers folder for anything to delete, looking in the ~/Library/Saved Application State for the same thing. Nothing has worked yet.

  • VikingOSX Level 6 (15,818 points)

    Let's take a step back. Five users. All on the same machine with different accounts right? Pages works fine for everyone but you. That points to mischief in your home directory. It may be local cache files, or a bad preference file. Let's focus on those.


    1. Clear local account caches
      1. Change to Library/Caches in your home directory
        1. If your Library folder is hidden
          1. press shift+command+G.
          2. Enter ~/Library/Caches and proceed.
      2. With command+a, select all files within your Library/Caches folder
      3. Right-button click and choose Move to Trash from the menu
      4. Don't empty the Trash just yet
    2. Delete Pages Preference files from your account
      1. Again, navigate to the Library/Preferences folder in your login directory
      2. Find any file and drag to the Trash
      3. A new preference file will be written on the next Pages launch
    3. Reboot and empty Trash
      1. Some files will be in use and require a reboot to remove them from Trash


    Try Pages again and see if it resumes normal functionality for you.

  • kennymac Level 1 (25 points)

    Thanks for the help. However, Pages still will not open a .pages document or template.



  • kennymac Level 1 (25 points)

    In my trying and trying and trying to get this to work, I discovered that I can SOMETIMES open older Pages docs (like one or two months old), and sometimes I can't. But I cannot open a document that I created two days ago.


    Hmmm. The search for an answer continues!

  • SuportID Level 1 (0 points)

    I went through all of your steps, but I am still having the same result as I described and as echoed by kennymac?

  • VikingOSX Level 6 (15,818 points)



    Based on what we know, your Pages issue is unique to your admin account on a five-user machine. Attempts to open new blank documents, other templates, or existing documents fail with Pages hung. We have cleaned local and system caches, rebuilt the font database, removed Pages preference(s), and found that Pages acts no differently in Safe Boot Mode as it does under normal boot.


    When OS X installs new user accounts, it also sets Access Control Lists on home directories, and the folders within that have an icon on them such as Library, Music, Documents, etc. If these ACL get changed or corrupted, your account access may not work correctly. This can happen when restoring home directories from a backup that may have corrupted these ACL. There is a simple process to reset them to original state.


    1. Reboot into recovery mode holding either of following keys
      1. command+R
      2. option key
    2. Choose Recovery partition
      1. From Utilities menu, run the terminal app
      2. type the following
        1. resetpassword
      3. A panel appears
        1. You will not be resetting any passwords
        2. At the bottom is the option to reset ACL - choose this only
          1. Resets ACL as originally established during account setup
      4. Quit recovery and boot normally
    3. Try Pages again - new or existing files in your home directory


    If Pages is still ornery after the above steps, press shift+command+U (opens /Applications/Utilities) and select the Console application. In its left panel under FILES, select system.log. In the bottom panel, lower right, select Now. And in the search window where it says String Matching, type in Pages, using leading capital. Now launch Pages again and attempt to access a local file. See what messages appear regarding this Pages session.

  • kennymac Level 1 (25 points)

    No joy.


    Here are the messages I received:


    10:53:02 AM Pages:

      Assertion failure: Method: markerOfType;forRulerView:atLocation:listlLevelActive:

    Object: <SFWPRulerMarker 0x408420>

    File: /SourceCache/iWorkShared/iWorkShared-807/sfwordprocessing/SFWPRulerMarker.rm

    Line #: 202

    we should have had an image or an image resource name


    10:53:02 AM Pages: Exception opening document: ***  - [SFWPRulerMarker initWithRulerView:markerLocation:image;imageOrigin:]: no image given. NSRulerMarkers must have an image.


    10:53:02 AM Pages: Failed to open document, but no unrecoverable error


    10:53:02 AM Pages: Error opening document in -[SFAppApplicationDelegate(Private) doCoordinatedReadWorkForURL:]. No NSError provided

  • VikingOSX Level 6 (15,818 points)

    For SuportID and Kennymac:


    I am fresh out of ideas for your individual Pages issues. It appears to me that Pages has developed corrupted files either in the Application itself, or the locations where it stores files. At this point, I recommend a reinstallation of iWork '09 or Pages, depending on what you installed originally.



    1. Save any custom Pages templates that you may have created
      1. homedir/Library/Application Support/iWork/Pages/Templates/My Templates
      2. Any custom folders on the same level as the My Templates
    2. iWork '09 removal (Pages, Numbers, Keynote)
      1. See my post recommendation here to completely remove iWork '09 components
        1. If you only have Pages '09 installed, the AppleScript will remove the application and support files
        2. If you have Numbers and Keynote separately installed, they will be thoroughly removed as well.
      2. Reinstall iWork '09 and/or individual applications with all software updates


    The documents that you created within Pages will remain. Upon thorough removal and reinstallation, your Pages functionality should return to normal. If it doesn't then there is something amiss with your home directory or specific system files that Pages depends upon have become corrupt beyond simple file permission repair.


    Good luck.

  • kennymac Level 1 (25 points)

    Yeah, I think a fresh install will help. I agree with you – something got misplaced or corrupted somewhere. I can't find a "RulerMarker" file anywhere.


    I'll report back about the reinstall.

  • ColinJA Level 1 (0 points)

    I have a similar problem on a solo iMac running Mac OS X Lion 10.7.5 (11G63) and all my iWork applications (originally from Snow Leopard disc pack and updated to 4.3) have recently failed on opening.for no apparent reason, or won't show documents. I have uninstalled and re-installed, including updates, incrementally, with no joy. Looks like the problem is wider than just one user.


    Still looking for an answer!

  • VikingOSX Level 6 (15,818 points)

    Did you see my post above with the link to an automated iWork removal tool. You cannot fully deinstall iWork by dragging applications and preferences to the Trash.


    Yes, there is something hard to detect and resilient to normal corrective methods, apparent in this thread.

  • ColinJA Level 1 (0 points)

    No, I missed that, but I have used AppZapper after doing a manual trash of preferences and the iWork folder in Library/Application Support - checking there was no obvious iWork items left at root level or user level. Even removed the iWork folder with its PDF manuals, left in Applications. Repaired permissions, restarted, re-installed iWork from original disc and updated to 9.3. And everything seems to be OK.


    My inspiration came from


    Thanks for your post, however. I just hope iWork stays stable, though I'm still at a loss as to what caused the problem.

Previous 1 2 Next