Skip navigation

Apps refuse to quit for Restart/Shutdown, plus other oddities

602 Views 7 Replies Latest reply: Jan 15, 2013 4:07 PM by jockefardig RSS
Martin E. G. Anhalt Level 1 Level 1 (10 points)
Currently Being Moderated
Dec 10, 2012 12:30 PM

This has started out of the blue. I cannot restart/shutdown anymore with apps open. Whan I try this, the usual alert window pops up, I confirm that I want to shut down, then nothing happens and console tells me:


loginwindow[34] ERROR | -[ApplicationManager(AppleEventHandling) _tryQuitAllForRequestor:replyEvent:] | _tryQuitAllForRequestor - _vproc_set_global_on_demand returned error -1854748728


After a while, I get a "timeout" window for every single program that is still running, one after another.


Also, repeat console messages like this one:


loginwindow[34] ERROR | WSActivateApp | SetFrontProcess({0, 528513}) returned error -600. Unable to activate process.


So I have to quit every application manually i order to shut down.


After I quit the last one, Finder is shut down, but the desktop is still there, as is the dock. Nothing happens. I can restart Finder from the dock, but then the same thing happen again when I want to shut down... so I can only "shut down" by pressing the power button...


I tried repairing permissions, which didn't help.


Another thing that doesn't work anymore is "Active corners" for screensaver - nothing happens. I don't know if this is related...


Thank you very much already...

PowerMac, Mac OS X (10.5.8), PowerMac G5 2x2 GHz
  • Neville Hillyer Level 4 Level 4 (1,845 points)

    Do you have any third party utilities or strange applications?


    Does it only affect one account?


    Is your disk full?

  • Neville Hillyer Level 4 Level 4 (1,845 points)

    It is important to know if it affects the whole OS or just one account.


    Create another account and try it for a while.

  • jockefardig Calculating status...



    I just encountered a problem where I am unable to make the at-symbol which is for my country the key-combination alt-2 . I found that the problem occurs first after I login and the process called "Get Info Key Server" started. Try to quit that and see if your screenshot-shortcuts works?


    If anyone know what that process does and where it comes from, please let me know.


    129Get Info Key Serverbigmega0,012,34 MB729,75 MB


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.