1 Reply Latest reply: Jan 15, 2013 4:40 PM by Niel
Jafar5ne Level 1 Level 1 (0 points)

I can't install any software,it said iOS 4.3,iOS 5, etc required.what should I do for this iOS....????


iPhone 3GS, iOS 4.1, Even I don't know what operating