5 Replies Latest reply: Jul 18, 2013 3:35 PM by RichPitts
darkcooleo Level 1 Level 1 (0 points)

I have 3 google calendar account setup on my iPad, iPhone and Mac - everything has worked fine under lion but I keep getting this constant message on Mountain Lion.

 

https://calendar.google.com/calendar/dav/myemailaddress@gmail.com/user///calendar.google.com/calendar/dav/myemailaddress@gmail.com/user/ is not a location that supports this request.

 

I've replaced my Email address with "myemailaddress@gmail.com" for illustration purposes.

 

Can anyone shed any light on what it causing this and why my calendars won't sync?


MacBook Pro, Mac OS X (10.7.2)
  • 1. Re: Calendar - gmail sync no longer working
    Patrick Faltico Level 1 Level 1 (10 points)

    Well for what it's worth, I was having the same problem.  I am not using the iCloud sync but was just trying to sync my Mountain Lion version of iCal with my Google calendar.  I already have my iPhone syncing nicely with Google just fine.  So it was quite frustrating that this wasn't working.

     

    Suspecting that it might simply be a configuration issue, I deleted all the iCal calendars and completely started over by doing the following.

     

    1- deleted all iCal calendars

    2- quit and restarted iCal

    3- navigated to iCal preferences -> Accounts tab -> click the "+"

    4- chose Account Type = "Google"

    5- entered my complete Gmail email address, e.g. "xxxxxx@gmail.com"

    6- entered my password

    7- clicked Create and crossed my fingers

     

    Seems to be working now without the annoying error messages constantly popping up.  For the record, I hadn't included the "@gmail.com" before, and the time before that tried Automatic as Account Type.  Seems a silly thing, but perhaps this is where the error was occuring.  Good luck!

     

    Also, I have a few sub calendars assigned to my Google calendar and was able to sync them as well by using the "Delegation" tab on the Accounts tab of iCal preferences.

  • 2. Re: Calendar - gmail sync no longer working
    darkcooleo Level 1 Level 1 (0 points)

    Just tried this after getting the error message every hour of every day, see how I get on with it now.

  • 3. Re: Calendar - gmail sync no longer working
    gavinwray Level 1 Level 1 (0 points)

    Thanks Patrick. Your steps solved the problem for me.

  • 4. Re: Calendar - gmail sync no longer working
    Asiimont Level 1 Level 1 (0 points)

    I think selecting Google as the Account type is the key - I had deleted and recreated the account several times and always left it on automatic and kept having the same issue. As soon as I followed your instructions exactly, it worked. Thank you!

  • 5. Re: Calendar - gmail sync no longer working
    RichPitts Level 1 Level 1 (0 points)

    I didnt have a problem with automatic BUT

     

    I found if you tried to delete a calendar which you nolong want anywhere ical after a "reload" using these very helpful guidelines, that ical will "accept" the command then start pumping out these messages again...

     

    All admin in terms of deleting calendars require you to go to a broswer and mange them there....

     

    The fundamental problem here is once your have commited some command like delete a calandar in ical which google WONT accept form this client them messages keep coming because it keeps trying.

     

    Stupid Robot you cant stop OTHER than wiping the calendar and starting again as per these instructions...

     

    Thanks all helpful discussion and ical is working properly again