13 Replies Latest reply: Jan 18, 2013 7:15 AM by furiet
furiet Level 1 Level 1 (0 points)

I use SL and ML : I need to use SL because I use applications uncompatible with ML, I use ML to learn to use it.

SL is on my internal disk, ML is on an external drive.

Time Machine is activated only for SL and uses a third disk.

While using ML, I  made an update for ML and wrongly for my Pages and Keynote SL versions, I had forgotten that the update searches for all appmications for all the disks of my configuration.
When returning to my normal use of SL, I discovered that Pages has been updated to the ML verzion, surprisingly without paying for this update.

To refind my Pages SL version, I tried to use my SL Time machine ; I restored a Pages version saved before I made the bad update.

I laucnched it successfully, but there are no models usable, I can't create a new document, and Pages doesn't accept to open existing files.

Whatever be the date of the Time machine savings restored, I didn't find the models file inside my user space in the Library/Applicaton support/iWork/Pages folder.

It looks that it is the wrong place ? Where is located the Pages models file ?

  • 1. Re: Pages models
    furiet Level 1 Level 1 (0 points)

    Of course, I can reistall the Pages SL version, but I should like to understand where is the Pages models file.

  • 2. Re: Pages models
    PeterBreis0807 Level 7 Level 7 (29,645 points)

    What do you mean "models file"?



  • 3. Re: Pages models
    Yellowbox Level 5 Level 5 (4,580 points)

    Hello furiet,


    Is a "models file" a template?


    You wrote: "I use SL and ML"

    What is SL? What is ML?



  • 4. Re: Pages models
    Tom Gewecke Level 9 Level 9 (71,735 points)

    Yellowbox wrote:


    What is SL? What is ML?



    I would assume Snow Leopard and Mountain Lion

  • 5. Re: Pages models
    furiet Level 1 Level 1 (0 points)


  • 6. Re: Pages models
    furiet Level 1 Level 1 (0 points)

    Models file : when yoiu open Pages, a window appeas which proposes yoiu to create a new document based on some document models which are displayed, these models are storred inside a file different fro the Pages application page, usually this file inside your user space in the Library/Applicaton support/iWork/Pages folder.
    Is it the case on your machine ?

  • 7. Re: Pages models
    PeterBreis0807 Level 7 Level 7 (29,645 points)

    That is the Template Chooser and those are templates.


    The supplied Apple templates are inside the application package, which you can access by right clicking on it, but you should not change these.


    Templates you have created yourself are inside the Application support folder.


    If you have attempted to reinstall iWork from Time Machine it is likely that Time Machine will not do a full restore because by default it does not back up the contents of your System folder.


    To do a complete reinstall you will need to go back to your original DVD or Installer file.



  • 8. Re: Pages models
    furiet Level 1 Level 1 (0 points)

    thanks for this precise answer

    I have reinstalled iWork'08 from the original DVD and dowloaded iWork '09.0.4 from the Apple Support downloadings.
    But it still does not work : when i try to launch Pages, a message tells me that a library was not loaded


      Library not loaded: @rpath/Inventor.framework/Versions/C/Inventor

      Referenced from: /Library/Application Support/iWork '09/Frameworks/SFCompatibility.framework/Versions/A/SFCompatibility

      Reason: image not found"

    Yet, this file eists at this place.

    have I to reinstall Snow Leopard ?

  • 9. Re: Pages models
    furiet Level 1 Level 1 (0 points)

    The message before was about iWork '09.

    If I try to launch Pages of iWork '08 J have a messge telling translation fro French)

    "Unable to open the template "blank.temlate"

  • 10. Re: Pages models
    PeterBreis0807 Level 7 Level 7 (29,645 points)

    Which version of OSX are you running?


    iWork '08 is a previous version which needs upgrading to its latest version.


    iWork '09 is a new separate programme and also needs to be updated from the DVD to the latest version, depending on your version of OSX.



  • 11. Re: Pages models
    fruhulda Level 6 Level 6 (15,110 points)

    You can't update iWork 08 with an update for iWork 09. iWork 08 and iWork 09 are two different applications. The update 9.0.4 is for iWork 09. Do you have an DVD with iWork 09?

  • 12. Re: Pages models
    furiet Level 1 Level 1 (0 points)

    the latest Snow LEOPARD VERSIN 10,6,8
    I haven't the iWork '09 DVD, I suppose I downloaded it, but I am not sure, but anyway I have the last Pages versin 4,0,4 and apparently the iWork '09,0,4 I downloaded was a full package, not just an adendum to previous version.

  • 13. Re: Pages models
    furiet Level 1 Level 1 (0 points)

    I found an iWork '09 DVD.

    Using CleaApp.app, I cautiously desinstalled all my iWork versions.

    I reinstalled iWork '09 using iWork '09 DVD.

    Under my currrent user account, I opened Pages : same problem, no models appear automatically, when opened they are not usable, cannot open a .pages file...

    Numbers and Keynote open correctly.

    There is yet a progress  : under another user account, everything is OK, Pages included.

    The versions numbers are correct, initial iWork 09 release :

                       Keyote 5,0
    Pages 4,0,
    Numbers 2,0
    Curiously, the Update app does not afford to update these three apps, tje last version numbers being :

    Keyote 5,2
    Pages 4,2
    Numbers 2,2
    temporary conclusion : since Pages runs correctly under another user, none SL file is corrupetd, none Application Support iWorkn 09 (library) is corruprted, it looks that my problem comes only from a file in my user account.

    I already deleted several times the preferences file

    my suer account/Library/Preferences/com.apple.iWork.Pages.plist

    with no effect until now, but after having  tried to copy this paste from the other user account, and
    unsuccessfully pasted in the "my suer account/Library/Preferences" folder, and re deleted this famous file it works !