Skip navigation

my imac g3 slot loading model will noot boot from the hdd or cd drive

1159 Views 11 Replies Latest reply: Jan 17, 2013 12:04 PM by rccharles RSS
emosun Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 14, 2013 3:00 AM

I attempted to upgrade the ram in my imac g3 slot loading original model.

 

After I installed the ram I got a flashing question mark on the screen with no boot. I then reinstalled the original ram, same flashing question mark.

 

I took the machine apart again and checked every cable and even reseated the cpu card , still flasing question mark.

 

I pressed both reset buttons on the board , still same.

 

I attempted to boot from the mac OS 9 cd , it will not boot from the cd drive in the command promt or by holding "C".

 

This machine worked flawlessly until I tried a ram upgrade.

iMac, Mac OS 9.0.x
  • rccharles Level 5 Level 5 (5,150 points)

    The blinking question mark means that the firmware could not find a valid OS on your startup disk.

     

    Normally i'd say: The likeliest possibilities are your OS has become corrupted or the harddrive has failed.

    It seems the machines has forgotten where to boot.  Boot with option key. Do the resets below. Could try a new battery, but I doubt a battery would help unless classic.

     

    For slot loading machines... Try holding down the option key then power on. This brings up the startup manager. Click on your hd. Click on right arrow key.

     

    Sometimes if volumes don't appear in Startup Manager (what you get when you hold down the Option key at startup), you need to reset the Mac's PRAM, NVRAM, and Open Firmware. Shut down the Mac, then power it up, and before the screen lights up, quickly hold down the Command, Option, P, and R keys, until the Mac has chimed twice more after the powerup chime. Then, before the screen lights up, hold down Command-Option-O-F until the Open Firmware screen appears. Then enter these lines, pressing Return after each one:

     

    reset-nvram

    set-defaults

    reset-all

     

    "The reset-all command should restart your Mac. If so, you have successfully reset the Open Firmware settings."

    http://support.apple.com/kb/TS1812?viewlocale=en_US

     

    How to eject a cd from the internal cd drive:

    eject cd

     

    List of devices:

    devalias

     

    List of variables:

    printenv

  • Allan Jones Level 7 Level 7 (29,585 points)

    This machine worked flawlessly until I tried a ram upgrade.

     

    Have you tried putitng the old RAM back in and testing?

     

    If you ordered the RAM online, can you post a link to it so we can see if there is a possible incompatibility afoot here?

  • rccharles Level 5 Level 5 (5,150 points)

    I gathered the information from 10.4, the results should be useful to you.

     

     

     

    ( nvram is the equivalent Mac OS X terminal command. )

    ---------------------

    Resetting your Mac's PRAM and NVRAM

    http://support.apple.com/kb/HT1379

     

    ---------------------

    reset the PMU

    http://mrjcd.com/junk/PMU.jpg

    --------------------

     

    Why set nvram variable? I've had open-firmware based Pegasos PPC and it simply had boot command, so instead of:

     

    setenv boot-device ud:3,\:tbxi

     

    should be enough to write:

     

    boot ud:3,\:tbxi

     

     

    How to boot cd from open firmware:

    http://blog.litot.es/2006/03/02/boot-from-cd-in-open-firmware/

     

    I hadn't been able to fathom the syntax... until I listed a bunch of os's.

     

    ------------------------------------------

    Now, we can guess meaning:
    boot-device     mac-io/ata-4@1f000/@0:12,\\:tbxi
                                        | | Partition/location
                                        |      on device
                                        |
                                        0 = master
                                        1 = slave
                                       
                                        for ata internal device
                                       

     

    Why set nvram variable? I've had open-firmware based Pegasos PPC and it simply had boot command, so instead of:

     

    setenv boot-device ud:3,\:tbxi

    should be enough to write:

    boot ud:3,\:tbxi

    my setup,boot my internal harddrive Tiger partition:
    boot-device     mac-io/ata-4@1f000/@0:12,\\:tbxi

    my setup, boot my internal harddrive classic 9.2.2 partition
    boot-device     mac-io/ata-4@1f000/@0:10,\\:tbxi

    boot from Mac OS 9 cd???
    boot-device     mac-io/ata-4@1f000/@1:9,\\:tbxi

    boot 10.2 install cd
    boot-device     mac-io/ata-4@1f000/@1:9,\\:tbxi

    boot hardware test cd
    boot-device     mac-io/ata-4@1f000/@1:9,\\:tbxi

    boot from external firewire hd with Tiger installed
    boot-device     fw/node@1d202009c115c/sbp-2@c000/@0:10,\\:tbxi

    boot from external firewire  cd/dvd drive Tiger DVD
    boot-device     fw/node@50770500071002/sbp-2@4000/@0:3,\\:tbxi

    boot from external firewire  cd/dvd drive 9.2.2 install cd
    boot-device     fw/node@50770500071002/sbp-2@4000/@0:9,\\:tbxi

    boot from external firewire  cd/dvd drive Hardware test
    boot-device     fw/node@50770500071002/sbp-2@4000/@0:9,\\:tbxi

    network startup
    boot-device     enet:bootp


    mac $ sudo pdisk -l
    Password:

    Partition map (with 512 byte blocks) on '/dev/rdisk0'
    #:                type name                    length   base      ( size )
    1: Apple_partition_map Apple                       63 @ 1       
    2:      Apple_Driver43*Macintosh                   56 @ 64      
    3:      Apple_Driver43*Macintosh                   56 @ 120     
    4:    Apple_Driver_ATA*Macintosh                   56 @ 176     
    5:    Apple_Driver_ATA*Macintosh                   56 @ 232     
    6:      Apple_FWDriver Macintosh                  512 @ 288     
    7:  Apple_Driver_IOKit Macintosh                  512 @ 800     
    8:       Apple_Patches Patch Partition            512 @ 1312    
    9:          Apple_Free                         262144 @ 1824      (128.0M)
    10:           Apple_HFS Apple_HFS_Untitled_1   2254440 @ 263968    (  1.1G)
    11:          Apple_Free                         262144 @ 2518408   (128.0M)
    12:           Apple_HFS Apple_HFS_Untitled_2 146538496 @ 2780552   ( 69.9G)
    13:          Apple_Free                        6982440 @ 149319048 (  3.3G)

    Device block size=512, Number of Blocks=156301488 (74.5G)
    DeviceType=0x0, DeviceId=0x0
    Drivers-
    1:  23 @ 64, type=0x1
    2:  36 @ 120, type=0xffff
    3:  21 @ 176, type=0x701
    4:  34 @ 232, type=0xf8ff

    pdisk: No valid block 1 on '/dev/rdisk2'

    Partition map (with 512 byte blocks) on '/dev/rdisk3'
    #:                type name       length   base    ( size )
    1: Apple_partition_map Apple          63 @ 1     
    2:  Apple_Driver_ATAPI*Macintosh       8 @ 64    
    3:           Apple_HFS Mac_OS_X  5531656 @ 72      (  2.6G)
    4:          Apple_Free                10 @ 5531728

    Device block size=512, Number of Blocks=5531738 (2.6G)
    DeviceType=0x0, DeviceId=0x0
    Drivers-
    1:   4 @ 64, type=0x701

    mac $

  • noondaywitch Level 6 Level 6 (8,130 points)

    Just a quick one before you get too deep - did you ensure the RAM is properly inserted? It takes a good deal of force to fully seat the cards in those models.

  • rccharles Level 5 Level 5 (5,150 points)

    I would have tried:

    boot mac-io/ata-4@1f000/@1:9,\\:tbxi

     

     

    See Richard's second paragraph having to boot up from the original cd to get cd reader to work again.

    http://discussions.apple.com/thread.jspa?messageID=5966197#5966197

  • rccharles Level 5 Level 5 (5,150 points)

    Ok I attempted the command and all I get is "can't open boot mac-io/ata-4@1f000/@1:9,\\:tbxi"

     

    I forget how the tray loading pata connection is configured.  I could be that the tray loader has two pata controlers.  Do

     

    List of devices:

    devalias

     

    List of variables:

    printenv

     

    and see if you can identify a second controller.  If so, the drive would be master.

     

    Is there any way to use the command area to check if the hdd is still working?

     

    Do not know.  You are in a Forth programming environment.

     

    Also , the only disk I have is a os 9 disk.

     

    Is the disc a full installation cd?  It should not be a machine specific cd -- not grey.

     

    Near the bottom of page on the left will be the 9 cd image.

    http://www.20thanniversarymac.com/software.htm

     

     

     

    I can understand if the mac wants an 8.6 disk to boot from but I dont have one.

     

    Might be 8.1.  According to Richard, it wants the orginal cd shipped with the machine. 

     

    Is there a mac equivelent to a windows boot disk available?

    This sort of software is included on the startedup disc.

     

    Is there any sort of command that will identify what specifically the flashing question mark is for?

    It means that it could not find a valid startup media.  If you could put an OS, you could run disk utility.

     

    --------------------------------

    Could try Ubuntu.  I've run Ubuntu on an iMac g3 600 -- a slot loader.

     

    I have read where the Ubuntu folks recommend running the lastest firmware before installing Ubuntu.
    Try the option key boot for the slot loader.

     

    You boot an Ubuntu or a Kubuntu CD the same way you would the Mac install CD.

     

    Tray
    If no cd/dvd is in the drive and you want to put in the install cd:
    Putting in the install cd
    For a try loading cd/dvd drive, you hold down the button when you are powering on the machine.  The tray should open up. Hold down for awhile may take a few more seconds than you expect. Sometimes it opens up and closes quickly.  Be quick with getting in the cd/dvd. ( This is from working with an iMac g3 tray loader.)

     

    For both the tray loading and slot loading iMac G3 you hold down the c key when powering on.

     

    Slot
    Try this: Hold down the option key when you poweron.  This will bring up the startup manager.  Press the cd/dvd button to eject try.  Insert cd/dvd.  Click rescan arrow. Click on cd/dvd. Click on right arrow. ( I think that this is your best approach. )
    http://docs.info.apple.com/article.html?artnum=106178

     


    re-partition harddrive
    While sparsely documented 10.4.11 contains terminal commands to re-partition a hard drive with out destroying the data on it.  This was introduced as part of the boot camp effort.

     


    Mac OS X - Nondestructive Partitioning
    http://www.ffnn.nl/pages/articles/apple-mac-os-x/nondestructive-partitioning.php
    Nondestructively Resizing Volumes
    http://www.macgeekery.com/tips/cli/nondestructively_resizing_volumes
    Here are bdaqua comments:
    http://discussions.apple.com/message.jspa?messageID=11438193#11438193

     


    Ubuntu

     

    The Ubuntu folks stopped supporting the power PC a while back.  You will have to install an older version of Ubuntu.

     

    You need to modify xorg.conf. See:
    http://ubuntuforums.org/showthread.php?t=219532

     

    Mac G3 modem install Howto
    http://ubuntuforums.org/showthread.php?t=355205

     

    You will have adjust adjust xorg.conf. See these instructions:
    http://ubuntuforums.org/showthread.php?t=234437

     

    I was able to get the last official versions of Ubuntu working on my G3 600.
    6.10 Edgy Eft,
    6.06 Dapper Drake

     

    I used the alternate install and did the alterations noted above.
    These versions are listed at the very bottom of the page.
    https://wiki.ubuntu.com/PowerPCDownloads

     

    Robert

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.