Skip navigation

Address Book -- Synchronize with Google

35244 Views 28 Replies Latest reply: Mar 5, 2013 10:27 AM by perry259 RSS
1 2 Previous Next
schackbrian Calculating status...
Currently Being Moderated
Sep 24, 2012 7:49 PM

Can you please help me synchronize Apple Address Book with Google Contacts?

 

Steps:

1. I checked "Synchronize with Google" in the Address Book preferences.

2. I entered my login information.

3. I added a contact to Google Contacts

4. I pulled the Sync menu down to "Sync Now."

 

Expected Result:

The contact is synced.

 

Actual Result:

The contact is not synced.

MacBook (13-inch Early 2008), Mac OS X (10.7.4)
  • Jim Leask Calculating status...
    Currently Being Moderated
    Sep 27, 2012 6:10 AM (in response to schackbrian)

    I am having the same trouble. Sync with Google was working perfectly for me for several months, but I was on OSX 7.3. I think I started having trouble when the 7.4 update happened. I have now upgraded to 8.2, and still can't get Google sync to work.

     

    What is the difference between configuring "Synchronize with Google" in the Contacts, vs. configuring "Mail, Contacts & Calendars" in the control panel? It seems like two different ways to set up sync. (Note that even though "Mail, Cotacts & Calendars" says contacts, there isn't a checkbox for contacts for GMail so I'm not sure if contacts is even part of this)

  • Jim Leask Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2012 7:41 AM (in response to schackbrian)

    My understanding is that "Contacts" is the address book, but the contents of the address book can be synced to different sources including Google.

     

    I just got the syncing to work again though, and hopefully it will continue to work. In a nutshell, I had to turn off the google sync, close address book (Contacts now in Mountain Lion), then reconfigure google sync. Here is what I did that seems to have straightened it out:

     

    - Syncing stopped working even though my Address book was connected to google, and had been working fine for many months.

     

    - In Address Book (Contacts) I Unchecked "Synchronize with Google" to disconnect the sync

     

    - I closed Address Book to ensure it didn't cache anything.

     

    - I reopend Address Book and in Preferences, I checked "Synchronize with Googe", and supplied my google account information again.

     

    - Note that there should now be a sync icon in the menu bar. Clicking "Sync Now" from here will force the sync and you should then be able to immediately see the results in the browser.

     

    - The sync process started, and it warned of duplicates - I picked Google as the source (I trusted that version more than my loca copy), and let the sync happen

     

    - Checking directly on Google in a browser showed the sync seemed to be working

     

    A possibility that may have caused this problem is when I configured iCloud, there is the ability to sync Contacts with iCloud. I may have clicked this (before deciding that was a bad idea) and I believe this turns off the Google sync but likely doesn't turn it back on again when you stop syncing contacts to iCloud.

     

    Hope this helps...

  • cdtrebor Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 4, 2012 4:41 AM (in response to Jim Leask)

    Unticking sync in AB prefs, closing, reopening and reticking and resupplying user name and password worked for me.  Thanks for posting.  I would say this is a bug.

  • mw-macuser Calculating status...
    Currently Being Moderated
    Oct 5, 2012 4:20 PM (in response to schackbrian)

    10-5-12

     

    I recently had the same issue.

    It has to do with the last Mountain Lion update.

    Apple isnt exactly going out of its way to make google accessories play nicely with apple tools.

     

     

    1. In address Book preferences, uncheck the "sync with google" box

    2. Then on iphone, turn off the contact sync through the "mail contacts calendar" menu in system preferences.

    3. Restart - power on power off  both devices

    4. Turn everything back on.

  • documental Level 1 Level 1 (10 points)
    Currently Being Moderated
    Nov 29, 2012 3:17 PM (in response to schackbrian)

    I have been trying to sync Google Contacts with my Mac's address book in Snow Leopard (OSX 10.6.8). Seems to work ok surprisingly, although initially it was prompting me to enter a MobileMe account that I don't have.

    The problem I'm having now is that when check Google after syncing, almost everything is doubled up in there. Luckily Google Contacts has a remove duplicates tool that works pretty well. Still not sure why that's happening though!

  • Michael Allbritton Level 6 Level 6 (16,270 points)
    Currently Being Moderated
    Dec 14, 2012 10:15 PM (in response to schackbrian)

    I started this thread a little earlier: Syncing Google Contacts

     

    What I want to do is update my existing Google contacts, which were originally uploaded from the previous version of Address Book, with the information that is currently in Contacts (the contacts are stored in iCloud) without generating a bunch of duplicates in either Contacts, iCloud or Google Contacts or messing up any of the existing information. I also do not want to disrupt any of my Google + circles. I've been scouring the internet looking for tips on the best way to do this but little luck. So any suggestions will be appreciated. I wish I could test any solutions before going live with it

  • penkapp Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2012 11:37 AM (in response to schackbrian)

    http://support.apple.com/kb/HT4872

     

    Also works for Mac OS X. Syncing takes a bit...works in batches of 100.

  • sillyvalley Level 1 Level 1 (95 points)
    Currently Being Moderated
    Jan 15, 2013 12:22 PM (in response to Jim Leask)

    I used Jim's method (had to do it twice - same happened several times before) to get sync to work again.  However, I have never seen any "Sync Now" in any menu since Snow Leopard all the way to Mountain Lion.  What do I need to do?  Is it an iLife specific feature? (iNoLife:-(

  • cdtrebor Level 1 Level 1 (15 points)
    Currently Being Moderated
    Jan 15, 2013 4:24 PM (in response to sillyvalley)

    You have to click Synchronise with Google in Address Book or Contacts Preferences first then the menu item appears.

  • sillyvalley Level 1 Level 1 (95 points)
    Currently Being Moderated
    Jan 15, 2013 9:37 PM (in response to cdtrebor)

    Turns out I was looking at the wrong place.  The task bar is on top of screen, and "sync now" comes from a rotor shaped icon, not in straight text.

  • dkokin Calculating status...
    Currently Being Moderated
    Jan 16, 2013 11:27 PM (in response to schackbrian)
    1. Tap Settings > Mail, Contacts, Calendars > Add Account > Other > Add CardDav Account.
    2. Enter the following information in the fields:
      • Server: google.com
      • User Name: Enter your full Google email address
      • Password: Your Google account password
    3. Select Next at the top of the screen to complete the setup.
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.