Skip navigation

Can't deactivate iMessage after switching phones?

208316 Views 132 Replies Latest reply: Apr 24, 2014 3:43 PM by akingpa RSS Branched to a new discussion.
  • coverbay Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2012 6:30 PM (in response to Literroy)

    We were instructed to go into our old iPhone, go to Settings, and there is an iMessage option.  We turned it off.  So far, it looks like that fixed the problem.

  • maketheswitchanythingbutapple Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 23, 2012 11:30 PM (in response to Literroy)

    Not working for me.  Just bought the Lumia 920 and still can't receive messags from iphone users.  Funny, I was going to buy a few iPads and a Macbook Pro for Christmas presents, but that isn't happening anymore.  Mark my words, in 5 years Apple will be in even worse shape than Microsoft was a little over 5 years ago.  Customers will only take so much abuse.

  • boggin828 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 26, 2012 10:18 PM (in response to modular747)

    Does anyone actually read Apple's terms of use agreements? They are up to 50 pages in length!

  • Smalls75 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 13, 2012 7:38 AM (in response to Literroy)

    Just spoke to Verizon, Who sent me to Apple about this issue. Apple said it’s my fault because I didn't turn off imessage before I deactivated my iPhone.

     

    Their solution: Reactivate my old iPhone, turn off my iMessage, and then have my new phone reactivated again.

     

    Seriously? That’s the solution? They can just click a button and disable it in my account? He also said I should have just bought another iPhone!

  • gullfaraz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 13, 2012 9:56 AM (in response to Literroy)

    did you wipe all data from your i phone there is the know bug that even if you did the iphone will still be found and recive your i messages.

     

    social media news

  • benwiz Level 1 Level 1 (0 points)

    What about group texts? My problem lies therein while normal texting works (so does normal group texting).

  • Ray Earley Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 26, 2012 8:38 PM (in response to Literroy)

    Switching off iMessage on the old iPhone worked for us. My son just got a galaxy s3 and messages to him from iPhone were still going to iPhone after it was deactivated. He switched off iMessage and texts started going to s3. One key may be that it still had a SIMM card in it. If you moved SIMM card to new phone, you may have to move it back to iPhone to disable iMessage then move it back to android phone.

  • Arelunde Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 31, 2012 3:28 PM (in response to Literroy)

    This isn't a permanent solution, but it does work...

     

    When you send an iMessage to a known Android (owned by a former iPhone person), RIGHT AFTER you touch "send" press and hold the message text. An option will appear to send as an SMS. Then, it will go to the Android as a regular text and this will continue until there's a pause in the conversation. If some time goes by, iMessage will re-activate and you have to do this sequence again.

     

    I tried deleting the @me email address from the other person's contact info. Helped briefly. The other person's phone has been totally reset and STILL the problem persists. PITA.

  • 7modesto7 Level 1 Level 1 (0 points)

    For some reason this does not work for me...

     

    My situation is:

    - I lost my iphone

    - I deactivated it via find my iphone.

    - I bought an android phone

     

    Now I have tried the steps to deregister the iphone using the steps provided by Alphonsusjude.

     

    I do get an "x" next to the iphone I want to deregister (interestingly the other devices just have a ">" next to them. I click it buit nothing happens.

     

    There is no "unregister" button or link.

     

    There is a "save" button. I tried clicking this but I get the error message: "We're sorry, your request can't be completed. Please try again."

     

    I have tried so many times from various web browsers on MAC, PC, and IOS platforms over the past few weeks... It is still not working.

     

    Another thing of note is that I am in Australia and the support profile web site is only for certain countries (not including Australia). For other countries it says:

     

    "Other Countries

    If your country is not listed, support is not currently offered through My Support Profile."

     

    I tried calling Apple support and they didn't know what I was talking about at first. They then told me to send a message to all my iphone using friends to do some vague set of steps similar to some other solutions in this thread... which I have no real faith in working permanently. A couple of my friends have follow it with mixed results.

     

    Has anybody got a real solution? Apple? Anyone?

     

    Does anyone from Apple even look at these forums? Do they even give a $%&#?

  • jape330 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 9, 2013 12:19 PM (in response to 7modesto7)

    I've just changed from Crapple iStone to a Galaxy Note 2, and had all the problems described with imessage hijacking my number.

     

    I worked through ALL the suggestions above, in order, and it seems that I have now freed my number from imessage. Thank god.

     

    Honestly, I've been an Apple fan for 20 years, and myself and the family still have iMac's, iPads etc etc, but I'm rapidly going off the brand. It seems to be becoming the new Microsoft...i.e. all about the profit and very little about the consumer.

     

    Simply put, there are a number of great products out there that are starting to put Apple in the shade. Issues like this, and then blaming the consumer for not reading 40 pages of dense text in the user agreement really alienates people, and they will move on.

     

    I won't buy another iPhone. There is life beyond Apple!

  • WozzaX Level 1 Level 1 (15 points)
    Currently Being Moderated
    Jan 12, 2013 1:01 PM (in response to Literroy)

    I think I have the full solution but does require you access to an iPhone (old or friends). I used my wifes.

     

    Grab a friends (wife) iphone.

    Log them out of iMessage (facetime as well if you want).

    I also logged out of my iMessage and Facetime on iMac and iPad just incase.

    Log in as you on the iPhone.

    Then turn iMessage (and facetime) Off. Leave it for a few minutes then reboot the phone still with it off.

    Log into your Apple Account via a website.

    Reset your Apple ID Password.

    On the iPhone turn on iMessage.

    It may look like its activated but it shouldnt cos the password has changed. just go into recievers and sign out and log back in as the original iphone owners account.

    Done.

    When I logged back in again on iPad and Mac my mobile number was missing. Hurrah.

  • 7modesto7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 12, 2013 7:08 PM (in response to WozzaX)

    Great, thanks this worked for me too!

     

    I did have to guess what you meant about a couple of steps. eg by login on the phone i guess this meant into icloud.  To be sure i also logged in to itunes but I do wonder if that step was necessary.

     

    Also for "just go back into receivers..." I assumed again it meant to log into iCloud.

     

    At first it looked like the number was still register because my girlfriends phone still wanted to send iMessages to my mobile. I deleted the whole conversation on her phone and now it just sends SMS.

     

    My number also now does not appear as an address in imessage on my ipad and I was happy to confirm that when I tried to send an iMessage from my ipad it told me that the number is not registered!

     

    Thanks wozzax.

  • Tymeytyrone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 17, 2013 12:50 PM (in response to leah clark)

    This link worked for me, I switched from my iphone4 to a galaxy s3. Once I clicked the link I unregistered my iPhone then I powered off both my iPhone and my Samsung and only then did it stop sending my text messages to my iPhone

    Thanks!!!

  • coocooconor Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2013 10:57 AM (in response to Tymeytyrone)

    My Dad receives my Mom's and sister's messages. My sister received my brothers messages.  They are all on the same family plan.  I am on a different plan altogether, but none of them receive my messages, so long as I have imessage turned on (eventhough it says "delivered")

     

    What on earth is going that so many people have this problem and Apple isn't doing anything.

     

    On my dad's phone, under Send and Receive in the messages settings, it has 4 phone numbers (his, mom's, brother's, sister's). I have tried and tried but cannot remove these phone numbers. They are just greyed out and nothing can be done with them. Does anyone know a way to just reset this Send and Receive setting, so it is just his phone number? I've tried the suggestions, but none work so far. Thanks.

  • jessicajkeo Level 1 Level 1 (0 points)

    i have done what you said but i can nott see edit product?? x

1 ... 3 4 5 6 7 ... 9 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (13)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.