Skip navigation

Major UI Lag in Logic Pro 9.1.7 on OS 10.8?

65145 Views 888 Replies Latest reply: Mar 31, 2014 1:50 PM by The Art Of Sound RSS Branched to a new discussion.
  • Nusskappe Calculating status...
    Currently Being Moderated
    Jan 12, 2013 1:57 AM (in response to Mark Lindsey)

    Dear apple, today is the 12th Januar 2013 and still no fix. Pls give the community a hint if you will ever fix our problem.

  • Saiuns Calculating status...
    Currently Being Moderated
    Jan 12, 2013 5:26 AM (in response to Saiuns)

    Ok, i've said the fix from nick 235 did it for me. But now its the same old again. Verry laggy UI. It's as if OSX is using the xtra resources, created by dissabling mission control, for something else again. While when I first dissabled it, the resources came free for Logic.

     

    ...

  • Fredo Viola Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jan 12, 2013 5:28 AM (in response to Saiuns)

    It'a a Core Audio Mountain Lion (and Lion) issue.  Unfortunately we have to just wait for the next Mountain Lion update which will fix it.  Or at least that's what I've been told.  The update is expectd no later than February.  Again, all this is what I was told by somebody very high up in the Logic Pro team.

  • gen_ Level 2 Level 2 (335 points)
    Currently Being Moderated
    Jan 12, 2013 9:32 AM (in response to Fredo Viola)

    Seeing how the issues on Lion were only (mostly, some people still have issues) fixed with the arrival of 9.1.8, well after ML arrived, I would'nt hold my breath on that. Judging by the constantly degrading performance of Logic on newer versions of OSX, I'm starting to think we may be experiencing a new form of planned obsolescence in preperation for Logic X.

     

    Logic 8 still runs more far more tracks on Leopard than Lion does on the same hardware, and I'm starting to notice that I'm hitting the CPU ceiling a lot faster than before. Wether that's due to updated VI's munching more cycles or something I don't know, but this time last year I could run 50 track comps on my SL Mac Mini (2.4Ghz C2D) and now I'm getting occasional dropouts on my Lion Pro 3,1 (Xeon Quad) on the same projects that I've just had to pull up... it really doesnt look good in front of a client to have your hardware dropping out so I might have to bite the bullet and buy a new Pro... or consider a used Nehalem one.

  • WindowsME Calculating status...
    Currently Being Moderated
    Jan 12, 2013 2:08 PM (in response to gen_)

    gen_ wrote:

     

    Seeing how the issues on Lion were only (mostly, some people still have issues) fixed with the arrival of 9.1.8, well after ML arrived, I would'nt hold my breath on that. Judging by the constantly degrading performance of Logic on newer versions of OSX, I'm starting to think we may be experiencing a new form of planned obsolescence in preperation for Logic X.

     

    A Logic X, now LOGIX!!!! 

    With a completely new redesigned interfaced (we twisted everything around again). With even better bugs.

    Our oustanding forum support with the same lack of solutions and as always your very same developer team doing your life easier...

     

     

    Sincerely,

     

    Your Logix Team (fancy name, isn't it?)

     

    ;-)

    ---

     

    I couldn't resist. If I have to make a prediction based what I experienced on the last 10 years would be something like that...

    I still want to believe it hasn't happened.

     

    Gen, what you've pointed out there, if true, would be completely irresponsible for any company in the world to do, so I think we must keep an eye on that...

     

    Many app developers make use of long beta testings in order to check problems as much as they can prior to release. They usually depend only on that software. Here is the opposite...

     

    They release it and we, in the forums, try to find solutions to the problems. When we solve them they release a newer version so we can start over again...

     

    In the meantime, we are allowed to compose...

     

    "It'a a Core Audio Mountain Lion (and Lion) issue". Fredo, do you remeber the date of Lion release?

    From Lion to Mountain got even worse...why should be different?

     

    Guys I ask you a question: if you go to a doctor, pay for his services because he is suppose to know what he is doing. And the prescription he gives you makes you ill and you loose time and job or money because you can't work properly, what would happen?

     

    What would you do?

     

    Would you study medicine and try to help him find your cure and be understanding for a whole year or ...?

     

    I'm starting to think that from time to time support team guys do write here but under pseudonims trying to calm everybody!

     

    In respect for others, I promise to refrain myself here from predicting what's going to happen unless I have hard proof of it. If I find any solution I'll share it otherwise I won't make any noise as I understand and respect how p... off is everybody here with this matter...

     

    BTW, Happy New Year!

  • WindowsME Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 17, 2013 1:30 PM (in response to gen_)

    https://discussions.apple.com/thread/3191083?start=120&tstart=0

     

    Also this post now has over 4000 views and no word from Apple?

     

    ----

     

    One question, what's your graphics card guys?

     

    This is mine:

     

    MacBook Pro

    17-inch, Mid 2010

    Processor  2.66 GHz Intel Core i7

    Graphics  NVIDIA GeForce GT 330M 512 MB

     

    ...

     

    BTW, My last post didn't get through. Weird...

    You'll have to see it online...

  • Nicolas Stenberg-Daniil Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 17, 2013 1:49 PM (in response to WindowsME)

    It's funny. Cuz now that I have a much more powerful iMac, it's not working as hard anymore, but the problem still occurs when opening LFOTool for example...

     

    Tired of it all. It has ruined my workflow and interest of making music since the beginning of August 2012.

  • Steven W Ross Calculating status...
    Currently Being Moderated
    Jan 17, 2013 2:43 PM (in response to Mark Lindsey)

    I'm on an 8-core with 16 Gigs of RAM. Logic was reliable until 10.8.n.  Since some (not sure) point, recenty, it's been getting increasingly unusable.  

     

    I've got to think there are designers, prop support people at the company who are following and reviewing these posts.  i have open cases for garbage type on certain sections (i.e., mail) the iCloud, iTunes Match craziness (error 4002) and it's kind of troubling.  Frankly, I'm mortified for Apple.

     

    Back to this issue... Is anyone getting the KB "space bar" lag / delay on another key? on a USB keybaord?  At times when there are no plugins open on the desktop - on the main display or a second display?  Do you use Waves plugins?  Version 9?   Is this problem more likely to happen, or does it happen exclusively with certain plug-ins?

     

    I began to notice this "lag, delay, in the play / pause transport a few months ago, and at first I thought / felt it was connected to USB, keyboard, mouse, track ball, etc.  I thought maybe the control surafce area. 

     

    It only happens (to me) when I open a plug-in and then try to stop-rewind in order to hear the changes I've made. I'll have ot wait for the "tape" to stop.  I'll click a few tiems and then relaize it's not going to happen, and best to wait.  And then it stops, sometimes the locator line goes to the beginnng of the track.  Without touching a control in a plug-in it has not happened.  I wondered if it was Waves V9 (anyone?)   I dont use too many of Logic's plugins, but I can't think of an occrence where it happened with the channel EQ open- although it may have. Same with Space Designer, Locig's reverb or delay.  I don't remember if it does.  

     

    I have used Superior Drummer, and not sure if it ever happened while playing in that virtual instrument, or maybe the ES or another Logic instrument.  Anyone?  

     

    But now there are other crazier problems, and every time I open up a session, I'm finding bizarre changes that iI cannot determie how or why they've happeend.     

     

    I can look for or start another thread - about  behaviour that for is MUCH MORE TROUBLING.  But I'll ask here 'cause I'm curious. Has anyone else experinced the following...

     

    Tracks that contain audio clips or regions, or ven tracks, that were imported in any number of ways from the media pull down, the finder, the bin, (WAVE, CAF, AIF) that used to play back - as other regions do, but are now silent.  They can played in the Finder.  They are silent in the browser though, as well as the Sample editor. 

    Dragging them from the original track to a new track allows them to playback.  I had to make a separate tracks for a reverse cymbal crash alone.  I have one song in which I had to create new tracks four times. One is drum fills, while the rest of the loops play fine.  It's crasy!

     

    I have seen Aux busses (sends / returns) become reassigned from a buss to an input.  For no reason.  I now need to check every session I open to check the aux return channels.

     

    I have even seen an audio track on which there is no Channel Inspector on its left side.  Intead it "says" it's being "Controlled by Track 19" which happens to be a MIDI track. A new track createed, dragging the contents to it, with the Automation data, works.  But Why??

     

    These types of behaviours are all happening on more than one song / Logic 9 session file. Actually I have a radii spot in which I reuse the music bad (going back several years) in which certain guitar tracks go away and I have to move parts, create new tracks, even MIDI or audio drum tracks, individual clips / regions where audio didappears.  No mutes.  They appear normal. and all "play" in the Finder.

     

    I also use Cubase.  There were some rough periods with 6 and 6.5 - audio dropouts, system resources, VST quirks, but 7 is stable.  Unfortunately for me I have six songs I started a while back, I'm almost finished working with, mixing and I'm stuck. 

     

    To summarize, I've seen Logic 9 go from ok to difficut to virtually unusable in the last year.  By the way, this is 10.8.2 OS.  For commerical use it's a joke.  I made the Final Cut change, and it's gotten better.  It's not fully professional but I'm in an area where my clients won't pay for real TV spots, and i'm having fun and affordable-  or I'd go back in to the city where the ost houses are dying.  Not sure what Logic X will be, and I'm sure I'll break down and give it a try.  But Logic 9 is not working in the way it was.  I produced two albums using it, a flm score and countless spots and soundtracks. I could not do that today.  And could not imagine starting a new project in Logic 9.

     

    Can it be plugons?  OS X 10.8.2?  USB?  Anyone? Sorry for long windedness.

  • gen_ Level 2 Level 2 (335 points)
    Currently Being Moderated
    Jan 17, 2013 3:04 PM (in response to Steven W Ross)

    I have had this problem on Lion and Snow Leopard. It's another one of those weird Logic bugs that happens randomly, you find a way around then try your best to ignore. What fixed it for me rearranging my tracks so that all my audio tracks are in a row then highlighting them all, hitting "Make Folder" then undoing that. The audio then works fine until you try to move audio regions again whcih makes it drop out.

     

     

    I havent't had it in quite a while but interestingly it only happened to projects which I was finished with creatively and was probably in the mixing/touch-up stage of production. That could suggest that it was a plug-in based problem as there are certain inserts like iZotope Ozone that I rarely use before the mixing stage... but I really don't know for sure.

  • Pancenter Level 5 Level 5 (7,505 points)
    Currently Being Moderated
    Jan 17, 2013 3:35 PM (in response to Steven W Ross)

    No real answer for you but Apple's recent operating systems must be the least efficient OS available on modern computers. I installed an upgrade to 10.8.2 (from 10.6.8) on a client's machine and saw a decrease of nearly 30% in Logic's performance, some previous projects were not playable without processor spikes/overloads. Last I spoke with him he wants to go back to Snow Leopard.  (This was running Logic 9.1.6)

     

    I also use Cubase (6.5) on a PC for commercial work and Logic for my own stuff, after seeing all the recent horror stories I'm sticking with 10.6.8 and Logic 9.1.3 which has been trouble free.

  • -mark- Calculating status...
    Currently Being Moderated
    Jan 17, 2013 3:48 PM (in response to Pancenter)

    Stay away from the 10.8 and stick to Snow with the 9.1.3. Logic and Apple have completely lost control of this problem. I’m totally screwed because I own a nice shiny new Retina Macbook that cannot use Snow Leopard and it’s the only Mac I ownL. So thanks again Apple Logic and goodbye… This has all been a blessing in disguise. Being forced to use Ableton Live has been a great experience and I’m getting more done with it than I ever did with Logic. I can do everything I need. It’s just different.

  • Steven W Ross Level 1 Level 1 (45 points)
    Currently Being Moderated
    Jan 17, 2013 3:55 PM (in response to Mark Lindsey)

    Hello.  As I see these subsequent posts, i am thinking -  THIS IS (part of the reason) WHY APPLE'S STOCK IS IN THE TOILET. 

  • fluffy Calculating status...
    Currently Being Moderated
    Jan 17, 2013 4:02 PM (in response to Steven W Ross)

    $502.68 is "in the toilet?" Sure, it's lower than it was a few months ago, but I sure wish I still had the 40 shares I bought back when it was $25...

  • Steven W Ross Level 1 Level 1 (45 points)
    Currently Being Moderated
    Jan 17, 2013 4:19 PM (in response to Mark Lindsey)

    Fluffy,  yeah I guess you're right.  "one man's ceiling is another man's floor." anyway, I'm not sure what that comment had to w this discussion.  I take it back.  Let's stick to helping each other deal with Logic, OS X and maybe helping Apple to help us, who're suffering with thier inability to get what should be progress and evolution to work for those of us who've invested into the stuff. 

  • gen_ Level 2 Level 2 (335 points)
    Currently Being Moderated
    Jan 17, 2013 4:23 PM (in response to Steven W Ross)

    Steven, this really illustrates the reason why Apple feels compelled to do nothing about the issues we point out. Even if the stock is something completely unrelated to the issue (Logic probably represents less than 1% of Apples 125bn profits in the bank but most certainly represents a much bigger mindshare than that due to how it fosters the 'for creative - and thus fashion conscious - professionals' image that the iPhone would have never existed without), it's still based on the sales of another big fudge.

     

    The iPhone 5 aka the iPhone 4.2 (4S=4.1). Since Jobs went we got into this iterative mess that sees a new iPhone with no major new features but some more CPU and half an inch more screen and an equally iterative new OS with Facebook/Twitter integration touted as it's great new feature and a massive increase in resource hogging for apparently no reason, as if Lion wasn't bad enough in that department. Sure, every reviewer on the planet will tell us it run's faster, is 'snappier' etc. but none of them actually load up Activity monitor to see just how many GB of RAM OSX uses today compared with before and at what cost.

     

    Seriously, if they gave me the option to kill off all the transparency, shadows, etc etc (already killed Mission Control) infact the whole of Aqua so Lion looked like Leopard I would. I'd actually gut everything that has been added since Leopard except 64bit, the App Store (seeing as there is no real alternative) and ExFAT.

     

    I will may add to that list once I've slept on it. I'm trying really hard to think of something. I would hate to think that the only reason I updated since 10.5 was those two and to support new stuff (HW and Software).

1 ... 27 28 29 30 31 ... 60 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.