5 Replies Latest reply: Jan 31, 2013 7:30 PM by MadMacs0
robroy1937 Level 1 Level 1 (0 points)

On 1/15/2013 update 11 for Java 7 appeared.  I tried to install it on 10.8.2 Mountain Lion.  I ran the installer and it says that installation was successful, but it really doesn't install. Java provides a check to answer the question "do I have Java" and the check shows that it is not installed.  I have tried this several times with both a Safari browser and a Firefox browser -- same negative result.  I worked yesterday for 2 1/2 hours with people at the genius bar of an apple store with negative results, even after reinstalling 10.8.2 and then trying to install Java 7u11.  I sent feedback to Java but so far no response.


MacBook Pro, OS X Mountain Lion (10.8.2), Download; ire-7u11-macosx-x64.dmg
  • 1. Re: Cannot install Java 7 update 11 on 10.8.2
    lkrupp Level 4 Level 4 (3,135 points)

    All I can report is that I also installed the same update and it works just fine running OS X 10.8.2 on my iMac.

  • 2. Re: Cannot install Java 7 update 11 on 10.8.2
    marc265 Level 1 Level 1 (0 points)

    our threads may be related:

     

    https://discussions.apple.com/thread/4729425

     

    I have been unable to get Safari 6.0.2 to use the newly installed Java 7 U 11 update. It does install fine, but Safari simply won't pick it up.

     

    check a couple of things:

     

    1) run a Terminal, and type

    java -version

     

    what does it tell you?

     

    2) Safari Preferences: find and make sure Enable Java is checked

     

    3) System->Java preferences - find and enable the Enable Java in browser check box in one of the panes

     

    4) restart Safari

     

    5) load http://www.h-online.com/security/services/Java-747799.html

    in the boxes, do you see Java is... Missing Plug-in?

    (probably yes is my guess)

     

    5) Safari-> Help -> Installed Plug-ins

    is anything listed for Java?

     

    If java tells you the right version at the command line, but that last 2 items tell you no java, then I think we are seeing the same problem. It's installed and emabled but Safari doesn't care.

  • 3. Re: Cannot install Java 7 update 11 on 10.8.2
    ARELLANOFAMILY Level 1 Level 1 (0 points)

    Folks,

    I've been seeing the same thing. And I have three platforms, iMac, MacBook, and MacBook Pro. And all three have the same result. Needless to say I think I've become an expert on doing OS X clean installs (LOL).

     

    @marc265, I will attempt your process and post my results.

     

    However, this is how it went down for me:

     

    1. I had cleaned installed the OS and began making sure it was patched through Apple. I then began installing Symantec Endpoint Protection (SEPv12) per my work requirements. It could not execute LiveUpdate because it needed Java. I did a Terminal command and as found, no Java installed. OS X offerred to download and install from Apple. I installed and ran the Terminal command (java -version). It now showed Java 6 installed.
    2. SEPv12 updated, problem resolved.
    3. I go to my NAS (WD My Book Live), and I am unable to open directories. Error states Java issue, needs most current version. I check with Apple, and I have most current available (unless I'm unaware of a special link to some download). No updates on App Store. So I go straight to Java. Get teh download 7u11, and execute. It updates and states, "Successful." Reattempted to access directories via Safari located on my NAS, same Java error. I go to Terminal and execute the "java -version" and it state v6!
    4. I tried the Java test (oracle.com site) and it says Plug-In blocked.
    5. I verified Safari and Java settings - No go thus far.
    6. But what is weird is that OS X keeps responding that v6 is installed after I keep reinstalling v7u11.

     

    I hope I didn't loose anyone with my rambling.

     

    /r

    Roy

  • 4. Re: Cannot install Java 7 update 11 on 10.8.2
    Russa Level 4 Level 4 (1,315 points)

    Appears Java still has some vulnerabilities. I'd wait until Oracle figures it out. Apple has been blocking Java installations including version 11. 

  • 5. Re: Cannot install Java 7 update 11 on 10.8.2
    MadMacs0 Level 4 Level 4 (3,735 points)

    ARELLANOFAMILY wrote:

     

    Folks,

    I've been seeing the same thing.

    And you will for awhile longer. Apple blocked browser us of both Java 6 and 7 once again last evening, so you'll have to wait for Oracle to release Java 7u12 now.